Bluetooth drivers for HP-15-Notebook

Asked by Antonio d'Amore on 2017-05-11

Hello, I recently installed Ubuntu 17.04 on my laptop (Computer Informations: HP-15-Notebook, 3.3 Gb Memory, AMD A8-6410 APU Processor with AMD Radeon R5 Graphics × 4; Gallium Graphics 0.4 on AMD MULLINS ( DRM 2.46.0 / 4.8.0-26-generic, LLVM 3.8.1), OS 64-bit), but I've never been able to run the bluetooth.
I ran the Checkbox application and the result was that the bluetooth worked correctly. So I think that a problem exists with drivers. I tried to find a site where download the right ones, but without success. Can anybody help me get out of this hut?
Thank you very much for the attention.

Ansfed

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Antonio d'Amore
Solved:
2017-05-13
Last query:
2017-05-13
Last reply:
2017-05-11

What is the output of:

sudo rfkill list; lsb_release -a; uname -a; dmesg | grep -i blue

Thanks

Antonio d'Amore (20laotzu13) said : #2

0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: brcmwl-0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
2: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 17.04
Release: 17.04
Codename: zesty
Linux ansfed-HP-15-Notebook-PC 4.10.0-20-generic #22-Ubuntu SMP Thu Apr 20 09:22:42 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[ 13.973798] Bluetooth: Core ver 2.22
[ 13.973840] Bluetooth: HCI device and connection manager initialized
[ 13.973846] Bluetooth: HCI socket layer initialized
[ 13.973850] Bluetooth: L2CAP socket layer initialized
[ 13.973860] Bluetooth: SCO socket layer initialized
[ 14.160400] Bluetooth: hci0: BCM: chip id 70
[ 14.176422] Bluetooth: hci0: BCM43142A
[ 14.176429] Bluetooth: hci0: BCM (001.001.011) build 0000
[ 14.231707] bluetooth hci0: Direct firmware load for brcm/BCM.hcd failed with error -2
[ 14.231714] Bluetooth: hci0: BCM: Patch brcm/BCM.hcd not found
[ 16.249855] Bluetooth: hci0 command 0x1003 tx timeout
[ 25.881285] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 25.881288] Bluetooth: BNEP filters: protocol multicast
[ 25.881293] Bluetooth: BNEP socket layer initialized
[ 54.766096] Bluetooth: RFCOMM TTY layer initialized
[ 54.766115] Bluetooth: RFCOMM socket layer initialized
[ 54.766128] Bluetooth: RFCOMM ver 1.11

OK, use the web to see what the BCM.hcd file error is about

Seems the file needs to go into /lib/firmware/brcm

Jeremy (wa113y3s) said : #5

https://askubuntu.com/a/632348/300665
Will give you an idea on how to use a windows driver file to find the firmware hex file and convert it to the hcd file needed by Linux

Antonio d'Amore (20laotzu13) said : #6

Many thanks Jeremy, I feel that I'll solve the problem!

Let me summarize the steps I followed.

First, I downloaded Broadcom drivers for Windows 8 from the following link (http://drivers.softpedia.com/get/BLUETOOTH/Broadcom/ASUS-X99-DELUXE-Broadcom-Bluetooth-Driver-6515800-12009860.shtml#download). Then I opened the file by Archive Manager and found the bcbtums.inf located at Win64 directory. Then I searched the file for VID_0A5C&PID_216c. These numbers are from my lsusb output. Then I sow the file BCM43142A0_001.001.011.0197.0231.hex.

At this point I should extract the file, but I do not know how to do it. Can you help me please?

Jeremy (wa113y3s) said : #7

You may need to extract everything and then find the BCM43142A0_001.001.011.0197.0231.hex file and copy it into the hex2hcd folder. If you haven't used git or compiled anything you will need to install a few things

sudo apt-get install git build-essential

Then you can install hex2hcd

Antonio d'Amore (20laotzu13) said : #8

I did everything as recommended in the guide (https://askubuntu.com/a/632348/300665) and everything you suggested to me, but bluetooth still doesn't work. I can see both the files (BCM43142A0_001.001.011.0197.0231.hex and BCM43142A0-0a5c-216c.hcd) on the Home directory, but I'm not sure that the .hcd file went into the right directory (that is /lib/firmware/brcm).
Do you suggest a way to verify this?
Thanks to you, I feel I'm very near to the solution of my problem!!!

Jeremy (wa113y3s) said : #9

Try this command, it is one line, then reboot

sudo cp /lib/firmware/brcm/BCM43142A0-0a5c-216c.hcd /lib/firmware/brcm/BCM.hcd

Antonio d'Amore (20laotzu13) said : #10

Great Jeremy you solved my problem. I'm very happy!! I am infinitely grateful to you.