Problem booting after resent update on Ubuntu 8.10

Asked by mrlopes on 2009-03-04

I'm using Ubuntu 8.10 fully updated and it was running well until i done an update a few days ago.

I was asked to restart after update so i did and now it won't boot up. It stops just before the login screen. The screen just goes black and nothing happens.

I don't know what to do.

I've press ESC on the GRUB screen and i have tried RECOVER MODE but no luck. If i choose a OS lower in the list it boots up ok and i can get to my desktop.

I really ain't got a clue what to do.

Please help!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
mrlopes
Solved:
2009-07-24
Last query:
2009-07-24
Last reply:
2009-03-05
peter b (b1pete) said : #1

just post here output of

fdisk -l

l is lower L; we need to see whether other linux distros are installed (you say 'If i choose a OS lower in the list it boots up ok and i can get to my desktop' BUT do not tell us if it is a linux install)

if you CAN BOOT UP a linux distro OR you have available a ubuntu live CD or alternate CD then things are quite easy.

basically, you have to invoke grub in a terminal or a console if using alternate CD; once you got a grub prompt like

grub> <cursor>

then

find /boot/grub/stage1

will output something like

(hdx,y)

where x is HD number -starts at 0 (zero) and y is part number then

root (hdx,y)

and

setup (hdx,y)

IF grub installed to PBR; if grub installed to MBR then

setup (hd0)

some output will tell you if it succeeded; if yes then

quit

and reboot - you should be able to boot into your linux.

peter b

mrlopes (mrlopes) said : #2

Hi...
Many thanks for your reply although it is a bit too technical for me.

Yes the other OS's in the list are all Ubuntu 8.10 Kernel.

Please could you tell me in really simple step.

Thanks for your time Peter

peter b (b1pete) said : #3

then just boot into a kernel and open a terminal, invoke grub as mentioned above and do

find /boot/grub/stage1

pls post output here; also copy/paste the contents of

menu.lst

file - it is located in /boot/grub (l above is lower L)

I or somebody else will pick it up from there.

peter b

mrlopes (mrlopes) said : #4

i re-installed ubuntu