Mount CD-ROM failes during installation

Asked by mike2006

I can't install Ubuntu, I tried release Draper flight 5. I have read some other unanswering threats in the forums which lead me to believe it might occur on Ubuntu Breezy too.

It comes up with the error: " Your installation CD-ROM could not be mounted. This probably means that the CD-ROM was not in the drive."

I have burned the disk slowly and more than once. I managed to copy the entire disks contents onto the computers harddrive in windows without problems:

When using Check CD for defects the following comes up: (On the same screen it happens with the installer)

( Process:1970):Mount: Mounting /dev/cdroms/cdrom0 on cdrom failed
(Process:1970): Invalid Argument

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
edmond1866 (edmond1866) said :

Pardon my English =)
I have encountered the same error as yours when I tried to install Breezy.
My fix was laying down the computer so the CD drive is placed horizontally (it was vertically mounted).
If this doesn’t work, maybe you should try another CD-ROM.
Hope this help!

Revision history for this message
Bajtalan Hunor (cerebellum) said :


Try first what edmond1866 said but I think you should write at a faster speed your cd's. Probably that is the problem.

If your problem persist than order a pack of entirely free ubuntu cd's from

Revision history for this message
Matthew Lange (matthewlange) said :

I would try re-downloading the source file from the server and try burning again.

Revision history for this message
John (brownbom) said :

I am having a similar problem with all 5 Live CD's sent to me by mail. Ubuntu accepts keyboard, country, etc then before commencing the install it tells me my drive has an error, after loading up to that point. I wish to try Live CD before doing a full install.
Error message is "files can not be read from CD".
I am running a P4 with 2Gb RAM and using a BenQ DVD r/w drive that has absolutely no problems with any other CD/DVD I have put in it.

Any clues?

Revision history for this message
cosmo (stonemonkey77ro) said :


I have the same problem ("[!!] Detect an mount CD-ROM - Your installation CD-ROM could not be mounted. This probably means that the CD-ROM was not in the drive. [...]") installing server edition of Ubuntu just downloaded from ubuntu site (this week) on an old IBM PC P3 and it happends also with Debian Sarge an older revision I think is r2. I also tried to install desktop edition of Ubuntu and it can not pass "Mounting root file system ..." operation, I get "<x>.<y> Buffer I/O error on device hdc, logical block z", x,y,z have diferent values.

I see that the comments/answers from this questios are quite old. I hope somebody found a solution until now, maybe can help me?


Revision history for this message
Andi from germany (andreas-kirchgaessner) said :

Dear all,

I yust loaded the actual STUDIO Version and have the same problem. Booting from DVD-ROM (LG) works, but installation runs into a error message " CDROM can not be mounted".
This happens on a DELL Laptop as well (NEC-DVD-Rom).
All this is independent from burningspeed.
Was found some solution to this yet?

Beside that, there is a deadlock when performing the CD-ROM failure test from start menue. If the CDRom is not mountable as it is actually, then the system circles around the error message and the HW-detection and there is no way to regret to the main menue for stop the installation and reboot "softly".
OK, a ctrl-alt-del kills the appl and reboots.... .

Alternatively I loaded the intrepid-alternate-i386-Version .
It seems to work because I could proceed the installation.
Now I first make a system backup of my old partition until going an.

Can you help with this problem?

Provide an answer of your own, or ask mike2006 for more information if necessary.

To post a message you must log in.