D-MAX STK-1135 built-in webcam with Asus F3S laptop?

Asked by george_rutkay on 2009-03-01

Are there any drivers available to allow this webcam to work under Ubuntu 8.10?


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
george_rutkay (yaktur) said : #1

More info: lsusb reveals:
Bus 003 Device 002: ID 174f:6a31 Syntek Web Cam - Asus A8J, F3S, F5R, VX2S, V1S


You can find information on webcams and how to attempt to get them working at https://help.ubuntu.com/community/Webcam

Can you try the instructions on that page and if you have any more problems post a reply here and someone may be able to help you further.


george_rutkay (yaktur) said : #3

Ok, I'm following it's directions.

When I type in ls /dev/video* I get:
ls: cannot access /dev/video*: No such file or directory.

When I try to use Ekiga to test my webcam (or Camorama) the camera remains undetected by these programs.

Next now I will try to set up Easycam and see if it can recognize this apparently Windows-only webcam. I'll post results here.

george_rutkay (yaktur) said : #4

Alright, this is what has failed when I try to compile EasyCam:

root@phillip-laptop:~# gksudo 'python /usr/share/EasyCam2/core.py --gtk'
GO !
ln: creating symbolic link `/lib/modules/2.6.27-11-generic/build/include/linux/config.h': File exists
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-headers-2.6.27-11-generic is already the newest version.
The following packages were automatically installed and are no longer required:
  tango-icon-theme ubuntustudio-sounds
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
rm -f *.o *.ko .*.o.d *~ .stk11xx*.cmd *.mod.c
rm -rf stk11xx-0.42 .tmp_versions
rm -f stk11xx-0.42.tar.bz2
make -C /lib/modules/2.6.27-11-generic/build SUBDIRS=/usr/share/EasyCam2/drivers/syntek modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.27-11-generic'
  CC [M] /usr/share/EasyCam2/drivers/syntek/stk11xx-usb.o
/usr/share/EasyCam2/drivers/syntek/stk11xx-usb.c: In function ‘usb_stk11xx_probe’:
/usr/share/EasyCam2/drivers/syntek/stk11xx-usb.c:807: error: implicit declaration of function ‘PAGE_ALIGN’
make[2]: *** [/usr/share/EasyCam2/drivers/syntek/stk11xx-usb.o] Error 1
make[1]: *** [_module_/usr/share/EasyCam2/drivers/syntek] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-11-generic'
make: *** [all] Error 2
mkdir -p /lib/modules/2.6.27-11-generic/kernel/drivers/usb/media
install -m 644 -o 0 -g 0 stk11xx.ko /lib/modules/2.6.27-11-generic/kernel/drivers/usb/media
install: cannot stat `stk11xx.ko': No such file or directory
make: *** [install] Error 1
FATAL: Module stk11xx not found.

george_rutkay (yaktur) said : #5

What on earth do I do now?? Help!!!

george_rutkay (yaktur) said : #6

I also tried plugging in a Microsoft VX-1000 webcam, reboot the computer and rerun EasyCam. No luck, same thing, not recognized.

Same with Camorama and Ekiga, they do not recognize this VX-1000 webcam.

What can I do now? I have to return this laptop today.

george_rutkay (yaktur) said : #7

When I try to launch Camorama, I immediately get error message:

"Could not connect to video device (/dev/video0). Please check connection."

This happens whether I'm trying the Microsoft VX-1000 or the built-in webcam on this laptop.


george_rutkay (yaktur) said : #8

I think I found why this isn't working, it appears I'm not the only one who has struggled with this.