can't install deb files

Asked by Neil on 2017-04-20

Hi all
I just installed 17.04 but software centre wont in stall deb files any fix please.
thank you
Neil

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2017-04-23
Last reply:
2017-04-24

How are you trying to install them?
What messages do you see?

We can't see your system. You tell us the symptoms but not anything useful like error messages and the like.

We can't see your system. You need to fill us in

Manfred Hampl (m-hampl) said : #2

Have you tried installing via command line, e.g. with the command

sudo dpkg --install directory/filename.deb

Neil (goofandfroggie) said : #3

Hi again
if I double click it will open software centre but if I click in install nothing happens..

I tried this command again open but nothing happens on clicking install. sudo dpkg --install

Thanks

Manfred Hampl (m-hampl) said : #4

What happened when you executed the command

sudo dpkg --install directory/filename.deb

(of course with directory/filename.deb replaced by the real file name and directory, if applicable, of your .deb file)?

Neil (goofandfroggie) said : #5

Hi Manfred
Yes I did that just opens software centre nothing more. I can use gdebi okay but not other to install the bug must be back this happen about 15.10 I think it was
thanks
Neil

Manfred Hampl (m-hampl) said : #6

Why should the command "sudo dpkg --install ..." open software center?
That is absurd.

Manfred Hampl (m-hampl) said : #7

There is a known bug in gnome-software. Maybe you are hitting this one (although you always write about software center)

see Bug #1672424 and comment 8 for a workaround (use absolute paths) that might help.

Neil (goofandfroggie) said : #8

Yes opening software centre is strange.but
this is the command I put in

sudo dpkg --install ..'/home/goof/Desktop/ubuntu-tweak_0.8.7-1-getdeb2-xenial_all.deb'

open it.. it does

Manfred Hampl (m-hampl) said : #9

The filename ..'/home/goof/Desktop/ubuntu-tweak_0.8.7-1-getdeb2-xenial_all.deb' is weird.
try

sudo dpkg --install /home/goof/Desktop/ubuntu-tweak_0.8.7-1-getdeb2-xenial_all.deb
and/or
gnome-software --local-filename=/home/goof/Desktop/ubuntu-tweak_0.8.7-1-getdeb2-xenial_all.deb

There is even a completely different approach for ubuntu-tweak by adding a PPA to your list of repository sources:
Create a file in the /etc/apt/sources.list.d directory with the contents

deb http://ppa.launchpad.net/tualatrix/ppa/ubuntu trusty main

(Notes: trusty is the last release for which a version of ubuntu-tweak was published. Hence the codename trusty in that line instead of zesty. This approach will provide 0.8.8-1 instead of 0.8.7-1 like your download.)

Can you help with this problem?

Provide an answer of your own, or ask Neil for more information if necessary.

To post a message you must log in.