My "deleted items folder" won't empty

Asked by Ampers on 2009-02-22

A lot of the answers above seem to concern Evolution. I don't use Evolution.

My "Deleted Items Folder" is full and when I try to delete the 6,305 items (totalling 425.6 MBs) not one file will delete.

No problem at the moment but what am I going to do when this reaches 348,274,190,234,045,386 items totaling 1,5 terrabytes?

Ampers

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Michael
Solved:
2009-02-28
Last query:
2009-02-28
Last reply:
2009-02-28
peter (peter-neuweiler) said : #1

Hi Ampers

What kind of mail server do you use?
Peter

Ampers (ampers) said : #2

Don't use a mail server.

I am a GMail user and prefer to access it directly from the Website. I tried Evolution and also Thunderbird but neither came up to my required standards.

peter (peter-neuweiler) said : #3

Hi Ampers

The question was not What kind of mail server do you use, but the question was: what kind of mail client do you use?

So, I guess, you don't need a Mail client. You work directly with the web site gmail.com. If you can't delete the files in the Trash on your web server gmail.com, this will be a problem of gmail.

Hope you can find an answer here.
Peter

peter (peter-neuweiler) said : #4

And if you are going to use a Mail client, try Thunderbird. It's very simpel to delete files, and it woks.
Peter

Ampers (ampers) said : #5

Ah! I think we are talking at cross purposes here.

I have no problem deleting email files on Google whatsoever.

I am referring to the trash icon at the bottom right of the screen which when you click on it opens up and calls itself Wastebacket.

I think the misunderstanding may have been on my part.

It is there that I cannot delete any of my files, they all seem to be protected but are listed as mine.

Ampers.

peter (peter-neuweiler) said : #6

Do the following:

In Nautilus open the directory .local/share/Trash/files.

There are all the files of the trash. You can delete them in a Terminal.

Hope it helps.
Peter

peter (peter-neuweiler) said : #7

You can delete the files also with Nautilus. I guess, it's much easier.
Peter

peter (peter-neuweiler) said : #8

Maybe this also helps:

Delete the trash in the taskbar. Position the mouse cursor to the place where you are going to place a Trash. Click the right mouse button and click Add to Panel. Choose the Trash and click Add and Close. The Trash will be placed there. Maybe now it works.
Peter

Tom (tom6) said : #9

Perhaps one time when you reboot choose the "Recovery Mode" option and choose to clear some space. It was fantastic on my system and left everything all tidy with all my settings still there and everything :)

Good luck and regards from
Tom :

Tom (tom6) said : #10

Misunderstandings just happen - no-ones fault. We just try to give answers as best we can while still trying to work out which of the many possibilities it could be. Language is wonderfully ambiguous, i'm just glad we don't all talk in maths. So i'm glad i'm not a machine.

Oh btw you know there are only 10 sorts of people in the world? Those that think in binary and those that don't ;) heheheh

Sorry about that old chestnut
Regards from
Tom :)

Ampers (ampers) said : #11

Peter, when I look at trash/files directory following .local, the file is empty?

When I use the ls command on ~/.local/share/Trash/files$ it shows no files.

I deleted the trash icon on the bottom task bar and replaced it.

After doing all this, I still have all the files in my trash.

I am using 8.10 and have a highly spec'd machine with 2GB mem and 1.4TB of hard disk, two core Intel etc

Ampers (ampers) said : #13

I have three 500GB drives in ICY containers and a lot of USB drives. I am not sure if this worked or some of the other suggestions, but now all is well.

Thanks all for your help. It was a nuisance as the folder was getting larger every day.

I have now initiated the delete direct button from Nautilus so this won't happen again. But I have lost the security of being able to use the folder.

Tom (tom6) said : #14

I think it's worth deliberately testing Michael's hypothesis there and if it works then you know what to do in the future. I also think that rebooting but choosing the boot-up grub-menu item for Ubuntu that has "Recovery Mode" at the end gives a "Clear space" option that might clear some of these sorts of problems

Good luck and regards from
Tom :)