eeebuntu: libs in /usr/local not found, have to set LD_LIBRARY_PATH

Asked by markov035 on 2009-02-21

Eeebuntu,

I've installed some soft under /usr/local/, but when I start the app, it can't find the libraries.

I have to set
LD_LIBRARY_PATH

linux-2.6.27-8-eeepc

Thanks!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-02-21
Last reply:
2009-02-21
Lars Ljung (larslj) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs .

Lars Ljung (larslj) said : #2

This is most likely caused by not having an updated ldconfig cache. Please run "sudo ldconfig /usr/local/lib" and see if that resolves the issue.

You can also check that /usr/local/lib is either /etc/ld.so.conf or in one of the files in /etc/ld.so.conf.d/ (should be in /etc/ld.so.conf.d/libc.conf).

Can you help with this problem?

Provide an answer of your own, or ask markov035 for more information if necessary.

To post a message you must log in.