digicel lte ethernet modem

Asked by Adam Albanowicz on 2017-04-13

I am Using Digicel modem. DT-235, LTE 4g Modem. It will not connect in Ethernet or Wireless. Well, It connects but does not connect to anything else, even the other computer, in wireless mode. I know this has to be something with the modem, as in ethernet mode it does not even locate it in Ubuntu. Says Not Controlled. Any ideas of setting I could use to make it work so I can upgrade? Noticed that even the modems in The UK were acting funny so wondering if maybe I have somehow locked up wrong settings and it does not know how to fix them. Not too good with settings but if anyone has any ideas for me to try, other than always using windows to access the internet, please help.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2017-04-25
Last reply:
2017-04-25

If you run:

ping -c 4 8.8.8.8

Do you get replies?

4 packets transmitted, 0 received, 100% packet loss time 3014 ms pipe3

Just to let you know, it has wireless and Ethernet connections enabled, but no joy. No pings getting through either way. Think it is a Digicel Jamaica problem but it could be I screwed up my settings somehow.

If you use the wired connection and run:

sudo dhclient eth0; clear; ifconfig

Do you get an IP address?

Not sure what I should get. Scope link up broadcast running multicast.
Lo .. scope host up loopback running
Neither seems to give me an address. But neither says an error either. In fact, eth0 says packets 82 errors 0 dropped 1 tx 205 errors 0 dropped 0 tx qeuelen 1000

Rx13.1 kb tx 15.0 kb

Ran again with wireless turned on, wlan looks like eth0 and lo, and internet, foxfire, still not connecting.

Manfred Hampl (m-hampl) said : #7

Do you try to connect to that device via WLAN or with an Ethernet cable (or both)?

When you issue the command
ifconfig
what names do you see in the very first column (besides lo).

in teh line below "lo" you will probably see
inet addr:127.0.0.1 Mask:255.0.0.0
Do you see a similar line also below the other interface names?
If yes, what are the values shown in these lines?

Ok, the exact I get is:
RTNETLINK answers:file exists
Eth0 link encap:Ethernet HWaddr 68:f7:28:36:f2:29
           Inet addr:192.168.1.40 Bcast:192.168.1.255 Mask 255:255:255:0
           Inet 6 addr fe80:6af7:28ff:fe36:f229/64 Scope:link Up Broadcast running multicast MTU :1500 metric:1
           Rx packets:159 errors :0 dropped:1 overruns:0 frame:0
           Tx packets:308 errors:0 dropped:0 overruns:0 carrier:0
            Collisions:0. Txqeuelen:1000
            RX bytes :23497 (23.4KB) TX bytes :21041 (21.0 KB)

Lo. Link encap: Local Loopback
            Inet addr:127.0.0.1 Mask:255.0.0.0
            Inet6 addr : ::1/128 Scope:host up loopback running mTU:65536 Metric:1
            Rx packets :737 errors:0 dropped:0 overruns:0 frame:0
             Tx packets :737 errors:0 dropped:0 overruns:0 carrier:0
             Collisions:0 txqeuelen:1
              Rx bytes 59564(59.5 KB). Tx bytes 59564 (59.5 KB)

Wlan0. Link encap:Ethernet. HWaddr ac:b5:7d:75:ce:09
               Inet addr:192.168.100.6 Bcast:192.168.100.255 Mask:255.255.255.0
               Inet6 addr:fe80::aeb5:7dff:fe75:ce09/64 Scope:Link up broadcast running multicast. MTU:1500. Metric :1
               Rx packets:93 errors:0dropped:0 overruns:0 frame:0
               Tax packets:124 errors:0 dropped:0 overruns:0 carrier:0
               Collisions:0 txqeuelen:1000
                Rx bytes :8560 (8.5 KB). Tx bytes 18303 (18.3 KB)

Sorry, but that is all I have. I have plugged it direct, and have run it wireless. Same computer runs windows, and it works both ways in windows. I am also typing this on an iPad at this time, wireless, same modem. It just seems to not work in Linux, and none of our other Digicel modems work in Linux as well.. wondering if I have my Linux configured wrong???

Manfred Hampl (m-hampl) said : #9

Your output shows that there are IP addresses, and that you have sent and received data for both the cable and the wireless connection.

Can you try opening a http connection to the modem device?

Actually, have tried to open it, like I can in Windows, and it does not open. I cannot get aptget to update, nor the other ways to update, and no joy with connecting to internet. Ping does not work, yet this shows it doing something..so, not sure

Manfred Hampl (m-hampl) said : #11

If you execute the command

ip route list

what value do you get behind "default via "?

Is this the same value as the one that you get as "Default Gateway" in the Windows network connection details?

I get into the modem, can see the various processes, and even tried disabling the firewall, but nothing is going right for internet. Tried ping, etc, and still getting packets lost, tried connecting to various sites and get check my internet connection. Go into windows, connect fine. Guess it may have to wait until I can do a new install of ubuntu from scratch and see if everything gets fixed that way in a few months...lol

Manfred Hampl (m-hampl) said : #13

I can only repeat that you should compare the network settings in the (working) Windows system and the (not-working) Ubuntu system.

Can you help with this problem?

Provide an answer of your own, or ask Adam Albanowicz for more information if necessary.

To post a message you must log in.