Passwd does not work

Asked by UberGTI

From the prompt I cannot change a users password using the passwd command.

I created a user: sudo adduser auser [Success]
Tried changing password: sudo passwd auser
            Ubuntu response: passwd: password updated successfully

I was never asked to enter a new password.

I tried: sudo su - auser
Then: passwd

I was asked for a current password: What do I enter? I just created the user, and don't have a password.

Thanks for your help.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
nhasian (nhasian) said :

you can specify a password when creating a user like:

sudo useradd auser -p apassword

you probably want to use the -D option for useradd. This command sets the system defaults for creating the user’s home directory, account expiration date, default group, and command shell. See the specific options in man useradd. Used without any arguments, it displays the defaults for the system. The default set of files for a user are found in /etc/skel.

for more info see man adduser

Revision history for this message
UberGTI (ddalessandro-centennialcollege) said :

Thanks. Unfortunately, that didn't fix my problem.

Revision history for this message
UberGTI (ddalessandro-centennialcollege) said :

Found my problem.

I uninstalled likewise-open and the passwd command works as expected.