b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found or load failed

Asked by dumpa

Hi, I have a Dell inspiron laptop 5150.
I used to have kubuntu and the wireless worked. Now I have Ubuntu and the wireless doesn't work.
When I go to System -> Administration ->]Hardware drivers , and try enable Broadcom B43 wireless driver, nothing happens, it doesn't enable.
I turned off my computer and it showed a message saying I had to go to linuxwireless.com and update a firmware, I didn't had a pen at the moment so didn't get the message right. Something to do with a b43-phy2 error.

I appreciate if someone can help me with this, thanks.


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Ernest Yang
Last query:
Last reply:
Revision history for this message
dumpa (dumpita) said :

I forgot to mention is ubuntu hardy.

Revision history for this message
Best Ernest Yang (ernest-atheros) said :

You can try to upgrade to Ubuntu 8.10, b43 and b43legacy driver may fit your needs.
in Ubuntu 8.10, b43 driver is in-kernel, so it should work fine without problem.
Check website here:http://linuxwireless.org/en/users/Drivers/b43
b43.ko is located in /lib/modules/<kernel-version>kernel/driver/net/wireless after you install Ubuntu 8.10.

Revision history for this message
Bernhard (b.a.koenig) said :
Revision history for this message
Mark Rijckenberg (markrijckenberg) said :


The error "b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found or load failed" should mean that b43-fwcutter is not installed yet on your pc. And that means that the Broadcom firmware for your wireless card is not loaded or installed yet.

Please proceed with the following commands:

sudo aptitude update
sudo aptitude install b43-fwcutter

b43-fwcutter exists in the Ubuntu repositories, but you will need a working Internet connection in Ubuntu in order to locate it and install it.

The only way to do that - in your case - is to connect the pc to the wireless router using a LAN cable, instead of using wireless.

This issue is similar to this one: https://answers.launchpad.net/ubuntu/+source/b43-fwcutter/+question/60355



Revision history for this message
dumpa (dumpita) said :

Thanks to all.
I went to linuxwireless.org and it wall really easy to install the firmware.

Revision history for this message
dumpa (dumpita) said :

Thanks Ernest Yang, that solved my question.