connect windows xp to ubuntu linux

Asked by Olof Carlqvist

Problem to connect windows XP with a linux ubuntu computer.
Connection is done with a wired cable to a router from every PC.
The router has a firewall turned on.

From the ubuntu computer I can ping and see my both windows computer.
One with windows 98 and another one with windows XP.
I can make file transfers from ubuntu to both of the windows PC,

From the windows computers I cannot ping any computer in the network.
I have internet connections from all computer in the network.
From windows 98 I can see all computers in the network and I can transfers files to and from all of them.
In windows XP I can just see the XP computer in the network neighborhoud.

I have had the same problem earlier with the windows 98 PC.
But after changing Vnetsup with regedit I had solved that problem.

I have turned off the firewall in Windows XP so thats not the problem.
I want to connect the windows XP to the other PC

Anybody who have the same problem and know how to sorted it out?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Olof Carlqvist
Last query:
Last reply:
Revision history for this message
nhasian (nhasian) said :

So if i understand you correctly, both your windows XP and Windows 98 computers can see the ubuntu pc just fine and you can transfer files back and forth between both windows computers to and from ubuntu right? so the windows networking (samba) in ubuntu is working fine then right?

and your only problem is getting one windows computer to communicate to the other windows computer?

Revision history for this message
ealthuis (ealthuis) said :

My experience is, that the Linux built in firewall will not let anything in that did no originate from the Linux computer, thus you can get stuff from the Internet and see the other computers but they cannot see LInux. If this is your problem, then on the Linux system go to System>Administration> Synaptic Package Manager, here enter a search for Firestarter. Install Firestarter.
Once Firestarter is installed open it (I cannot tell you where to find it, mine is in the Admin menu), a password will be asked for, use the one you use to log in. In the screen you see then, open the tab Policy click inside the section Allow connections from host, click add rule in the menu bar, then enter the actual IP addresses of the Windows computers in this format ie and click Apply Policy

Do this for each computer you want to access your Linux computer.

You might want to do similar things in the Windows firewalls. If you want more info about that stuff let me know.

Revision history for this message
Olof Carlqvist (jerker-olofpark) said :

Sorry this is not a firewall problem.
Windows 98 and Ubuntu can see and transfer files to and from all computers.
Windows XP cannot but can use the internet.

Windows 98 can see the Ubuntu PC but Windows XP cannot.
Samba is working so Ubuntu can transfer files to and from Windows 98 and Windows XP.
From Windows 98 I can communicate with Windows XP and Ubuntu.
From Windows XP I cannot communicate with Windows 98 or Ubuntu.

Revision history for this message
ealthuis (ealthuis) said :

I am sorry to hear that your problem has not been resolved, unfortunately I do not remember exactly how I made Windows XP read 2 Linux computers, but here is what I currently have. My Windows system can see and open files on each of my Linux 8.10 computers, faster than WXP to WXP which is what I had before my change over to Linux.

WXP is even more fussy than Linux, I also found W98 is not quite as fussy, these are requirements:
File sharing must be set for those files you wish to share
Workgroup must be the same on all computers
Each needs a unique name
Username on each
Passwords for all

On Windows XP go to start>connect to> click on Show all connections
In Network connections click on Create a new connection, Next on the Welcome screen
Select Set up a home or small office network> next and finish, next once again and agian
In the next screen, "Select a connection method" click otherand next
Choose the first item and next, you should now be at the name and description screen, provide name and description then click nextfinally select workgroup name, next and select File and Printer sharing and next once more. Yes to the are you sure question. You will get a screen that lists your setup and a request to apply these settings. click next, please wait...
finally you are almost done choose what you need out of four radio buttons, I selected "just finish..."
Finally "Completing the Network Setup Wizard, click finish and restart the computer.

Now on the desktop you should have an icon My Network places, click that and see what you get, With a bit of luck you will see all of your computers listed. if this is so, click on any computername and provide userid and psw, you should be in the requested computer. If not, go back to the firewalls and see if all is as needed.

After all of this typing which I am not very good at, I sincerely hope this solves the problem for you.
By the way my XP has two firewalls, Windows turned on and another provided by Computer Associates, which is accessible to me, in there I set network rules to allow access by and my other computers.

Revision history for this message
Olof Carlqvist (jerker-olofpark) said :

I have used linux for more then five years and changed from windows 98 to linux.
I am new with Windows XP

Windows XP has no firewall turned on.

File sharing must be set for those files you wish to share
Workgroup must be the same on all computers
Each needs a unique name
Username on each
Passwords for all

All this with same Workgroup, username and password.

On Windows XP go to start>connect to> click on Show all connections
Start > my network places > view workgroup computers
and I get the answer:
“WORKGROUP is not accessible. You might not have permission to use this network resource.
Contact the administrator of this server to find out if you have access permissions.
The account is not authorized to log in from this station.”

When I look at the workgroup name i Windows XP it is “WORKGROUP”
In all other computer the workgroup is “workgroup”

Looks like a possible solution.
But I want to have “workgroup” and not “WORKGROUP”
How can I change that in Windows XP?

Revision history for this message
ealthuis (ealthuis) said :

Right now I have no answer, I don't think I have ever been told I have no permissions. The problem lies with XP, Tell me more on how you installed XP, are you the only user, does XP ask for a password when you start it etc.

 I would search Microsoft for the permissions question.

I am sorry I can't do better, by the way I tried to change the workgroup name to lower case, XP insisted on upper case.

I will continue to look for an answer, keep in touch


Revision history for this message
Olof Carlqvist (jerker-olofpark) said :

Yes the problem lies with XP.
It is an old version of XP (version 5.1) which I have tried to connect to network before without success. I installed it as a virtual XP in ubuntu and liked it.
As a virtual XP there are no problem with the network.
After that I tried a real installation again and decided to try to sort out the problem.

I am the only user with the same username and password as on other computers.

If You have the same problem with lower cases in XP.
Do You have only upper case in your workgroup name?

Revision history for this message
ealthuis (ealthuis) said :

No my workgroup is all in lower case. When I look at "System" in control panel I find uppercase and I can't change that. Try this: go to control panel, click on user accounts and see how you are recorded there, it should be administrator, I am and have no "permission " problems. In the meantime, I will continue to search for the answer.

My XP is Home edition, version 2002, Service pack 3

I find it interesting that you installed XP as VM, I tried to make VirtualBox (on a different disk, d:\ ) boot Windows XP on C:\, it always came up with error 21 device not found. Never resolved.

Revision history for this message
Olof Carlqvist (jerker-olofpark) said :

Control panel > user accounts
my username
Computer administrator
Password procected

Then your workgroup is like mine in lower cases but XP can just use upper case.
If you have connection so changing to lower case will not solve the problem.

I have used VirtualBox in two different ubuntu PC.
Both installed on the same way.
Each one has one hard disk where the installation file was /home/username/.VirtualBox
Here the XP has no static IP and is using DHCP. Username and password is the same.

I could not install the synaptic version to get it working I used:

sudo apt-get install build-essential linux-headers-`uname -r`

wget /virtualbox_1.5.6-28266_Ubuntu_hardy_i386.deb ; sudo dpkg -i

sudo adduser username vboxusers

sudo gedit /etc/init.d/
# Magic to make /proc/bus/usb work
mkdir -p /dev/bus/usb/.usbfs
domount usbfs "" /dev/bus/usb/.usbfs -obusmode=0700,devmode=0600,listmode=0644
ln -s .usbfs/devices /dev/bus/usb/devices
mount --rbind /dev/bus/usb /proc/bus/usb

grep vbox /etc/group

sudo gedit /etc/fstab
## usbfs is the USB group in fstab file:
none /proc/bus/usb usbfs devgid=126,devmode=664 0 0

sudo gedit /etc/init.d/
Paste the 2 lines below above the line: "# Mount spufs, if Cell Broadband processor is detected"
## Mount the usbfs for use with Virtual Box
domount usbfs usbdevfs /proc/bus/usb -onoexec,nosuid,nodev,devgid=126,devmode=664

Everything worked fine but the usb-device as memory device only.

Revision history for this message
ealthuis (ealthuis) said :

Thank you for the VM info, I certainly will try it and see what happens, Are the Ubuntu PC's pure Linux or dual boot, Mine is dual boot with WXP on c: and Linux on d:

  As far as XP is concerned, do you have Automatic updates turned on, I am beginning to believe that maybe your XP is missing some networking info??. Also as administrator the User accounts show no password was set up.

In XP, when you run windows explorer, do you see an item called 'My Network Places"?, if so if you click the + sign to expand do you have 1) Microsoft Terminal Services, 2) Microsoft Windows Network, 3) Web Client Network, and 4) hopefully another item or more. If you have more that the first three try clicking on one of the additional ones.

I am now just guessing, even though that is the way mine connect correctly.

Revision history for this message
Olof Carlqvist (jerker-olofpark) said :

Mine is a pure ubuntu linux PC.

And in WXP I have the automatic update turned on.
But in windows explorer I have only:
entire network
 microsoft windows network
  Workgroup (with no permission to reach)

 microsoft terminal service
 web client network
 or other items

But after updating manually.
When I left-click on My network places I can search after PC in the network by name.
Now the WXP found the W98 without permission problem!!!
I can see another WXP without permission problems also!!!
I can see one ubuntu PC but with permission problem.
But another Ubuntu PC cannot be found.

So I still have problems to connect WXP with ubuntu computers.
Remember that is not the problem from W98 so the problem is still by WXP not in ubuntu.

Revision history for this message
Olof Carlqvist (jerker-olofpark) said :

After turned off firewall in ubuntu PC I can see both of them in WXP.
To connect from W98 I have changed in Vnetsup with regedit.
How to disable encrypted password in WXP?

Revision history for this message
ealthuis (ealthuis) said :

I received your latest message at 01:39 PST, it is now 06:47 PST, which is 8 hours West of GMT. I am happy that XP is finally starting to get smart. As to your last question, I believe that my Dell book states that to change the master password one needs to remove for a short period the small battery on the motherboard. I shall search through that book and confirm this.

Now as to the Ubuntu firewalls, go back to the beginning of this story and set the firewalls up as I suggested and all should work.


Revision history for this message
ealthuis (ealthuis) said :

I searched through the Dell manual and found a long list of things to do in order to change the master PSW, the book about the ASUS motherboard indicated the BIOS is the place to change the PSW. You may have to search in any manuals you have to come up with the solution, though I am sure removing the battery does the same thing as indicated in the ASUS motherboard manual. Other settings too will be cleared, so be careful.


Revision history for this message
Olof Carlqvist (jerker-olofpark) said :

No I think this have to be done in WXP software.
To remove the battery will remove the password but keep the encrypted password settings by default.
So I tried:
Control panel > Administration tools > Local security policies
Security settings > Account policies > Local policies
Security options > Microsoft network client: Send unencrypted password to SMB servers.

After I have “enabled” Send unencrypted password to SMB servers I was more lucky.
Now the Ubuntu PC can be seen on WXP and I get a password question.
But unfortunatly not accept the plain password sent from WXP.

Before the change the WXP did not asked for a password just refused connection.

It must be somewhere else I have to change from encryptet to plain password?

Revision history for this message
ealthuis (ealthuis) said :

Now the Ubuntu PC can be seen on WXP and I get a password question. At this point enter the ubuntu password.

I have made sure that the password on all computers is the same, so no matter which one asks, the answer is the same

Revision history for this message
Olof Carlqvist (jerker-olofpark) said :

I get a question about username and password in WXP.
After written them down and sent away it takes a while and then comes the same window with the same question again.
Username and password are the same for all PC. but is not sent in a proper way from WXP to ubuntu.

Now I can see all PC in network neighborhoud.
There are four of them, W98, WXP and two ubuntu PC.

Revision history for this message
ealthuis (ealthuis) said :

On the Ubuntu machines have you installed filesharing? If yes, then I would look at Firestarter again and see if the XP machine is allowed in.

I have mostly worked with the numeric ID's of the other computers, and that worked well. i.e, where the xxx indicates the ID of each computer.

On Ubuntu try to read a file on the Windows XP machine, if you get a message that it cannot mount the device on the Windows machine chances are good it is caused by the firewall.

Actually I do not remember how I made WXP read the Linux files, but I have the computers listed under My Network Places : Newazura and Oldazura, the computer names. When I click on one of them I get the username and PSW question and the list of files is shown instanly.

Much faster than XP to XP ever was.

Revision history for this message
Olof Carlqvist (jerker-olofpark) said :

Yes filesharing is working between the two ubuntu and to and from W98.
Firestarter is turned off on both ubuntu.

I use static IP as well.

I have no problem to read files on WXP from all other computers.

I have all the computers listed under My Network Places on WXP.

Revision history for this message
ealthuis (ealthuis) said :

i am just about out of ideas, but try this for information:

Left click on the My Network Places, it should show all your other computers together with the TCP/IP adresses and names (right click if your mouse is left handed)

Revision history for this message
ealthuis (ealthuis) said :


I have been worried about this password problem, I also see from your answers and reaction to suggestions that you know quite well what you are doing. so forgive me for this idea:

Go check all of your user ID and passwords for being identical, they should all be either in lower case or upper case, no mixtures, mixtures are to easy to forget. I will not get back to this problem until tomorrow morning PST, it is now 18:59 PST


Revision history for this message
Olof Carlqvist (jerker-olofpark) said :


I have tried a crossed wire connection between WXP an ubuntu.
But the same behaviour as before.
So nothing is wrong with the router firewall.

WXP does not behave as W98 with plain text password.
When I left-click on “My network places” I can see ubuntu there.
When I left-click on ubuntu and then properties I get the following answer.

“You do not have the appropriate access rights for this server. For more information contact your network administrator.”

I have checked username and password on all PC. And they are the same.
To have accessright I must have the same username and password.

I have checked the ubuntu log-files.
The message in auth.log is the same for login from W98 as from WXP.
There are a difference in IP but that is normal.
So ubuntu accept booth W98 and WXP.

The problem lies in WXP and how to give the accessrights for ubuntu.
Any Idea?


Revision history for this message
ealthuis (ealthuis) said :

Yes I am back to removing the motherboard battery, both my Dell manual and the one for the ASUS motherboard indicate that that will clear date, time and system passwords, if you have a manual make sure you use the instructions it provides, that is a manual for the computer or motherboard, not XP.

It involves removing the battery as well as changing a jumper on the motherboard, though I can't tell you which one.

Also if you have an XP CD, try this boot it in the CD drive, when asked what you want to do, choose repair (r) then enter 1 and at the c:\ prompt enter help, see what the list of actions contains, then if there is something that might help, enter help .... (i.e. help diskpart)

Revision history for this message
ealthuis (ealthuis) said :


I may have just found your answer:

In my Dell computer when it boots (dual boot), it displays the Windows logo, and the keys to get to the BIOS (F2 and F12) I pressed F2 and got the BIOS Menu, there I found "System Security" , pressed "enter" and there was all that is needed:

Password status.............unlocked
System Password,,,,,,,,,,,,Not enabled
Setup Password..............Not Enabled
Post Hotkeys...................F2 and F12
PXE BIS Default Policy.....Deny

Find yours, and change them as above, that I hope will resolve the problem


Revision history for this message
Olof Carlqvist (jerker-olofpark) said :

No this is not a BIOS-problem.

I have tried another Windows XP on another PC.
This on has version 5.1 and Servicepack 1.
No problem att all to connect to ubuntu linux.

So the problem lies in the installation of Windows XP without Servicepack 1.
I have recogniced that earlier and that was why I prefered
Windows 98 compared to Windows XP.
To load additional software for such fundamentel service is stupid.

Many thanks to Emanuel with all his knowledge about Windows XP.
Without him I had to spend more days to solve this problem.

Revision history for this message
ealthuis (ealthuis) said :


Glad the problem has been resolved, have fun with your more capable systems, I do with mine.


Revision history for this message
Olof Carlqvist (jerker-olofpark) said :


Again many thanks for Your help