Mp3s failing to play over SMB

Asked by Scott White on 2006-03-26

I have a file server on FreeBSD using Samba, this has been working with my other PCs from Windows environments.

On my Ubuntu (5.10) box I tried playing my Mp3s from my file server and it files to play. From Totem for instance the error is:

"Totem could not play 'smb://.../x.mp3

There were no decoders found to handle the stream, you might need to install the corresponding plugins"

When I copy the mp3 to the local computer it runs properly. It also fails to run on VLC but gives me no error.

Any ideas? I'm pretty new at running media on Linux.

Thanks!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2006-03-26
Last reply:
2006-03-29
Bajtalan Hunor (cerebellum) said : #1

Hello,

Mp3, Avi, Mpeg, Mov are not free formats = you have to pay for these, for ubuntu not that is why you can not play these.
There is a new tool, everything is done just with a click, audio/video/java/flash and other supports/tools too.

Just use this service https://launchpad.net/products/easyubuntu
Hope this helps

Craig Sampson (ubuntu-psi-aus) said : #2

Hello Bajtalan Hunor, I don't think Scott White is having the problem you describe.

As he says:

"When I copy the mp3 to the local computer it runs properly."

Which means that he is obviously able to play mp3's and have them decoded properly. I think the problem he is experiencing is with a failure of gnome-vfs, or rather a failure of totem to be able to use gnome-vfs-smb. I'm pretty sure this is fixed with Dapper Drake, however the problem with continually appear with any application that does not support gnome-vfs directly.

Scott: you may find that you benefit by mounting the remote smb drive rather than trying to virtualise the filesystem. If this is a bother by hand you might find the package smb4k a useful GUI for making (semi) permanent smb mounts.

Hope that helps,
Craig

Scott White (swhite1) said : #3

Bajtalan,

Yes I read that somewhere too and I went and installed the W32 stuff as well as some others. As Craig observently mentioned, this didn't happen when the file was local. I proceeded to mount the share and my Mp3s worked!

Craig,

Great work I really appreciate the feedback. My guess is that your analysis is correct in that it isn't supporting gnome-vfs directly. I haven't checked out Drapper yet as I dunno how stable it is yet.

This is a great forum you have here. Let me know if there's anyway I can help out.

Thanks,
Scott

Ralph Green (severian) said : #4

  I mount a samba file system from a shell script. Thus, when I want to play the file, I just tell totem to play /candi/isihac_1999jun23.mp3. This always works fine, while the smb://janet/open/isihac_1999jun23.mp3 reference fails in some programs(I think totem was one). I suggest you create a mount point for the share and mount it. Then enjoy your show. It will work,

Can you help with this problem?

Provide an answer of your own, or ask Scott White for more information if necessary.

To post a message you must log in.