I cannot eject the CD

Asked by Mohammad Alhobayyeb on 2009-01-29

Do I have to cry, Ubuntu?!
What's wrong Ubuntu? every thing is fine with my 4 years acer laptop but with this new one Asus F8VR I have many problems!

If I inserted a CD then do whatever with it (Read, Copy or Nothing) I will not be able to eject it and If I tried right-click then eject (or unmount) a dialogue appears saying:
Unable to mount media.
There is probably no media in the drive.

This not all thing but I opened the Computer folder (computer:///) and surprised that I have two CD/DVD players???
I found there these two items: me
CD-RW/DVD±RW Drive
English Cafe 01 (this is my inserted CD)

One minute there is another thing, after trying ejecting the CD the CPU meter says that I am using more than 50% of the CPU.

Come on guys what is going on with??

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Mohammad Alhobayyeb
Solved:
2009-01-31
Last query:
2009-01-31
Last reply:
2009-01-31

it should be on the desktop right mouse button on it go to eject. There it is...lol..
Gnu/Linux locks the drive so just eject works great..
ever in terminal

just type eject with something in or not it will eject.

oops drive is locked...my bad..

I know this is weird. but shut down the computer it goes through a set of things it will eject during shutdown you have hardly no time to grab the disk but try..

If you missed it power it on press the front eject button a few times till it ejects but be quick grab the disk to remove.

or even sudo eject in terminal sometimes works.

Mohammad Alhobayyeb (mih1406) said : #4

I know that If I shut-down my PC I can press the eject button in the CD door

I tried sudo eject but nothing happed

ok it happened to me I had a locked drive it is locked due to a in use lock it didn't end if you want to while it is running kill the process well you might not no what process is still running you can do in a terminal type
ps -A and paste it here.

If you know what it is

kill it..try jobs it will give you an unstopped jobs

sudo kill %#

#= number of the job(s) if there is one.

Mohammad Alhobayyeb (mih1406) said : #6

See this guys

Unable to eject English Cafe 01

DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

What can I do now I want to eject the CD without shutting down!!

Tom (tom6) said : #7

Applications meu on the top taskbar - Accessories - Terminal

then into the terminal/command window/console type

sudo dir --help

It'll ask for your user password, not your Root/SuperUser one.
This command there will show you a help-file on what the command does. Now you're maybe feeling a bit safer try ...

sudo kill --help

and compare against the instructions below to see they are not likely to cause lasting damage. Try

sudo kill -L

and compare against my table of processes. I've not got a cd in my tray so any proceses that are running on your machine that aren't listed below will probably be worth stopping. Anyway, here's my output

 1 HUP 2 INT 3 QUIT 4 ILL 5 TRAP 6 ABRT 7 BUS
 8 FPE 9 KILL 10 USR1 11 SEGV 12 USR2 13 PIPE 14 ALRM
15 TERM 16 STKFLT 17 CHLD 18 CONT 19 STOP 20 TSTP 21 TTIN
22 TTOU 23 URG 24 XCPU 25 XFSZ 26 VTALRM 27 PROF 28 WINCH
29 POLL 30 PWR 31 SYS

Ooops, looked a lot neater in my terminal window. Anyway lets say that you have a process "32 Cd active" then you'd stop the process by typing

sudo kill %32

It's unlikely that the process you want to kill as as obviously named as that so just try 'killing' (they can be resurrected) any process that isn't listed in my output.

Good luck with this.
Regards from
Tom :)

Tom (tom6) said : #8

It sounds like there might be a problem with the cd-drive itself or maybe you haven't got a big enough linux-swap partition or something. On some laptops it's pretty easy to pull the cd-drive out and push it back in firmly. There's usually a slide button on the bottom of the laptop to stop the cd-drive from falling out. To check your linux-swap go up to the top taskbar and click on System - Administration - Partition Editor (if it's there). It takes ages to produce the report but eventually you should see a picture of what your hard-drive looks like. Is there a red box? Is it at least 256Mb? Ok, close gparted because it's a dangerously powerful tool and we want to be sure about what we're doing when we use it. Just looking is safe though. Do you also know how much Ram your machine has?

Good luck with this too :)
Tom :)

Mohammad Alhobayyeb (mih1406) said : #9

Thanks for you help.

First, The CD drive works fine in Vista Premium, so there isn't any problem with it.

Second:
Linux-swap 5.79 GB
RAM 2GB

I am waiting for help!1

Mohammad Alhobayyeb (mih1406) said : #10

There is only one button, the normal button to eject the CD but also didn't solve any thing.

pe3k (qyx) said : #11

Can you please post the output of 'mount' command when the CD is inserted?

Tom (tom6) said : #12

Just idly wondering if you are trying to resolve a problem or trying to prove that linux doesn't work?

If you do want to fix the problem then please try the kill commands as suggested by 2 of us.

Thanks for letting us know that you do have plenty of ram and swap space. If anything you should be able to safely do without the linux-swap at all because you have so much ram. Normally linux-swap only needs to be about twice Ram size but for over 1Gb of Ram that changes.

Good luck in resolving the problem there
Regards from
Tom

Mohammad Alhobayyeb (mih1406) said : #13

pe3k

See this is the output of 'mount' command when the CD is inserted:
/dev/sda5 on / type ext3 (rw,relatime,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
lrm on /lib/modules/2.6.27-11-generic/volatile type tmpfs (rw,mode=755)
/dev/sda1 on /windows type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
securityfs on /sys/kernel/security type securityfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/mih1406/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=mih1406)
/dev/scd0 on /media/cdrom0 type iso9660 (ro,nosuid,nodev,utf8,user=mih1406)

Mohammad Alhobayyeb (mih1406) said : #14

"Just idly wondering if you are trying to resolve a problem or trying to prove that linux doesn't work?

If you do want to fix the problem then please try the kill commands as suggested by 2 of us.

Thanks for letting us know that you do have plenty of ram and swap space. If anything you should be able to safely do without the linux-swap at all because you have so much ram. Normally linux-swap only needs to be about twice Ram size but for over 1Gb of Ram that changes.

Good luck in resolving the problem there
Regards from
Tom"

Be self-confidence Tom!!

Mohammad Alhobayyeb (mih1406) said : #15

Tom

See this is the output of 'sudo kill -L' command:
 1 HUP 2 INT 3 QUIT 4 ILL 5 TRAP 6 ABRT 7 BUS
 8 FPE 9 KILL 10 USR1 11 SEGV 12 USR2 13 PIPE 14 ALRM
15 TERM 16 STKFLT 17 CHLD 18 CONT 19 STOP 20 TSTP 21 TTIN
22 TTOU 23 URG 24 XCPU 25 XFSZ 26 VTALRM 27 PROF 28 WINCH
29 POLL 30 PWR 31 SYS

What do you want me to DO, Tom?

Tom (tom6) said : #16

Feedback is good so we can narrow down what is causing the problem.

 1 HUP 2 INT 3 QUIT 4 ILL 5 TRAP 6 ABRT 7 BUS
 8 FPE 9 KILL 10 USR1 11 SEGV 12 USR2 13 PIPE 14 ALRM
15 TERM 16 STKFLT 17 CHLD 18 CONT 19 STOP 20 TSTP 21 TTIN
22 TTOU 23 URG 24 XCPU 25 XFSZ 26 VTALRM 27 PROF 28 WINCH
29 POLL 30 PWR 31 SYS

That's my output from earlier but sadly your output is identical to mine. If you had informed us that was the case then we would have had at least known to ignore that variable out of the many hundreds of things to consider. We need to ask questions and get feedback to narrow down exactly what is causing the problem. Otherwise we could just give you a manual and an endless list of anecdotes such as ...

I have a great little laptop dvd-drive but it doesn't eject properly. After getting the OS to eject i had to swiftly pry a screwdriver into it in order to get the tray open! I sprayed it with WD40 and it stopped being so good at reading/writing stuff for a while until i delicately cleaned the lens. Then i noticed the slider arm that interfaces between the tray and the main part of the unit and been just slightly bent. If i had the skill and the resources to straighten it i would but it's been easier for me to just remove the case and use it as an external dvd drive.

The first stage of fixing someone elses problem with a cd drive not ejecting is not to take their drive apart to see if their arm is also bent but rather to try things that are likely to work in a majority of cases. There are thousands of reasons why someone wouldn't respond and only one of those reasons is that they tried it and it didn't work. We're not mind-readers.

Mohammad Alhobayyeb (mih1406) said : #17

Thanks!

But what is next?

Tom (tom6) said : #18

It might be good at some stage to find out what make and model of laptop you are using so that someone can compare it against a list of known hardware issues such as at
http://www.fsf.org/resources/hw

or to get the tech spec manual from somewhere or whatever seems appropriate given the known factors.

Being confident sounds a lot like being deliberately ignorant of there being a huge range of possibilities.

Mohammad Alhobayyeb (mih1406) said : #19

My laptop M/B Version: ASUS F8VR

I couldnot understand how to deal with this site:
http://www.fsf.org/resources/hw

Tom (tom6) said : #20

lol, me too. There's got to be something easier somewhere

Tom (tom6) said : #21

The cd-tray can only eject on shutdown and while booting up? But it does eject then so that pretty much rules out hardware issues. It's not likely to be an incompatibility issue but i wouldn't know.

the eeePC series had a bit of trouble so Ubuntu has to be installed with different kernels and some repackaging
http://www.eeebuntu.org/
Normally an install can be done withut reformatting anything and so it just refreshes, updates and adds in missing packages but you have to go through the Manual Partitioning rather than the Guided or Automatic Partitioning and it's a bit scary and "techi" so i'd back-up your data if you try this route. I'm not sure about the F8vr tho and i seem to be having "issues" with google at he moment so i can't look up any specs.

Sorry, not much good so far - hopefully someone else will be ale to take this further now
Good luck and regards from
Tom :

PS sorry about earlier - have fun now

Mohammad Alhobayyeb (mih1406) said : #22

Finally, solved via BIOS:

Advance -> IDE Configuration -> SATA Operation Mode.

Changed from 'Enhanced' to 'Compatible'

By the way I couldn't install Ubuntu without doing this, does this mean there is compatibility issue between ubuntu (linux) and SATA??

Thanks Tom and others
I appreciated your hard work and your time

Tom (tom6) said : #23

No, i think it's just a bios issue. Bios' are often weird and wonderful but usually default and "Auto" settings work. Lots of people have Sata drives so i think we'd be getting a lot of noise if there was a problem there. My mbord lets me have both but i'm still on ide drives.

lol, i'm kicking myself for not thinking of looking around in the bios but they can be a bit daunting at times.

Good luck and congrats for fixing it
Nice one
Regards and welcome to Ubuntu from
Tom :)

Mohammad Alhobayyeb (mih1406) said : #24

Thanks Tom for helping and being patient with a Linux newbie

Eddy Leong (eddyljm) said : #25

Hi Guys,

I also having the same problem as Mohammed and I tried the solution to change the setting in the BIOS but then the result was i not able to boot up my Windows Vista. While loading the Vista it provide me a blue screen and the system restart..

So i change back the BIOS configuration then only I able to boot up windows Vista...So is there anyway that we can have Ubuntu to support SATA instead?

Regards,
Eddy

Tom (tom6) said : #26

Eddy, please post this as a new Question. People don't often look around in Questions marked as Solved in order to help solve them
https://answers.launchpad.net/ubuntu/+addquestion

Good luck and regards from
Tom :)