fsck reports hard drive problems - what to do?

Asked by Daniel Brumbaugh-Keeney on 2009-01-27

One day I started my machine, and it went through the occasional hard drive check, which failed, it provided me a shell and told me to run fsck manually, which went like this:

fsck 1.41.3
e2fsck 1.41.3
Pass 1:
Inode 2867419 has imagic flag set, clear? no
Inode 2867419 has INDEX_FL flag set, but is not a directory
Clear HTree index? no
HTREE directory inode 2867419 has an invalid root node
clear HTree index? no
Inode 2867419, i_blocks is 3034906360, should be 0, fix? no
Pass 4: checking reference counts
Inode 2867419 (...) has invalid mode (00).
Clear? no
Unattached inode 2867419
connect to /lost+found? yes
inode 2867419 ref count is 46620, should be 1, fix? no
Pass 5:
Inode bitmap differences: +2867419
Fix? no

Obviously, I have a problem with my filesystem. I'm not really sure what it means to agree to this stuff. If I agree to this stuff, will my system be okay? Should I check for data corruption? If so, how? Is there someway I can prevent these errors or detect them sooner in the future? Is this all caused by hard drive mechanical failures? Is this a prelude to a total hard drive failure? I haven't booted my computer since running fsck as reported, and the hard drive was mounted in read-only, I think, so I'm not actually sure if even that yes I agreed to has been applied yet.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Tim Sharitt
Solved:
2009-01-31
Last query:
2009-01-31
Last reply:
2009-01-27
nhasian (nhasian) said : #1

yes there are some errors, you need to agree to allow fsck to fix the filesystem.

Can you answer any of my other questions?

Best Tim Sharitt (tsharitt) said : #3

You will need to say yes to fix the errors before it will be mounted in read-write. If you want have fsck run more often you can run 'tune2fs -c max-mount-counts device' see man tune2fs for more info.

 If you cant find a file after fixing the errors look in /lost+found.

I wouldn't say that it is a prelude to a hard ware failure.

Thanks Tim Sharitt, that solved my question.