black screen installing ubuntu amd64 with geforce 8800

Asked by John S on 2007-04-29

Trying to install Ubuntu 7.04 amd64, and Im running into a problem during installation.

When I boot to the CD, I select install, and then it go through the first few options/boxes. Then, it tries to probe for hardware.
When it gets to the video card, it says unknown nvidia device 0139 (not sure if that is the exact number, but I can be more specific if needed)
Then, it starts to load up x server and then the screen goes black and goes into power save mode.
I have done a bit of searching on the web for this problem but everything seems to be for installing drivers on existing linux installations, I have not been able to find anything related to installation of linux on this hardware.

My computer:
EVGA 680i
Intel E6600
EVGA 8800 GTS
2 320GB seagates in RAID-0

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Massimo Forti
Solved:
2007-04-30
Last query:
2007-04-30
Last reply:
2007-04-30
John S (someguy07) said : #1

I forgot to mention, I have tried "linux vga" and "linux vga=normal xdriver=vesa" and it does the same thing.

I also tried the noprobe command but it still tries to probe for the video card when the anaconda installer comes up and the same thing happens.

Cesare Tirabassi (norsetto) said : #2

This is a know issue which is being worked on. For more details please have a look at the following bug report:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nv/+bug/91556

John S (someguy07) said : #3

Thank you, I will keep an eye on that.

Massimo Forti (slackwarelife) said : #4

The problem is the NVIDIA GeForce 8800 is supported by the new NVidia Driver. To use the live cd you can start it in "safe mode" than when you are in a consol mode do:

dpkg-reconfigure xserver-xorg

and replay vesa when you must choose the driver. After you do start x and you can install ubuntu.

Thanks

John S (someguy07) said : #5

Is there another safe mode other than the "graphical safe mode"?

I tried to run it (version 6.06 by the way) and I get the following on my screen:

--------
(A bunch of series of numbers, the last 3 lines are listed below):
[40.873851] CR2: 0000000000000001
[40.873955] <0> Kernel panic - not syncing: Attempted to kill init!
[40.874124] (blinking cursor)
--------

If giving you more of the screen here would help, let me know and I will try to copy it down. FWIW I dont think I can generate a log or anything like that, I cant type anything at the "prompt". I have to do a hard reset (Ctrl-Alt-Del does nothing).

Thanks for the help so far.

Cesare Tirabassi (norsetto) said : #6

If you have an Abit board I would suggest to download the latest BIOS (there were few fix needed).
Perhaps some of the "A bunch of series of numbers" could be helpful especially those around this messagge "Unable to handle kernel NULL pointer dereference".

Best Massimo Forti (slackwarelife) said : #7

Take the Ubuntu 7.04 live cd and on the first screen, the boot menu on the cd, press F6 (extra options) you will be presented with some preloaded parameters. Append the pre-existing parameters by adding “noapic nolapic pci=noacpi acpi=off” at the end of the line (without " "). This disable for the moment the acpi daemon.

Let me know, thanks

John S (someguy07) said : #8

Thanks Massimo Forti, that solved my question.