Invalid unicode when copying from Windows shares

Asked by Sideburn on 2007-04-29

I just maneged to connect to my Windows XP file server

https://answers.launchpad.net/ubuntu/+question/5808

but when I copy from it to Ubuntu, my swedish characters is replaced with question signs, and the info box complains about "invalid unicode".
This isn't the case when I use GNOME-VFS...

I use an (US) English installation of Ubuntu Feisty, maybe this is causing the trouble?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Massimo Forti
Solved:
2007-04-30
Last query:
2007-04-30
Last reply:
2007-04-30
Massimo Forti (slackwarelife) said : #1

Thanks for your question, to solve your problem you can put this line in your mount option:

iocharset=iso8859-1,codepage=cp850

so your line became like:

//servername/share /media/example cifs credentials=/home/yourusername/.smbcredentials,uid=1000,gid=1000,ocharset=iso8859-1,codepage=cp850 0 0

Thanks

Sideburn (sveggo) said : #2

Thanks for your effort, but the problem is still there... :-/

The WinXP installation on the other computer is Swedish, and have ntfs partitions, if that could be of any help?

Massimo Forti (slackwarelife) said : #3

//servername/share /media/example cifs credentials=/home/yourusername/.smbcredentials,uid=1000,gid=1000,iocharset=iso8859-1,codepage=cp850 0 0

I mistake before.

Sorry.

Sideburn (sveggo) said : #4

No problem...
Unfortunatly that doesn't help either. :-/

Best Massimo Forti (slackwarelife) said : #5

try this:

//servername/share /media/example cifs credentials=/home/yourusername/.smbcredentials,uid=1000,gid=1000,iocharset=utf8 0 0

Sideburn (sveggo) said : #6

Thanks Massimo Forti, that solved my question.