Some Feisty apps can connect to Windows servers, others not...

Asked by Sideburn on 2007-04-28

I'm running Ubuntu on a laptop with a small HDD, and have all my multimedia stuff on a Windows XP file-server.

Ubuntu is able to connect to shared Windows-folders, but not all applications seems to have access to those...

For example, in Rhythmbox it's possible to import files or folder from the shares, but Firefox can only see the local mounts and folders.
This is extra irritating when it comes to movies, since I would rather use good ol' VLC instead of Totem.

Is there some good reason for this behaviour, or is it some kind of bug/neglectance? And, most important, is there some kind of workaround or tweak to solve this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Christoph Langner
Solved:
2007-04-28
Last query:
2007-04-28
Last reply:
2007-04-28
Best Christoph Langner (chrissss) said : #1

Only "real" GNOME applications like nautilus, rhythmbox, totem, etc can use the GNOME-VFS (Virtual File System)

http://en.wikipedia.org/wiki/GNOME_VFS

It you want to use your shares in all applications, you've got to mount the remote file system. To be able to do this, you've got to install the package smbfs. After that, you can mount windows and samba shares via

# sudo mount -t cifs -o username=yourwindowsusername,password=yourwindowspassword //servername/share /media/example

or via a new line inside your /etc/fstab

----
//servername/share /media/example cifs credentials=/home/yourusername/.smbcredentials,uid=1000,gid=1000 0 0
----

where /home/yourusername/.smbcredentials is a file with your username and passwrd

----
username=yourwindowsusername
password=yourwindowspassword
----

CU
Christoph

Sideburn (sveggo) said : #2

Thanks Christoph Langner, that solved my question.

Sideburn (sveggo) said : #3

Thanks a lot Christoph!

After some trouble back and forth I finally got the fstab right...
At first the commands didn't work, but after using the ip-adress instead of servername, and manually creating the example directory with

"sudo mkdir /media/example"

it worked like a charm!

BUT...
I get some messages when I shut down the computer:

[ 244.477988] CIFS VFS: server not responding
[ 244.478050] CIFS VFS: no response for cmd 50 mid 23

The computer shuts down after some time-out period, so it's not the end of the world...

Again, thank you!