Movies flashes in my laptop, I cannot display them clearly

Asked by Mohammad Alhobayyeb on 2009-01-16

When I played any movie in my ASUS F8VR, the movies flashes and did not display clearly!

ATI RADEON HD 3470, Installed via Hardware Drivers (I think its Restricted Driver)

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Andy Ruddock
Solved:
2009-01-19
Last query:
2009-01-19
Last reply:
2009-01-19
nhasian (nhasian) said : #1

what media player are you using totem? try installing vlc instead

sudo apt-get install vlc

also make sure your system is up to date.

sudo apt-get update
sudo apt-get upgrade

Mohammad Alhobayyeb (mih1406) said : #2

I have Installed VLC, MPlayer and every gstreamer in the Add/Remove...
And my system is up to date

Mohammad Alhobayyeb (mih1406) said : #3

I have Installed VLC, MPlayer and every gstreamer in the Add/Remove...
And my system is up to date

But still I have the same problem

nhasian (nhasian) said : #4

okay your using the restricted drivers for your video adaptor and vlc and your still having problems? maybe its the media? what movies are flashing? DVDs? avi? .flv? can you give us more information?

Mohammad Alhobayyeb (mih1406) said : #5

The media is avi and wma displayed OK in Vista and another laptop with Ubuntu 8.10

Andy Ruddock (andy-ruddock) said : #6

Open a terminal window and then type

gstreamer-properties

Click on the "video" tab and in the "Default Output" section select "X Windows System (No Xv)" for the "Plugin" option.

nhasian (nhasian) said : #7

do all avi and wma files have playback problems? or just this specific one?

Mohammad Alhobayyeb (mih1406) said : #8

All videos

Mohammad Alhobayyeb (mih1406) said : #9

I did whatAndy Ruddock said but nothing changed!
I deactivated the hardware and installed it manually but nothing changed!

Tom (tom6) said : #10

Andy Ruddock's suggestion usually fixes this know issue. (Always worked before). Have you got the ati driver enabled?
System - Administration - Hardware Driver
Please check the gstreamer-properties from a terminal window, are they still as you set them ... (no Xv)?

Finally worth checking is
System - Preferences - Appearance
on the last tab switch off all desktop effects. If this works then try the middle setting.

Sorry about this
Good luck
Regards from
Tom

Mohammad Alhobayyeb (mih1406) said : #11

- Yes I have the ATI driver enabled.
- Yes they are still (no Xv).

- Yes switching off all desktop effects solved it, but the middle one did not, so I have to disable all the desktop effects! :(

But why 'Finally' Tom??
Do I have to switch off all the desktop effects every time I am going to watch a movie??
Then I have to enable it after that then changing the setting for the Compiz??

We need I solution.
We do not want to go around it!

Thanks very much

Andy Ruddock (andy-ruddock) said : #12

Can you post the information from the "Help -> About" box in the media player that's exhibiting the problem.

Mohammad Alhobayyeb (mih1406) said : #13

Totem Movie Player 2.24.3
Movie Player using GStreamer 0.10.21
Copyright © 2002-2007 Bastien Nocera

Please try to remove the .xine directory settings...

Open a Terminal from the menu Applications → Accessories → Terminal and type:

rm -fr $HOME/.xine

Hope this helps

Mohammad Alhobayyeb (mih1406) said : #15

No use! :(

gnome-mplayer 0.7.0
A media player for GNOME that uses MPlayer
Copyright © 2007,2008 Kevin DeKorte
http://code.google.com/p/gnome-mplayer/

Mohammad Alhobayyeb (mih1406) said : #16

I have reinstalled my Ubuntu and this issue solved for totem only with no Xv!!

But VLC and MPlayer still have the issue??

Best Andy Ruddock (andy-ruddock) said : #17

Unfortunately the different media applications are configured differently, so you need to configure each one individually to use the Xv output.

In VLC :

Tools -> Preferences select Video on the left, select "X11 video output" in the Output section.

In gmplayer :

Right click on the video window and select Preferences. In the Video tab select xv in the list of available drivers.

In mplayer :

You need to edit the file ~/.mplayer/config and add the line
vo="x11"
You can do this with the following command :
echo vo=\"x11\" >>~/.mplayer/config

Mohammad Alhobayyeb (mih1406) said : #18

Thanks

GMPlayer prefs does not work??

VLC (Uninstalled) :)

Andy Ruddock (andy-ruddock) said : #19

Oops, sorry, you need to select the "x11 X11(XImage/Shm)" entry, and check the "Enable direct rendering" checkbox a little lower down.

Mohammad Alhobayyeb (mih1406) said : #20

There is only X11 no "x11 X11(XImage/Shm)"

And there is no "Enable direct rendering"

Can you show me a screenshot?

Remember I mean gnome-mplayer

Mohammad Alhobayyeb (mih1406) said : #21

Oops!

I am sorry I tried X11 and worked finally for GNOME-MPlayer

And I have installed VLC media player then I tried it and finally solved it

:)

I really appreciate this work
Thank you very much all of you guys

Mohammad Alhobayyeb (mih1406) said : #22

Thanks Andy Ruddock, that solved my question.