Dmraid(fakeraid) failed upgrade from egdy to feisty

Asked by fincan on 2007-04-27

I have a problem with dmraid and feisty, with upgrade or clean install I could not install feisty on my raid0 system. on the other hand I am still using dmraid and raid0 without problem in ubuntu. after upgraded, my root partition disappeared at boot, and if I try to make clean install with dmraid, I ll see this error message:
"root@ubuntu:~# dmraid -ay
ERROR: isw device for volume "Volume0" broken on /dev/sda in RAID set "isw_cgffbhhfed_Volume0"
ERROR: isw: wrong # of devices in RAID set "isw_cgffbhhfed_Volume0" [1/2] on /dev/sda"

but İf I try with 6.10 clean install I will not see this error. My motherboard is abit-ab9 pro(ich8 south-chipset).
and I tried some advices like adding " udevsettle --timeout=30" the dmraid but this line already in there.
I want to use 7.10 but there is only one barrier between me and feisty.
and the last thing, I have only using linux and ubuntu since last month,, please could you be more explanatory to make me understand easly???

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Massimo Forti
Solved:
2007-05-02
Last query:
2007-05-02
Last reply:
2007-04-27
Best Massimo Forti (slackwarelife) said : #1

Thanks for your questione, you can see this:

https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/103177

Report me you impresions

thanks

fincan (ejderpencesi) said : #2

Thanks Massimo Forti, that solved my question.

fincan (ejderpencesi) said : #3

I made mistake with clicking the wrong link and on the other hand I realized that my problem does not related with dmraid. whenever I boot with feisty livecd, at raid boot screen my raid hdds appear as offline and after powered of the pc they are back as online. I tried 64 and 32 bit livecds, kernel 2.6.21.1 but the problem was still there. are there any idea about what a hell problem ???? and last I am going to try to update my bios 916 to 917 maybe this may help to solve the problem but till this time I am open to any idea...