Feisty update - error on boot after crash

Asked by Mick Kielhauser on 2007-04-26

Hi,

I updated from Edgy to Feisty earlier this week and ran into some problems. Huygens helped me to get it sorted and now hopefully the installation is fine but it still refuses to boot.
This time I get at least a decent error message:

/sbin/usplash_write error while loading shared libraries: libc.so.6

I'm sure I have seen this on the answer page before and it was a quite simple fix but I'm unable to locate it again and Google was also not too helpful.

If anybody could give me some help this would be really appreciated (it's really true, never touch a running system...). Thanks a lot,

Greetings Mick

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Massimo Forti
Solved:
2007-04-27
Last query:
2007-04-27
Last reply:
2007-04-27

hmm, usplash is the pretty Ubuntu logo and percentage bar that runs when you first load into Ubuntu.

I could tell you how to disable usplash if you like, and just have kernel declarations instead (i do)

Hello Sam,

Many thanks for coming back to me so quickly. I don't care much about a fancy picture if my system works, but isn't it the symptom of a more serious problem?

At this stage I wonder if it is less pain to backup my data and do a clean 7.04 installation. Could you advise which directories I need, to keep (most) of my settings? From reading a bit through this board I see that there are some mor serious problems w/ Feisty and as it seems to boot fine on my machine I don't want to tie down resources w/ a minor question that could be used better somewhere else (or need some sleep for that matter).

Any advice or comment would be very welcome. I'm now a week w/o my laptop and it is getting from the annoying to the painful stage...

Greetings Mick

Oh, and I'm living in Tokyo so that's why there's some time delay in my responses.

Best Massimo Forti (slackwarelife) said : #4

If you want to do a backup you must copy all your /home directory and config file you have changed in /etc dir.

thanks

Cesare Tirabassi (norsetto) said : #5

Hi Mick,

usplash_write is used by different scripts to interact with the usplash daemon (for instance it is used by /etc/init/d/rc to update the progress bar).
The error message which is displayed means that usplash_write is unable to locate a runtime library it needs to do its job.
This could indeed be the symptom of something more serious:

1) Perhaps it is a PATH problem (that would be easy to recover)
2) Perhaps only the soft link is missing (libc.so.6 is only a symlink in /lib; on my 7.04 is pointing to libm-2.5.so)
3) Perhaps you have a corrupted filesystem

The only solution I can give (beside a complete reinstall of course....) is to use your live CD (or Knoppix or whatever else you feel confortable with) and check what happened to your file system and react accordingly.

Cesare Tirabassi (norsetto) said : #6

Let me also add, just in case you manage to log-in in Safe Mode (always worth a try), you can try to re-install libc by using sudo apt-get --reinstall install libc6. (This would solve your problem if it is #2 on my list above).

Thanks Massimo Forti, that solved my question.

Many thanks to everyone for responding. I really appreciated your help. After some consideration I decided to backup my data and re-install from scratch.

I first tried Feisty but neither my microphone nor the card reader worked (I have a HP Compaq NX6325), which they did under Edgy. As Edgy ran almost flawlessly for more than five months it was really a nobrainer.
I installed Edgy and applied all updates/patches. The system is back where it was and working again as it should. Maybe I retry Feisty in some months time, but I really like my system that way (switch on - work). I never regretted that I kicked Windows off that machine and went for Ubuntu so the whole thing w/ Feisty is a bit of a shame...

In any case, thanks again to all of you and hope you'll have a good weekend.

Greetings Mick