Synaptic Package Manager won't work

Asked by mbamaluikenna on 2009-01-08

I tried typing 'sudo dpkg --configure -a' in the terminal and I get this:

dpkg: failed in buffer_read(fd): copy info file `/var/lib/dpkg/status': Input/output error

I opened the the file but the system started malfunctioning as if the file was corrupt. The file never really opened, just hung with a blank screen.

Pls someone help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Ariel Cabral
Solved:
2009-01-09
Last query:
2009-01-09
Last reply:
2009-01-09
Matt Arnold (mattarnold5) said : #1

Tell me what was the last thing you did with synaptic/apt/dpkg/aptitude before the problem occoured.

Best Ariel Cabral (acabral1961) said : #2

It seems like a memory or physical hard disk problem. can you start with a Live CD and check if those things are ok?
If you don't know how, please ask.
Besides that, please answer the Mark's question and tell us also which version of Ubuntu are you using and some info of your hardware.
Hope this helps, let me know.

marce (welcometsp) said : #3

hey... I'm having a similar problem, it works, but doesn't install many applications...

what is it for that command?? should I trie it?

mbamaluikenna (mbamaluikenna) said : #4

It seems the hard disk has some physical problem. My windows is also showing some IO errors on some files.

mbamaluikenna (mbamaluikenna) said : #5

Thanks Ariel Cabral, that solved my question.

Not necessarily the solution. See:

http://ubuntuforums.org/archive/index.php/t-1073276.html
http://ubuntuforums.org/archive/index.php/t-197407.html

As it was in my case, /var/lib/dpkg/status was corrupted.