No vmlinuz for Ubuntu 8.10 after installation

Asked by Vishal on 2009-01-07

This is my grub file (the OS in /dev/sda2 is Ubuntu Studio 8.10

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

default 0

timeout 10

title Ubuntu 8.10, memtest86+
uuid 0ba8f784-d8a8-43ee-882f-7a9df700548f
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

title Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Home Edition
root (hd0,0)
savedefault
makeactive
chainloader +1

# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda2.
title Ubuntu 8.10, kernel 2.6.27-7-generic (on /dev/sda2)
root (hd0,1)
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=6fc42ade-b436-4524-a7d4-db56539c5eee ro quiet splash
initrd /boot/initrd.img-2.6.27-7-generic
savedefault
boot

# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda2.
title Ubuntu 8.10, kernel 2.6.27-7-generic (recovery mode) (on /dev/sda2)
root (hd0,1)
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=6fc42ade-b436-4524-a7d4-db56539c5eee ro single
initrd /boot/initrd.img-2.6.27-7-generic
savedefault
boot

# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda2.
title Ubuntu 8.10, memtest86+ (on /dev/sda2)
root (hd0,1)
kernel /boot/memtest86+.bin
savedefault
boot

The contents of the /boot of finally installed Ubuntu 8.10 are

/media/disk/boot$ ls
abi-2.6.27-7-generic memtest86+.bin
config-2.6.27-7-generic System.map-2.6.27-7-generic
grub vmcoreinfo-2.6.27-7-generic
initrd.img-2.6.27-7-generic

I tried reinstalling Ubuntu 8.10, but still the same error exists

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-01-07
Last reply:
2009-01-23
Vishal (coolfriend-vishal) said : #1

Ubuntu 8.10 is installed in /dev/sda4. Windows XP in /dev/sda1 and sda3 is swap partition.

plutino (plutino) said : #2

Delete this part in the menu.lst file:

--BEGIN--
title Ubuntu 8.10, memtest86+
uuid 0ba8f784-d8a8-43ee-882f-7a9df700548f
kernel /boot/memtest86+.bin
quiet
--END--

Since you default boot option is set to 0, grub will boot to memtest. Also move the XP lines to the end of the file if you don't want to boot to windows by default.

Vishal (coolfriend-vishal) said : #3

The thing is that I have installed Ubuntu 8.10 on sda4, Ubuntu Studio 8.10 on sda2, XP on sda1 and swap is in sda3.

The problem therefore is that Ubuntu 8.10 is not booting. There's no 'vmlinuz' file in boot folder in root directory in sda4, where Ubuntu 8.10 is installed.

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.