b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found -> excellent solution found for Broadcom wireless issues in Ubuntu 8.10

Asked by Denis R on 2009-01-05


I recently installed Ubuntu (newest one) however I have a problem with my wireless network. I have a belkin driver (which is windows) and according to the help it says that to install it I need to us a ndisgtk

Now, I went to the required place (can't remember exact position cos working on windows now cos no internet on ubuntu) and it isn't there. I tried searching and there is no such thing installed :(

How could I get something to make this work? The driver works perfectly in windows so is there a way for me to install it? Keep in mind that I don't have internet on Ubuntu, so I guess that unless it's in some other place I'm going to have to download the thing in windows then somehow install on Ubuntu (could you help with that too? If it's hugely different to windows XP)


Question information

English Edit question
Ubuntu b43-fwcutter Edit question
No assignee Edit question
Solved by:
Denis R
Last query:
Last reply:


Please follow this procedure:

Step 1: Open Terminal from "Applications->Accessories->

Step 2: Run the following commands (type each then hit <enter>)

sudo iwlist scanning
sudo lshw -C network
uname -a
dmesg|grep ound
dmesg|grep etect

Step 3: Post results (cut/paste terminal output from each command) here

Please also provide the full model and make of wireless card that you are using. USB or PCI card? Which model number?



Denis R (druderman) said : #2

Hi, i tried to do this however the terminal asks me for a sudo password. And I don't know what to enter, infact, i can't enter anything. It doesn't show any values :(


The sudo password is the root (superuser) password. This password was chosen for the root user during the installation of Ubuntu.

It is normal for the sudo command to not display the characters you are typing. It will accept the characters you type, just not display them (for security reasons).




I believe the sudo password - in this case - is actually the password you use to log into Ubuntu. Please try that first.



Denis R (druderman) said : #5

sudo iwlist scanning
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 Interface doesn't support scanning : Network is down

pan0 Interface doesn't support scanning.

NetworkManager Tool

State: disconnected

- Device: eth0 ----------------------------------------------------------------
  Type: Wired
  Driver: e100
  State: unavailable
  Default: no
  HW Address: 00:03:47:D7:A1:FA

    Supported: yes
    Carrier Detect: yes
    Speed: 10 Mb/s

  Wired Settings

- Device: wlan0 ----------------------------------------------------------------
  Type: 802.11 WiFi
  Driver: NULL(info.linux.driver)
  State: disconnected
  Default: no
  HW Address: 00:00:00:00:00:00

    Supported: yes

  Wireless Settings
    WEP Encryption: yes
    WPA Encryption: yes
    WPA2 Encryption: yes

  Wireless Access Points


lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:""
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          Tx-Power=0 dBm
          Retry min limit:7 RTS thr:off Fragment thr=2352 B
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

eth0 Link encap:Ethernet HWaddr 00:03:47:d7:a1:fa
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
          inet addr: Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:246 errors:0 dropped:0 overruns:0 frame:0
          TX packets:246 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:15408 (15.4 KB) TX bytes:15408 (15.4 KB)

sudo lshw -C network
^CI (sysfs)

00:00.0 Host bridge: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge (rev 04)
00:01.0 PCI bridge: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 05)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 05)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 Controller (rev 05)
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 05)
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus Controller (rev 05)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 05)
00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio Controller (rev 05)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AR [Radeon 9600]
01:00.1 Display controller: ATI Technologies Inc RV350 AR [Radeon 9600] (Secondary)
02:08.0 Ethernet controller: Intel Corporation 82801BA/BAM/CA/CAM Ethernet Controller (rev 03)
02:0a.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 04)
02:0b.0 USB Controller: NEC Corporation USB (rev 41)
02:0b.1 USB Controller: NEC Corporation USB (rev 41)
02:0b.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
02:0d.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

Bus 005 Device 004: ID 0781:5406 SanDisk Corp. Cruzer Micro 1/4GB Flash Drive
Bus 005 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 045e:009d Microsoft Corp.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 8086:1122 Intel Corp.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
uname -a
Linux denis 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686 GNU/Linux

dmesg|grep ound
[ 0.696238] pnp: PnP ACPI: found 13 devices
[ 2.281051] isapnp: No Plug & Play device found
[ 2.376734] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 4.223746] No dock devices found.
[ 4.519954] ssb: Sonics Silicon Backplane found on PCI device 0000:02:0d.0
[ 4.701954] hub 1-0:1.0: USB hub found
[ 4.805047] hub 2-0:1.0: USB hub found
[ 5.729764] hub 2-2:1.0: USB hub found
[ 6.230330] hub 3-0:1.0: USB hub found
[ 7.415011] hub 4-0:1.0: USB hub found
[ 7.737052] hub 3-2:1.0: USB hub found
[ 8.136446] hub 5-0:1.0: USB hub found
[ 9.062231] hub 5-3:1.0: USB hub found
[ 10.033766] usb-storage: device found at 4
[ 20.927655] b43-phy0: Broadcom 4306 WLAN found
[ 31.870443] apm: BIOS not found.
[ 39.202215] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
[ 39.340337] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found

dmesg|grep etect
[ 0.000000] Detected 1794.165 MHz processor.
[ 2.374790] EISA: Detected 0 cards.
[ 4.701971] hub 1-0:1.0: 2 ports detected
[ 4.805066] hub 2-0:1.0: 2 ports detected
[ 5.733988] hub 2-2:1.0: 4 ports detected
[ 6.230352] hub 3-0:1.0: 3 ports detected
[ 7.415033] hub 4-0:1.0: 2 ports detected
[ 7.739956] hub 3-2:1.0: 4 ports detected
[ 8.136469] hub 5-0:1.0: 5 ports detected
[ 9.062554] hub 5-3:1.0: 4 ports detected
[ 16.859149] iTCO_wdt: No card detected

My wireless card is a belkin wireless 54Mps Desktop Adapter

Denis R (druderman) said : #7


Sorry it still doesn't work:

E: Couldn't find package b43-fwcutter

Anything else I can do? It works perfectly on windows. Is there a way to install it on Ubuntu using the Windows system?

Denis R (druderman) said : #8

Also, i found something else.

F5D7000au is the name of my driver.


That has the uk version, however mine doesn't work out of the box. I don't have the ndiswrapper either. How would i install it? I don't have internet on Ubuntu either :(


b43-fwcutter exists in the Ubuntu repositories, but you will need a working Internet connection in Ubuntu in order to install it.

The only way to do that - in your case - is to connect the pc to the wireless router using a LAN cable, instead of using wireless.

I don't see a good alternative.



Denis R (druderman) said : #10


I did some more fact finding and searching and found some stuff on the net about my problem. I tried some stuff but it doesn't solve it, perhaps you could help me in this.

I installed ndiswrapper and installed the driver.

denis@denis:~$ ndiswrapper -l
autorun : invalid driver!
bcmwl5 : driver installed
 device (14E4:4320) present (alternate driver: ssb)
denis@denis:~$ ndiswrapper -i $/media/Belkin_F5D7000au/Driver/bcmwl5.inf
driver bcmwl5 is already installed

And then I tested my network:

*-network:0 DISABLED
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:30:bd:f6:50:44
       capabilities: ethernet physical wireless
       configuration: broadcast=yes multicast=yes wireless=IEEE 802.11bg

How can I connect now? I mean the driver is installed.


Denis R (druderman) said : #11

Solved thanks to this excellent thread. Worked perfectly and incredibly simple


Thanks heaps for your help Mark!