can't get java to work

Asked by rdtindsm

Just installed ubuntu 8.10 on an amd opteron 64 bit processor. Tried to solve a puzzle from After spinning for a bit, I get an error message: “… no longer connected to internet or your computer has problems displaying Java applets.”

www.javatest indicates that java is not working. Used synaptic to download java 6

synaptic now indicates that Java is as the latest version 6-10-0ubuntu2 and is installed in /usr/lib/jvm/java-6-sun- Below that are numerous files indicating that the files are available and the path at least looks reasonable.. still fails. Mozilla preferences->content indicates that JavaScript and Java are both enabled.

As a separate and bit of a newbie problem, I went to and downloaded jre-6ull-linux-x64-rpm.bin thinking that the files obtained through synaptic might not work on an amd 64 bit system.

This file from the Java site is now on my desktop. I found that I couldn’t change the exe status from the terminal because I kept being told that the file was not there. I was finally able to change the exe status thought the property dialog of the places gui. But I still cannot copy the file to an installation directory. I get a an error “cp: cannot state “file”: no such file or directory. All permissions are rwx

Am I missing some setting somewhere in the system to enable Java
Why won’t the cp and chmode commands see the file.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Simone Oberti
Last query:
Last reply:
Revision history for this message
Best Simone Oberti (simone-obo) said :
Revision history for this message
rdtindsm (rdtinknx) said :

Thanks obo, that solved my question.

Revision history for this message
rdtindsm (rdtinknx) said :

last ms was in error, I had an itchy mouse finge and hit the "solved my problem" by mistake.

I thank obo for his attention, but his link did not work. One of the things I forgot to mention is that I am using 32 bit ubuntu rather than 64 bit. Figured the 32 bit product would be better supported, and 64 bit applications are probably a bit scarce.

I went back into synaptic, did a search on java, and found a "sun-java6-plugin".

Installed it, Mozzilla shows a java plug in, indicates that java is enabled, and my browser works