Cannot get cdrom to mount

Asked by jodi on 2008-12-29

This is odd because I am able to pull up .jpg files on the cdrom, but can't play music. I'm using a cd-r with a mp3 short song on it, what do I need to do to get xubuntu 8.04.1 to recognized it or am I using the wrong type of music or do I have the right program to open it. I have followed some sudo mount /dev/cdrom and several other commands suggestions on this site but not having any luck. I did make a screenshot but cannot figure how to copy and paste to this message. Can someone guide me on all of this please. Thank You

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
jodi
Solved:
2009-01-02
Last query:
2009-01-02
Last reply:
2009-01-02
cmnorton (octopusgrabbus) said : #1

Look at the output of df. If you can access files on the CDROM, it sounds like it is mounted.

What mount command are you using? What, if any, are the messages after you issue the mount?

How do you know you have the wrong program to play the .mp3 file? Can you play any sound at all?

jodi (jodi5549) said : #2

What is df, I'm very new at this stuff. The only files I can access off the cdrom are picture files. I agree it sounds like it is mounted. So far I can play sounds on the internet through comcast fancast but the sound is choppy and I did download flashplayer the .deb file. for the video. The only program that loaded that I thought would reconized the sound is Movie Player under the multimedia section but it states :

Failed to mount cd-rom disk

mount: block device /dev/scd0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so.

It is a mp3 partial song, not a full song. The commands I was using was sudo mount /dev/cdrom, sudo mount /dev/scd1, cat /etc/fstab /etc/mtab. I can do this again and copy and paste as you ask so you can see the results if you can help me on this. I sure would appreciate it. Thank you

jodi (jodi5549) said : #3

"bump"

Please is there anyone out there that can help?

Jim Campbell (jwcampbell) said : #4

If you can access jpeg files on the cdrom, then it is mounted. Can you copy the mp3 off of the cdrom? Try this by navigating to the path where the file is stored on the cdrom, right-click, select copy, and then paste it onto your desktop (or into your home folder).

From there, I suggest that you make sure that you have the right packages installed to play mp3's. If you are using Xubuntu 8.04.1, typing "sudo aptitude install xubuntu-restricted-extras" into a command prompt should install the proper packages to allow you to play mp3's. From there, you can just double-click on the file that you have copied off of the cd-rom, and a media-player should open, allowing you to listen to the song...

I do have a bit of a concern that the "partial" mp3 may not be a working mp3 file, but hopefully that won't be the case.

jodi (jodi5549) said : #5

The mp3 partial is working on my dell xp, so I though it would work on this. I will take your advise on typing sudo aptitude if this os system would quick hanging in a window and not closing, just can't bring anything else up. Makes to slow. How do you stop a process or window from hanging. ctrl alt delete doesn't work like with windows of course and I new to this terminal stuff. Can I please send you also, if I can get the copy and paste working on my sudo commands? To see if it looks right to you, I'm totally lost on what it is saying to me. I appreciate you coming back to me on this window hanging 1st, because I can't do nothing else and don't know how to kill it. I was trying to open the sudo that I saved in Gimp using Abiword and the little circle is going now for 20 minutes. I will get back with you if this other works. Thank You

Jim Campbell (jwcampbell) said : #6

"I was trying to open the sudo that I saved in Gimp using Abiword and the little circle is going now for 20 minutes."

Sorry, but this makes no sense! :( Please take your time and try to be more clear about what your problem is. There is no way to open a sudo that you saved in Gimp using Abiword.

jodi (jodi5549) said : #7

I don't know any other way to paste the sudo responces if I doing them off line in the terminal, so I save them to the system hoping when I got back online I could copy and paste. All I had to save them to was gimp or Abiworld. I did what you stated aboved and it humg in the terminal on the Java part and cluldn't click enter for it to go on, so I really don't know what was installed and how to find it. Please respond when you can I'm dog tired and going to bed. I was up all night last night. It lock up so bad and had to reinstall everything. I'll will get back with you tomorrow if thats ok. I you can tell me how to cut and paste from the terminal and next time I'll be on line where I can do it imeitelly in the forum. Thank you for being so nice to me and helping out in a timey manner, but I gone for now. Been up for 24 hours and it's got me.

Paul (treepata) said : #8

Hey Jodi,

I hope you managed to get some sleep when you read this message. I am probably facing similar issues you are having, although I am using Xubuntu 8.10. I managed to fix some, although not all.

My situation:
I can play DVDs and read data CDs and DVDs (and game CDs and DVDs as normal), but when I put a normal audio CD in the tray the system doesn't (or didn't) do anything to read it. It also, just like in your case, didn't mount the CD at all.

What I have so far done:
1. Go to "Applications" > "Settings" > "Settings manager" and click on the Icon "Removable Drives and Media". When the new window opens, go to the second panel "Multimedia". There, where it probably says "totem cdda:/", change this value into "totem cdda://" (so with twice the slash). You can do the same for the second option (change "totem dvd:/" into "totem dvd://".
2. Make sure you have all the necessary codecs to read & play your files (like Jim said). You can find more information about this here > https://help.ubuntu.com/community/RestrictedFormats. Or you can simply open up a Terminal screen (under "Accessories" in the "Applications" menu and copy/paste the following text there...
sudo apt-get install xubuntu-restricted-extras

Now hopefully when you enter an audio CD the Movie Player will start and load the audio files. On my PC the file manager (Thunar) still doesn't see the audio CD, but at least the Movie Player does.

By the way, if you want to stop a process (for example because it hangs), press the combination "ctrl+alt+esc". Your cursor should now change to into a "X". When you then click on the bad program, it should be terminated.

Hope this helps and otherwise I am sure someone here can help you better.

jodi (jodi5549) said : #9

Well I tried that, but didn't work. Nothing is coming up now, but I don't think that has caused it. I inserted the same mp3 that I tried and got this error. Maybe you or someone knows what to do here.

Failed to mount cd-romd disk

mount: block device /dev/scd0 is write-protected mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/scd0, missing codepage or helper program, or other error
In some cases useful info is found in syslog-try dmesg | tail or so

Does this make sense to you? Do I need to go into terminal and do something? I couldn't even bring up my pictures this time. It just opens the cd file manager showing the date to the left, but on the right no pictures and movie player didn't come up either. Do I need to change that back to what is was on the cdda?

jodi (jodi5549) said : #10

To add to the above I'm now having to use the end of a paperclip to open the cd-rom. There must be something wrong in the terminal that I can fix. Nothing was wrong with the cd-rom before.

jodi (jodi5549) said : #11

Could you help me go thru some of the sudo commands? Maybe I followed the wrong ones and got something messed up. I'll get on the computer I'm working with so I can copy and paste to let you know the results. This is what I entered before and I can do this again if need be.

sudo mount /dev/cdrom
sudo mount /dev/scd1
sudo mount /dev/dvd.......don't know for sure if I did this one
cat /etc/fstab /etc/mtab

Maybe something has gotton messed up with the cd-rom since?

Jim Campbell (jwcampbell) said : #12

On Tue, Dec 30, 2008 at 21:40, jodi <email address hidden>wrote:

> Question #55795 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/55795
>
> jodi gave more information on the question:
> Could you help me go thru some of the sudo commands? Maybe I followed
> the wrong ones and got something messed up. I'll get on the computer I'm
> working with so I can copy and paste to let you know the results. This
> is what I entered before and I can do this again if need be.
>
> sudo mount /dev/cdrom
> sudo mount /dev/scd1
> sudo mount /dev/dvd.......don't know for sure if I did this one
> cat /etc/fstab /etc/mtab
>
> Maybe something has gotton messed up with the cd-rom since?
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

Hi Jodi,

Can you please provide the output of the command "cat /etc/fstab" (without
the quotes)? That information will help me to help you here. Thanks!

jodi (jodi5549) said : #13

Here you go

sherrie@sherrie-desktop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=4419d5ec-c10c-4df2-bb63-d23cc2389356 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda5
UUID=43ff9161-4511-4299-9320-cedee33eb869 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

Jim Campbell (jwcampbell) said : #14

entering:

sudo mount /dev/scd0 /media/cdrom0 should work :) (make sure you have a space between scd0 and /media...)

this command identifies the drive or partition you want to mount (/dev/scd0) and tells the computer to mount it at a certain point in the filesystem (/media/cdrom0).

once you've entered this command you can just navigate to /media/cdrom0 via the command line or thunar, and your files should be there.

if this helps, please be sure mark this question as solved. if not, let me know what problems you have. thanks!

jodi (jodi5549) said : #15

Did not work from what I can tell, did I loose my cd-rom altogether? Here is what I got

sherrie@sherrie-desktop:~$ sudo mount /dev/scd0 /media/cdrom0
[sudo] password for sherrie:
mount: No medium found
sherrie@sherrie-desktop:~$

Jim Campbell (jwcampbell) said : #16

Can you try putting in a different cdrom? Maybe a cdrom that contains an ISO of ubuntu or something?

jodi (jodi5549) said : #17

Do mean the xubuntu that I loaded with?

Jim Campbell (jwcampbell) said : #18

that would be fine. any cdrom that you know is good.

jodi (jodi5549) said : #19

The cd-rom file manager is reading that it is xubuntu in the left column with nothing in the right panel and that is all I get. I had to open the drive with paper clip again tho.

Jim Campbell (jwcampbell) said : #20

Can you try some other cd's with data on them? Any other cdroms that you have with a bunch of documents, mp3's, or other files saved to them?

When you got that message that said "No medium found," that means that it doesn't see a cd in the drive. Maybe the cd wasn't properly seated or properly inserted in the drive?

jodi (jodi5549) said : #21

Sorry I've haven't been able to get back sooner. But I booted up the computer this evening and behold! I put a data disk in and it work thru Abbiword, then I put the only movie disk I had and of course the error that I was missing MPEG -1 Layer 3 (mp3) decoder and micorsoft MPEG - 4 4.3 decoder. Then I tried to eject and another error came up and stated; cannot unmount bolumn, an application is preventing the volumn 010922_2313 from being unmounted. What could this be? Now I cannot even pushed the button on the cd drive again to get the disk out, I guess the paperclip again. But what could be making this not want to eject properly? I'll will reboot again and try some music again in the meantime till I hear from you. Thank You

jodi (jodi5549) said : #22

Cd-rom is reading ok now, all I need to do now is I assume is to download the codecs for the Mp3 to play music and such. If you can help me on how to do this I'll sure appreciate it then will mark this solved. Thank you for help on all of this!

jodi (jodi5549) said : #23

Just recalling your suggestion about installing, sudo aptitude install xubuntu-restricted-extras. Do you think it missed something on the mp3 or would it hurt to do it again? After installing should I not be able to play any music cd, commercial or not?

Paul (treepata) said : #24

for getting the correct codecs, there are some easy steps to follow. Simply go here, read it and it will explain to you what you need to do (note that you might already have done the first step, as we explained before);

https://help.ubuntu.com/community/RestrictedFormats

You probably want to have some additional codecs installed needed for e.g. many DVDs. To install these, go to this site and follow the steps there;

https://help.ubuntu.com/community/Medibuntu

Once you follow those easy steps, you should be able to play all your files without problems (don't forget the w32codecs on the Medibuntu page). Good luck!

jodi (jodi5549) said : #25

Ok I tried this in the terminal because the all available application did not come up with the xubuntu restricted extra and this is what I got:

sherrie@sherrie-desktop:~$ sudo apt-get install xubuntu-restricted-extras
[sudo] password for sherrie:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
sherrie@sherrie-desktop:~$ dpkg --configure -a
dpkg: requested operation requires superuser privilege

Would not go further with my password.

jodi (jodi5549) said : #26

Finally figure out what I was doing wrong with putting sudo in front, but this is all I got, is it because I already have the restricted extra except the java and should I go on medibuntu?

sherrie@sherrie-desktop:~$ sudo apt-get install xubuntu-restricted-extras
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
sherrie@sherrie-desktop:~$ sudo dpkg --configure -a
Setting up java-common (0.28ubuntu3) ...

jodi (jodi5549) said : #27

Ok, I went on ahead and installed the w32codec. Did I install the correct one for i386 and does the output look correct? Do I need to do anything else? Looks like didn't install right. See below

sherrie@sherrie-desktop:~$ wget -c http://packages.medibuntu.org/pool/non-free/w/w32codecs/w32codecs_20071007-0medibuntu2_i386.deb
--20:54:03-- http://packages.medibuntu.org/pool/non-free/w/w32codecs/w32codecs_20071007-0medibuntu2_i386.deb
           => `w32codecs_20071007-0medibuntu2_i386.deb'
Resolving packages.medibuntu.org... 88.191.82.11, 88.191.79.39
Connecting to packages.medibuntu.org|88.191.82.11|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 14,283,118 (14M) [application/x-debian-package]

100%[====================================>] 14,283,118 2.59M/s ETA 00:00

20:54:13 (1.42 MB/s) - `w32codecs_20071007-0medibuntu2_i386.deb' saved [14283118/14283118]

sherrie@sherrie-desktop:~$ sudo dpkg -i w32codecs_20071007-0medibuntu2_i386.deb
[sudo] password for sherrie:
Selecting previously deselected package w32codecs.
(Reading database ...
dpkg: serious warning: files list file for package `sun-java6-jre' missing, assuming package has no files currently installed.
97383 files and directories currently installed.)
Unpacking w32codecs (from w32codecs_20071007-0medibuntu2_i386.deb) ...
dpkg: dependency problems prevent configuration of w32codecs:
 w32codecs depends on libstdc++5 (>= 1:3.3.4-1); however:
  Package libstdc++5 is not installed.
dpkg: error processing w32codecs (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 w32codecs
sherrie@sherrie-desktop:~$

jodi (jodi5549) said : #28

Please can anyone help? What did I do wrong here?

Paul (treepata) said : #29

I am afraid someone else has to answer that question, I am not the expert to ask on this. But it looks like w32codecs was unable to install correctly, because some of its dependencies (other programs that w32codecs relies on) are not present yet on your PC.

First, it appears that Sun Java is not installed (correctly?) on your PC. It is recommended to install that. You can do that by going to "applications" >> "System" >> "Add/remove..." and then simply type java in the Search Box. It should be one of the first programs you get.

And maybe after that you can try to install w32codecs again. If it refuses again, read why it didn't get properly installed (maybe libstdc++5). Install those dependencies either through the Terminal, or simply use the "Synaptic package Manager" in the "System" menu as well. This is the preferred installer for all files for your PC anyway, and it wouldn't hurt to understand how it works.

Jim Campbell (jwcampbell) said : #30

I think that the w32codecs package is only available through the medibuntu
repository ( http://www.medibuntu.org/ ). To add the medibuntu repository,
follow the instructions on this page:
https://help.ubuntu.com/community/Medibuntu

Jim Campbell (jwcampbell) said : #31

Jodi - it looks like you were just attempting to individually download and install a package from the medibuntu repository, so the package manager was not able to fully pull in any dependencies that would otherwise be made available through the package repository.

If you add the medibuntu repository per the instructions in the prior link, and then enter, "sudo aptitude install w32codecs" the w32codecs software should install correctly.

Generally speaking, you want to avoid using dpkg to install software until you are comfortable with what you are doing, or have been provided with specific instructions of what to do. Most all of the software you need should be available through a repository (so you should be able to just type "sudo aptitude install [name of software].)

jodi (jodi5549) said : #32

First I think I messed the add/remove, this is what I get when I try to bring it up:

Failed to check for installed and available applications
This is a major failure of your software management system. Please check for broken packages with synaptic, check the file permissions and correctness of the file '/etc/apt/sources.list' and reload the software information with: 'sudo apt-get update' and 'sudo apt-get install -f'.

Should I try to make this right first before doing your suggestion Jim?

Jim Campbell (jwcampbell) said : #33

>
>
> Should I try to make this right first before doing your suggestion Jim?
>
>
Yes. You should fix broken packages before going forward.

'Broken packages' are packages that have unsatisfied dependencies. If broken
packages are detected, Synaptic will not allow any further changes to the
system until all broken packages have been fixed.

*To fix broken packages*

   - Open Synaptic
   -

   Choose *Edit* > *Fix Broken Packages* from the menu.
   -

   Choose *Apply Marked Changes* from the *Edit* menu or press *Ctrl + P*.
   -

   Confirm the summary of changes and click *Apply*.

If that doesn't fix the problem, let me know.

jodi (jodi5549) said : #34

Are you talking about the Synaptic Manager? If so I can't bring it up. See below the error I got. Is there another way?

You have 2 broken packages on your system!

Use the "Broken" filter to locate them.

Jim Campbell (jwcampbell) said : #35

First try, "sudo apt-get check" to see where the errors are. Then you can use a couple of dpkg commands to try and fix things.

Below I'll assume that the w32codecs package is identified as the cause of the problem. If apt-get check identifies a different package, replace that package name (or the package names) in place of w32 codecs in the command listed below.

Use the command "sudo dpkg -r w32codecs" to remove the packages causing problems, or "sudo dpkg --purge w32codecs" to remove all traces of the packages from the system, including any installation files. Both these approaches are frequently successful.

I hope this helps. :)

By the way, are you still having the problem with the cd drive and playing music? Is this issue part of that larger problem?

jodi (jodi5549) said : #36

Here is what I got with the sudo apt-get check:

sherrie@sherrie-desktop:~$ sudo apt-get check
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  w32codecs: Depends: libstdc++5 (>= 1:3.3.4-1) but it is not installed
E: Unmet dependencies. Try using -f.
sherrie@sherrie-desktop:~$

Should I proseed with sudo dpkg -r w32codecs and the purge?

jodi (jodi5549) said : #37

Yes I still cannot play music

Jim Campbell (jwcampbell) said : #38

Yes, please go ahead with the dpkg -r commands I entered previously. Then you can follow the instructions to set up the medibuntu repository ( https://help.ubuntu.com/community/Medibuntu ) and try to re-install the w32codecs package.

jodi (jodi5549) said : #39

Ok looks good to me, see below. Is this all I need, should that libsdc ++5 be there also this time? I'll close this as solved and try to play mp3 music again and if I have problems I will start new with you. Thanks so much for your help!

sherrie@sherrie-desktop:~$ sudo wget http://www.medibuntu.org/sources.list.d/hardy.list --output-document=/etc/apt/sources.list.d/medibuntu.list
[sudo] password for sherrie:
--16:56:28-- http://www.medibuntu.org/sources.list.d/hardy.list
           => `/etc/apt/sources.list.d/medibuntu.list'
Resolving www.medibuntu.org... 87.98.242.110
Connecting to www.medibuntu.org|87.98.242.110|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 226 [text/plain]

100%[====================================>] 226 --.--K/s

16:56:29 (1.96 MB/s) - `/etc/apt/sources.list.d/medibuntu.list' saved [226/226]

jodi (jodi5549) said : #40

Sorry I didn't mark problem solved right.