upgraded to 7.04 cannot reboot

Asked by Sebastian Geiger on 2007-04-23

After using the update-manager and upgrading to Ubuntu 7.04 i got the following problem after the first reboot:
When starting up Ubuntu i see the splash screen but it only grow about one millimeter and then hangs, after more than 5min the console appears with the following error:

   /bin/sh: can't access tty; job control turned off

then the system hangs....

If i press escape the GRUB menu offers the following choices:
      Ubuntu, kernel 2.6.20-15-386 //This one can not boot
      Ubuntu, kernel 2.6.20-15-386 (recovery mode) //This neither.
      Ubuntu, kernel 2.6.20-15-generic //Boots properly
      Ubuntu, kernel 2.6.20-15-generic (recovery mode)
      .... (and some older kernel options)

I used a suggestion in another answer and removed the 'slash quiet' in the GRUB edit kernel line.
Now i see the following lines before the system hangs:
     Begin: Mounting root file system ... ...
     Begin: Running /scripts/local-top ...
     Done.
     Begin: Waiting for root file system ... ...

What is the actual difference between the -386 and the -generic kernel? How can i fix the error? Where do i find more detailed log files?
How can i find out whether the upgrade finished correctly?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Vijay
Solved:
2009-01-15
Last query:
2009-01-15
Last reply:
2007-07-18
TraceyLedbetter (concept10) said : #1

Hello and thanks for the question.

You may want to make a note of the kernel that causing the lockup and file a bug report.

You might want to take a look through some of the bugs assigned to this kernel:-

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bugs

Sebastian Geiger (lanoxx) said : #3

i looked through the bugs but couldnt find any that i think would match my problem, is this a bug at all or would it be enough to reconfigure some settings?

Sebastian Geiger (lanoxx) said : #4

After the system hangs it takes about 5min. Then this appears?

BusyBox v.1.1.1.3 (Debian 1:1.1.13-3ubuntu3) Build-in shell (ash)
Enter `help` for a list of build-in commands.

/bin/sh/: can't access tty; job controll turned off
(initramfs)

Afterwards the system hangs and i have to hard restart.

Victor (victorx10) said : #5

I have the same problem, but I never bother to wait the 5min though. Everything else is identical.

I'm typing this post in the initrd.img-2.6.20-15-generic kernel.

I'd say this is a bug.

Best Vijay (vsukthankar) said : #6

Fiesty has started using libata and if u have /dev/hd defined then it would not boot. Change the menu.lst with /dev/sd based on the drive you are using..

I have installed ubuntu on my second partition of second HDD and I give /dev/sdb3.

I'm also having the same problem with 7.04 failing to boot. I've tried both the upgrade route and the clean install from the live CD with the same results. I was trying edgy eft with no problem and this boots from another drive on my system without difficulty.

Sebastian Geiger (lanoxx) said : #8

Thanks Vijay, that solved my question.