Unable to install anything on Ubuntu 6.06 Dapper Drake

Asked by Shaymus22

I'm really, REALLY sorry for all of the code I'm going to have to post. Also, something that you should know is that I'm pretty new to Ubuntu, Linux, and UNIX. I'd like to think that I've learned a lot, and I have, but in truth I know just enough to not be naive enough to think that I know anything. The reason I'm telling you this is that if you're going to post help, make sure not to leave any gaps that you might expect someone with experience to be able to fill in.

The following problems were found on your system:

With that out of the way, here's my problem:
Every time I try to install anything with Add/Remove Applications, it gives me this error (for this example, I was trying to install iPodder...the installation failed the first time):

E: /var/cache/apt/archives/libx11-6_2%3a1.0.0-0ubuntu9_i386.deb: unable to create updated files list file for package libx11-6
E: /var/cache/apt/archives/libx11-dev_2%3a1.0.0-0ubuntu9_i386.deb: unable to create updated files list file for package libx11-dev
E: /var/cache/apt/archives/locales_2.3.18.3_all.deb: unable to create updated files list file for package locales
E: /var/cache/apt/archives/makedev_2.3.1-79ubuntu1_all.deb: unable to create updated files list file for package makedev
E: /var/cache/apt/archives/app-install-data-commercial_5.5_all.deb: unable to create updated files list file for package app-install-data-commercial
E: /var/cache/apt/archives/libhal1_0.5.7-1ubuntu18.2_i386.deb: unable to create updated files list file for package libhal1
E: /var/cache/apt/archives/hal_0.5.7-1ubuntu18.2_i386.deb: unable to create updated files list file for package hal
E: /var/cache/apt/archives/hal-device-manager_0.5.7-1ubuntu18.2_all.deb: unable to create updated files list file for package hal-device-manager
E: /var/cache/apt/archives/xmms_1.2.10+cvs20050809-4ubuntu5.1_i386.deb: unable to create updated files list file for package xmms
E: /var/cache/apt/archives/python2.4-xmms_2.06-3ubuntu1_i386.deb: unable to create updated files list file for package python2.4-xmms
E: /var/cache/apt/archives/python-xmms_2.06-3ubuntu1_all.deb: unable to create updated files list file for package python-xmms
E: /var/cache/apt/archives/python-wxversion_2.6.1.2ubuntu2_all.deb: unable to create updated files list file for package python-wxversion
E: /var/cache/apt/archives/python-wxgtk2.6_2.6.1.2ubuntu2_i386.deb: unable to create updated files list file for package python-wxgtk2.6
E: /var/cache/apt/archives/python2.4-pyrss2gen_1.0.0-1_all.deb: unable to create updated files list file for package python2.4-pyrss2gen
E: /var/cache/apt/archives/python-pyrss2gen_1.0.0-1_all.deb: unable to create updated files list file for package python-pyrss2gen
E: /var/cache/apt/archives/python-feedparser_4.1-2ubuntu1_all.deb: unable to create updated files list file for package python-feedparser
E: /var/cache/apt/archives/ipodder_2.1.9-4_all.deb: unable to create updated files list file for package ipodder
E: /var/cache/apt/archives/libqt3-mt_3%3a3.3.6-1ubuntu6.2_i386.deb: unable to create updated files list file for package libqt3-mt
E: /var/cache/apt/archives/kdelibs-data_4%3a3.5.2-0ubuntu18.4_all.deb: unable to create updated files list file for package kdelibs-data
E: /var/cache/apt/archives/kdelibs4c2a_4%3a3.5.2-0ubuntu18.4_i386.deb: unable to create updated files list file for package kdelibs4c2a
E: /var/cache/apt/archives/kdelibs-bin_4%3a3.5.2-0ubuntu18.4_i386.deb: unable to create updated files list file for package kdelibs-bin
E: /var/cache/apt/archives/libhal-storage1_0.5.7-1ubuntu18.2_i386.deb: unable to create updated files list file for package libhal-storage1
E: /var/cache/apt/archives/libxine-extracodecs_1.1.1+ubuntu1-2_i386.deb: unable to create updated files list file for package libxine-extracodecs
E: /var/cache/apt/archives/linux-headers-2.6.15-28_2.6.15-28.53_i386.deb: unable to create updated files list file for package linux-headers-2.6.15-28
E: /var/cache/apt/archives/linux-headers-2.6.15-28-386_2.6.15-28.53_i386.deb: unable to create updated files list file for package linux-headers-2.6.15-28-386
E: /var/cache/apt/archives/linux-image-2.6.15-28-386_2.6.15-28.53_i386.deb: unable to create updated files list file for package linux-image-2.6.15-28-386
E: /var/cache/apt/archives/pmount_0.9.11-1ubuntu1_i386.deb: unable to create updated files list file for package pmount
E: /var/cache/apt/archives/wine_0.9.35~winehq0~ubuntu~6.06-1_i386.deb: unable to create updated files list file for package wine

If I try apt-get install ipodder, I get this (if I'm not root I use sudo apt-get install ipodder):

[there's more, but it wasn't saved by the Terminal; it's pretty much the same as what you see directly above]

dpkg: serious warning: files list file for package `usplash' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `libid3tag0' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `libcupsimage2' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `libgnutls12' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `libwrap0' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `xserver-xorg-driver-via' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `netcat' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `oclock' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `lsof' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `python2.4-soappy' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `python-pyogg' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `ttf-bengali-fonts' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `libxau6' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `liblaunchpad-integration0' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `libbtctl2' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `gnome-power-manager' missing, assuming package has no files currently installed.
65 files and directories currently installed.)
Preparing to replace libx11-6 2:1.0.0-0ubuntu9 (using .../libx11-6_2%3a1.0.0-0ubuntu9_i386.deb) ...
Unpacking replacement libx11-6 ...
dpkg: error processing /var/cache/apt/archives/libx11-6_2%3a1.0.0-0ubuntu9_i386.deb (--unpack):
 unable to create updated files list file for package libx11-6: No such file or directory
Preparing to replace libx11-dev 2:1.0.0-0ubuntu9 (using .../libx11-dev_2%3a1.0.0-0ubuntu9_i386.deb) ...
Unpacking replacement libx11-dev ...
dpkg: error processing /var/cache/apt/archives/libx11-dev_2%3a1.0.0-0ubuntu9_i386.deb (--unpack):
 unable to create updated files list file for package libx11-dev: No such file or directory
Preparing to replace locales 2.3.18.2 (using .../locales_2.3.18.3_all.deb) ...
Unpacking replacement locales ...
dpkg: error processing /var/cache/apt/archives/locales_2.3.18.3_all.deb (--unpack):
 unable to create updated files list file for package locales: No such file or directory
Preparing to replace makedev 2.3.1-79ubuntu1 (using .../makedev_2.3.1-79ubuntu1_all.deb) ...
Unpacking replacement makedev ...
dpkg: error processing /var/cache/apt/archives/makedev_2.3.1-79ubuntu1_all.deb (--unpack):
 unable to create updated files list file for package makedev: No such file or directory
Preparing to replace app-install-data-commercial 5.3 (using .../app-install-data-commercial_5.5_all.deb) ...
Unpacking replacement app-install-data-commercial ...
dpkg: error processing /var/cache/apt/archives/app-install-data-commercial_5.5_all.deb (--unpack):
 unable to create updated files list file for package app-install-data-commercial: No such file or directory
Preparing to replace libhal1 0.5.7-1ubuntu18.2 (using .../libhal1_0.5.7-1ubuntu18.2_i386.deb) ...
Unpacking replacement libhal1 ...
dpkg: error processing /var/cache/apt/archives/libhal1_0.5.7-1ubuntu18.2_i386.deb (--unpack):
 unable to create updated files list file for package libhal1: No such file or directory
Preparing to replace hal 0.5.7-1ubuntu18.2 (using .../hal_0.5.7-1ubuntu18.2_i386.deb) ...
Unpacking replacement hal ...
dpkg: error processing /var/cache/apt/archives/hal_0.5.7-1ubuntu18.2_i386.deb (--unpack):
 unable to create updated files list file for package hal: No such file or directory
Preparing to replace hal-device-manager 0.5.7-1ubuntu18.2 (using .../hal-device-manager_0.5.7-1ubuntu18.2_all.deb) ...
Unpacking replacement hal-device-manager ...
dpkg: error processing /var/cache/apt/archives/hal-device-manager_0.5.7-1ubuntu18.2_all.deb (--unpack):
 unable to create updated files list file for package hal-device-manager: No such file or directory
Preparing to replace xmms 1.2.10+cvs20050809-4ubuntu5.1 (using .../xmms_1.2.10+cvs20050809-4ubuntu5.1_i386.deb) ...
Unpacking replacement xmms ...
dpkg: error processing /var/cache/apt/archives/xmms_1.2.10+cvs20050809-4ubuntu5.1_i386.deb (--unpack):
 unable to create updated files list file for package xmms: No such file or directory
Preparing to replace python2.4-xmms 2.06-3ubuntu1 (using .../python2.4-xmms_2.06-3ubuntu1_i386.deb) ...
Unpacking replacement python2.4-xmms ...
dpkg: error processing /var/cache/apt/archives/python2.4-xmms_2.06-3ubuntu1_i386.deb (--unpack):
 unable to create updated files list file for package python2.4-xmms: No such file or directory
Preparing to replace python-xmms 2.06-3ubuntu1 (using .../python-xmms_2.06-3ubuntu1_all.deb) ...
Unpacking replacement python-xmms ...
dpkg: error processing /var/cache/apt/archives/python-xmms_2.06-3ubuntu1_all.deb (--unpack):
 unable to create updated files list file for package python-xmms: No such file or directory
Preparing to replace python-wxversion 2.6.1.2ubuntu2 (using .../python-wxversion_2.6.1.2ubuntu2_all.deb) ...
Unpacking replacement python-wxversion ...
dpkg: error processing /var/cache/apt/archives/python-wxversion_2.6.1.2ubuntu2_all.deb (--unpack):
 unable to create updated files list file for package python-wxversion: No such file or directory
Preparing to replace python-wxgtk2.6 2.6.1.2ubuntu2 (using .../python-wxgtk2.6_2.6.1.2ubuntu2_i386.deb) ...
Unpacking replacement python-wxgtk2.6 ...
dpkg: error processing /var/cache/apt/archives/python-wxgtk2.6_2.6.1.2ubuntu2_i386.deb (--unpack):
 unable to create updated files list file for package python-wxgtk2.6: No such file or directory
Preparing to replace python2.4-pyrss2gen 1.0.0-1 (using .../python2.4-pyrss2gen_1.0.0-1_all.deb) ...
Unpacking replacement python2.4-pyrss2gen ...
dpkg: error processing /var/cache/apt/archives/python2.4-pyrss2gen_1.0.0-1_all.deb (--unpack):
 unable to create updated files list file for package python2.4-pyrss2gen: No such file or directory
Preparing to replace python-pyrss2gen 1.0.0-1 (using .../python-pyrss2gen_1.0.0-1_all.deb) ...
Unpacking replacement python-pyrss2gen ...
dpkg: error processing /var/cache/apt/archives/python-pyrss2gen_1.0.0-1_all.deb (--unpack):
 unable to create updated files list file for package python-pyrss2gen: No such file or directory
Preparing to replace python-feedparser 4.1-2ubuntu1 (using .../python-feedparser_4.1-2ubuntu1_all.deb) ...
Unpacking replacement python-feedparser ...
dpkg: error processing /var/cache/apt/archives/python-feedparser_4.1-2ubuntu1_all.deb (--unpack):
 unable to create updated files list file for package python-feedparser: No such file or directory
Preparing to replace ipodder 2.1.9-4 (using .../ipodder_2.1.9-4_all.deb) ...
Unpacking replacement ipodder ...
dpkg: error processing /var/cache/apt/archives/ipodder_2.1.9-4_all.deb (--unpack):
 unable to create updated files list file for package ipodder: No such file or directory
Preparing to replace libqt3-mt 3:3.3.6-1ubuntu6.1 (using .../libqt3-mt_3%3a3.3.6-1ubuntu6.2_i386.deb) ...
Unpacking replacement libqt3-mt ...
dpkg: error processing /var/cache/apt/archives/libqt3-mt_3%3a3.3.6-1ubuntu6.2_i386.deb (--unpack):
 unable to create updated files list file for package libqt3-mt: No such file or directory
Preparing to replace kdelibs-data 4:3.5.2-0ubuntu18.3 (using .../kdelibs-data_4%3a3.5.2-0ubuntu18.4_all.deb) ...
Unpacking replacement kdelibs-data ...
dpkg: error processing /var/cache/apt/archives/kdelibs-data_4%3a3.5.2-0ubuntu18.4_all.deb (--unpack):
 unable to create updated files list file for package kdelibs-data: No such file or directory
Preparing to replace kdelibs4c2a 4:3.5.2-0ubuntu18.3 (using .../kdelibs4c2a_4%3a3.5.2-0ubuntu18.4_i386.deb) ...
Unpacking replacement kdelibs4c2a ...
dpkg: error processing /var/cache/apt/archives/kdelibs4c2a_4%3a3.5.2-0ubuntu18.4_i386.deb (--unpack):
 unable to create updated files list file for package kdelibs4c2a: No such file or directory
Preparing to replace kdelibs-bin 4:3.5.2-0ubuntu18.3 (using .../kdelibs-bin_4%3a3.5.2-0ubuntu18.4_i386.deb) ...
Unpacking replacement kdelibs-bin ...
dpkg: error processing /var/cache/apt/archives/kdelibs-bin_4%3a3.5.2-0ubuntu18.4_i386.deb (--unpack):
 unable to create updated files list file for package kdelibs-bin: No such file or directory
Preparing to replace libhal-storage1 0.5.7-1ubuntu18.2 (using .../libhal-storage1_0.5.7-1ubuntu18.2_i386.deb) ...
Unpacking replacement libhal-storage1 ...
dpkg: error processing /var/cache/apt/archives/libhal-storage1_0.5.7-1ubuntu18.2_i386.deb (--unpack):
 unable to create updated files list file for package libhal-storage1: No such file or directory
Preparing to replace libxine-extracodecs 1.1.1+ubuntu1-2 (using .../libxine-extracodecs_1.1.1+ubuntu1-2_i386.deb) ...
Unpacking replacement libxine-extracodecs ...
dpkg: error processing /var/cache/apt/archives/libxine-extracodecs_1.1.1+ubuntu1-2_i386.deb (--unpack):
 unable to create updated files list file for package libxine-extracodecs: No such file or directory
Preparing to replace linux-headers-2.6.15-28 2.6.15-28.51 (using .../linux-headers-2.6.15-28_2.6.15-28.53_i386.deb) ...
Unpacking replacement linux-headers-2.6.15-28 ...
dpkg: error processing /var/cache/apt/archives/linux-headers-2.6.15-28_2.6.15-28.53_i386.deb (--unpack):
 unable to create updated files list file for package linux-headers-2.6.15-28: No such file or directory
Preparing to replace linux-headers-2.6.15-28-386 2.6.15-28.51 (using .../linux-headers-2.6.15-28-386_2.6.15-28.53_i386.deb) ...
Unpacking replacement linux-headers-2.6.15-28-386 ...
dpkg: error processing /var/cache/apt/archives/linux-headers-2.6.15-28-386_2.6.15-28.53_i386.deb (--unpack):
 unable to create updated files list file for package linux-headers-2.6.15-28-386: No such file or directory
Preparing to replace linux-image-2.6.15-28-386 2.6.15-28.51 (using .../linux-image-2.6.15-28-386_2.6.15-28.53_i386.deb) ...
The directory /lib/modules/2.6.15-28-386 still exists. Continuing as directed.
Unpacking replacement linux-image-2.6.15-28-386 ...
dpkg: error processing /var/cache/apt/archives/linux-image-2.6.15-28-386_2.6.15-28.53_i386.deb (--unpack):
 unable to create updated files list file for package linux-image-2.6.15-28-386: No such file or directory
Preparing to replace pmount 0.9.11-1ubuntu1 (using .../pmount_0.9.11-1ubuntu1_i386.deb) ...
Unpacking replacement pmount ...
dpkg: error processing /var/cache/apt/archives/pmount_0.9.11-1ubuntu1_i386.deb (--unpack):
 unable to create updated files list file for package pmount: No such file or directory
Preparing to replace wine 0.9.34~winehq0~ubuntu~6.06-1 (using .../wine_0.9.35~winehq0~ubuntu~6.06-1_i386.deb) ...
Unpacking replacement wine ...
dpkg: error processing /var/cache/apt/archives/wine_0.9.35~winehq0~ubuntu~6.06-1_i386.deb (--unpack):
 unable to create updated files list file for package wine: No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/libx11-6_2%3a1.0.0-0ubuntu9_i386.deb
 /var/cache/apt/archives/libx11-dev_2%3a1.0.0-0ubuntu9_i386.deb
 /var/cache/apt/archives/locales_2.3.18.3_all.deb
 /var/cache/apt/archives/makedev_2.3.1-79ubuntu1_all.deb
 /var/cache/apt/archives/app-install-data-commercial_5.5_all.deb
 /var/cache/apt/archives/libhal1_0.5.7-1ubuntu18.2_i386.deb
 /var/cache/apt/archives/hal_0.5.7-1ubuntu18.2_i386.deb
 /var/cache/apt/archives/hal-device-manager_0.5.7-1ubuntu18.2_all.deb
 /var/cache/apt/archives/xmms_1.2.10+cvs20050809-4ubuntu5.1_i386.deb
 /var/cache/apt/archives/python2.4-xmms_2.06-3ubuntu1_i386.deb
 /var/cache/apt/archives/python-xmms_2.06-3ubuntu1_all.deb
 /var/cache/apt/archives/python-wxversion_2.6.1.2ubuntu2_all.deb
 /var/cache/apt/archives/python-wxgtk2.6_2.6.1.2ubuntu2_i386.deb
 /var/cache/apt/archives/python2.4-pyrss2gen_1.0.0-1_all.deb
 /var/cache/apt/archives/python-pyrss2gen_1.0.0-1_all.deb
 /var/cache/apt/archives/python-feedparser_4.1-2ubuntu1_all.deb
 /var/cache/apt/archives/ipodder_2.1.9-4_all.deb
 /var/cache/apt/archives/libqt3-mt_3%3a3.3.6-1ubuntu6.2_i386.deb
 /var/cache/apt/archives/kdelibs-data_4%3a3.5.2-0ubuntu18.4_all.deb
 /var/cache/apt/archives/kdelibs4c2a_4%3a3.5.2-0ubuntu18.4_i386.deb
 /var/cache/apt/archives/kdelibs-bin_4%3a3.5.2-0ubuntu18.4_i386.deb
 /var/cache/apt/archives/libhal-storage1_0.5.7-1ubuntu18.2_i386.deb
 /var/cache/apt/archives/libxine-extracodecs_1.1.1+ubuntu1-2_i386.deb
 /var/cache/apt/archives/linux-headers-2.6.15-28_2.6.15-28.53_i386.deb
 /var/cache/apt/archives/linux-headers-2.6.15-28-386_2.6.15-28.53_i386.deb
 /var/cache/apt/archives/linux-image-2.6.15-28-386_2.6.15-28.53_i386.deb
 /var/cache/apt/archives/pmount_0.9.11-1ubuntu1_i386.deb
 /var/cache/apt/archives/wine_0.9.35~winehq0~ubuntu~6.06-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@lee-desktop:/home#

How do I fix this?

Thank you for your time
--Shaymus22

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Someone
Solved:
Last query:
Last reply:
Revision history for this message
Shaymus22 (shaymus22) said :
#1

I pasted that wrong..."The following problems were found on your system:" should be after the second paragraph, sorry...

Revision history for this message
David Morris (dave-greenacre) said :
#2

I assume you still have space on the disk? Can you paste the results of 'df-h' on to here?

Revision history for this message
David Morris (dave-greenacre) said :
#3

sorry that should of been 'df -h'

Revision history for this message
Shaymus22 (shaymus22) said :
#4

Filesystem Size Used Avail Use% Mounted on
/dev/hdb2 14G 8.4G 4.9G 64% /
varrun 364M 128K 363M 1% /var/run
varlock 364M 4.0K 364M 1% /var/lock
udev 364M 132K 363M 1% /dev
devshm 364M 0 364M 0% /dev/shm
lrm 364M 19M 345M 6% /lib/modules/2.6.15-28-386/volatile
/dev/hda1 5.6G 4.6G 987M 83% /media/hda1
/dev/hda2 33G 29G 3.8G 89% /media/hda2
/dev/hdb1 96G 68G 29G 71% /media/hdb1
/dev/sda1 233G 106G 127G 46% /media/sda1

Revision history for this message
Shaymus22 (shaymus22) said :
#5

I tried after moving files off of the Ubuntu partition, and it has >9GB free...the problem is still there

Revision history for this message
Alan Pope 🍺🐧🐱 πŸ¦„ (popey) said :
#6

Can you please put a copy of your /etc/apt/sources.list in http://pastebin.ubuntu-uk.org/ for us to study? You can open it by pressing ALT+F2 then running:-

gedit /etc/apt/sources.list

Could you also run the following command in a terminal (Applications --> Accessories --> Terminal) and pastebin the output?

sudo apt-get update

Revision history for this message
Shaymus22 (shaymus22) said :
#7

http://pastebin.ubuntu-uk.org/87 (/etc/apt/sources.list)

http://pastebin.ubuntu-uk.org/88 (sudo apt-get update)

Revision history for this message
Shaymus22 (shaymus22) said :
#8

It's still doesn't work

Revision history for this message
Ralph Janke (txwikinger) said :
#9

Why don't you just delete all the package in your local cache archive and let them be downloaded again when you install them.

sudo rm /var/cache/apt/archives/*
sudo apt-get update
sudo apt-get install -f

I hope this helps

Revision history for this message
Shaymus22 (shaymus22) said :
#10

It looked like it did, because it started downloading stuff, but then this again:
http://pastebin.ubuntu-uk.org/98

Revision history for this message
Ralph Janke (txwikinger) said :
#11

Ok.. maybe apt-get can fix that with the clean command. Please do

sudo apt-get clean
sudo apt-get update
sudo apt-get install -f

I hope this helps

Revision history for this message
Shaymus22 (shaymus22) said :
#12

Nope...it still didn't work :(

The one thing that is always constant is
E: Sub-process /usr/bin/dpkg returned an error code (1)
at the very end...since it always shows up, maybe that's the problem?

It's funny that I don't really even understand what it means, yet I'm suggesting that it might be important :)

Revision history for this message
Someone (s4910321931-deactivatedaccount) said :
#13

Your /var/lib/dpkg/info directory is likely to be corrupted or has permissions problems.

for me 'ls -ld /var/lib/dpkg/info' produces:
drwxr-xr-x 2 root root 159744 2007-04-28 13:18 /var/lib/dpkg/info

What is yours?

Revision history for this message
Shaymus22 (shaymus22) said :
#14

Holy crap...

ls: /var/lib/dpkg/info: No such file or directory

Revision history for this message
Ralph Janke (txwikinger) said :
#15

This is not good. This directory contains among other things all the information about the packages that are installed on your system.

Revision history for this message
Shaymus22 (shaymus22) said :
#16

Is there any way that I can get a copy of the files, etcetera? How should I proceed?

Revision history for this message
Ralph Janke (txwikinger) said :
#17

If you would know all the packages, you might be able to recover the contents of the directory with

apt-get install -d <packagename>

to download it back into your cache and

dkpg-reconfigure <packagename>

to recreate all the information.

However, I have never done this, so this is rather theoretical. Maybe a dpkg-reconfigure -a (reconfigure all packages) might work, however, I doubt it does without the packages in the local cache.

One question.. how did the information get lost? Do you think you have a disk that is going bad?

Revision history for this message
Shaymus22 (shaymus22) said :
#18

I have no idea...I hope that nothing is wrong with any hardware. Nothing that I'm using is particularly old, but then again some things break hours out of the box, so who knows.

Could I possibly use the process you've described on each of the packages that are listed as encountering errors in the terminal?

Example (source of this is at the top of this page):
dpkg: serious warning: files list file for package `usplash' missing, assuming package has no files currently installed.

Revision history for this message
Shaymus22 (shaymus22) said :
#19

lee@lee-desktop:~$ sudo apt-get install -d libx11-6
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
  app-install-data-commercial ipodder kdelibs-bin kdelibs-data kdelibs4c2a
  libqt3-mt libx11-dev libxine-extracodecs linux-headers-2.6.15-28
  linux-headers-2.6.15-28-386 linux-image-2.6.15-28-386 locales
  python-feedparser python-pyrss2gen python-wxgtk2.6 python-wxversion
  python-xmms python2.4-pyrss2gen python2.4-xmms wine xmms
Suggested packages:
  libqt3-mt-psql libqt3-mt-mysql libqt3-mt-odbc linux-doc-2.6.15
  linux-source-2.6.15 wx2.6-doc wx2.6-examples python-xmms-doc msttcorefonts
Recommended packages:
  perl-suid lilo libmikmod2
The following packages will be upgraded:
  app-install-data-commercial ipodder kdelibs-bin kdelibs-data kdelibs4c2a
  libqt3-mt libx11-6 libx11-dev libxine-extracodecs linux-headers-2.6.15-28
  linux-headers-2.6.15-28-386 linux-image-2.6.15-28-386 locales
  python-feedparser python-pyrss2gen python-wxgtk2.6 python-wxversion
  python-xmms python2.4-pyrss2gen python2.4-xmms wine xmms
22 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.
28 not fully installed or removed.
Need to get 1950kB/70.2MB of archives.
After unpacking 25.6MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://security.ubuntu.com dapper-security/main libx11-dev 2:1.0.0-0ubuntu9.1 [1240kB]
Get:2 http://security.ubuntu.com dapper-security/main libx11-6 2:1.0.0-0ubuntu9.1 [710kB]
Fetched 1950kB in 15s (128kB/s)
Download complete and in download only mode
lee@lee-desktop:~$ sudo dpkg-reconfigure libx11-6
/usr/sbin/dpkg-reconfigure: libx11-6 is broken or not fully installed

Revision history for this message
Shaymus22 (shaymus22) said :
#20

Since I saw that the package was listed as being broken, I tried going into the Synaptic Package Manager and using the custom filter 'Broken' to search for broken packages that Synaptic could possibly fix...when I hit refresh, this came up:

The following problems were found on your system:
W: Duplicate sources.list entry http://security.ubuntu.com dapper-security/universe Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_dapper-security_universe_binary-i386_Packages)

Revision history for this message
Ralph Janke (txwikinger) said :
#21

Check if you have duplicate entries in your sources.list file in /etc/apt/ directory including the entries in any file in /etc/apt/sources.list.d/

Revision history for this message
Shaymus22 (shaymus22) said :
#22

sources.list - http://pastebin.ubuntu-uk.org/106

lee@lee-desktop:~$ dir /etc/apt/sources.list.d/
dapper-universe.list dapper-universe.list.save winehq.list winehq.list.sav

I checked each of those four files in /etc/apt/sources.list.d/ and no two lines are the same, if that's what you mean by duplicate entries

Revision history for this message
Ralph Janke (txwikinger) said :
#23

What is in those 4 files in /etc/apt/sources.list.d/ ?

I think, dapper-universe.list and dapper-universe.list.save have the same entries... You can't be as far as I know.

I hope this helps

Revision history for this message
Shaymus22 (shaymus22) said :
#24

Do you mean that they are not supposed to have the same entries? I ask because they do...how can I fix this?
By the way, it says that they're Read Only...how do I make them writable?

dapper-universe.list:

# automatically added by gnome-app-install on 2007-04-06 20:59:10.300591
deb http://security.ubuntu.com/ubuntu dapper-security universe
deb http://us.archive.ubuntu.com/ubuntu/ dapper-updates universe

dapper-universe.list.save:

# automatically added by gnome-app-install on 2007-04-06 20:59:10.300591
deb http://security.ubuntu.com/ubuntu dapper-security universe
deb http://us.archive.ubuntu.com/ubuntu/ dapper-updates universe

winehq.list:

## WineHQ - Ubuntu 6.06 LTS "dapper drake"
deb http://wine.budgetdedicated.com/apt dapper main
deb-src http://wine.budgetdedicated.com/apt dapper main

winehq.list.save:

## WineHQ - Ubuntu 6.06 LTS "dapper drake"
deb http://wine.budgetdedicated.com/apt dapper main
deb-src http://wine.budgetdedicated.com/apt dapper main

Revision history for this message
Shaymus22 (shaymus22) said :
#25

It still doesn't work!

Revision history for this message
Ralph Janke (txwikinger) said :
#26

You shouldn't have the .sav files in that directory.. move them somewhere else

You can do that with

sudo mv <filename> <target>

where <filename> is the file you want to move and <target> is the path to the destination.

Revision history for this message
Shaymus22 (shaymus22) said :
#27

I successfully moved the .sav files to /etc/apt/newfolder

However, it still doesn't work, and returns the same error messgae.

Revision history for this message
Ralph Janke (txwikinger) said :
#28

This is because the entries of the file dapper-universe.list are probably also in the /etc/apt/sources.list file which is read too. You should mv the dapper-universe.list too (check also about the wine file, I don't remember if those entry have been in the normal sources list).

Revision history for this message
Someone (s4910321931-deactivatedaccount) said :
#29

The first thing is to fix the directory.

For me 'dpkg -S /var/lib/dpkg' shows
base-files, dpkg, dselect: /var/lib/dpkg
So install these three packages first:
apt-get install base-files dpkg dselect --reinstall -y
That should give you a basic /var/lib/dpkg directory.

SIDENOTE
If you had an intact /var/lib/dpkg directory the commands below would help:

Reistall everything:
ALL=`apt-show-versions | sed '{s/[\/ ].*//}' | wc -l`; I=0; for P in `apt-show-versions | sed '{s/[\/ ].*//}'`; do let I=I+1; echo; echo " Installing $P ($I/$ALL)" ; apt-get -y --force-yes -qq --reinstall install $P ; done

Redownload everything:
ALL=`apt-show-versions | sed '{s/[\/ ].*//}' | wc -l`; I=0; for P in `apt-show-versions | sed '{s/[\/ ].*//}'`; do let I=I+1; echo; echo " Downloading $P ($I/$ALL)" ; apt-get -dy --force-yes --reinstall install $P ; done

You need apt-show-versions package installed for that.
END OF SIDE NOTE

The second step is to resurrect the package list and reinstall every package.
The following may work:
ls -1 /usr/share/doc | xargs apt-get -n 1 install -y --reinstall
There may be some complaints from apt-get because not all in /usr/share/doc directly maps to package name.
As the final step ensure that 3 essential packages are installed after all:

apt-get install kubuntu-desktop ubuntu-standard ubuntu-minimal
for Kubuntu, or
apt-get install ubuntu-desktop ubuntu-standard ubuntu-minimal
for Ubuntu.
Hope that helps.

Revision history for this message
Shaymus22 (shaymus22) said :
#30

@Ralph Janke - it still didn't work after I did what you said

@Dennis P. Nikolaenko - it returned the same dpkg errors as above when I tried
apt-get install base-files dpkg dselect --reinstall -y

when I tried
ls -1 /usr/share/doc | xargs apt-get -n 1 install -y --reinstall
I got an error about [-n]

I'm not sure what the | in command lines are, but I've always assumed that it means that the commands are on a seperate line.
ls -1 /usr/share/doc
worked fine, but when I did
xargs apt-get -n 1 install -y --reinstall
it seems to have hung the terminal.
Is this supposed to take a long time? It's been quite a while.

Revision history for this message
Shaymus22 (shaymus22) said :
#31

AH! Dennis P. Nikolaenko, I can now install stuff on my system. Thank you so much! It was the final step that did it, I think.
However, I still get all of the dpkg error messages, even though it works perfectly.

If I mark you as the one who solved my question, will you still be able to reply with an answer to help me with this?

Revision history for this message
Best Someone (s4910321931-deactivatedaccount) said :
#32

Oops, that was a typo!
The command should be

ls -1 /usr/share/doc | xargs -n 1 apt-get install -y --reinstall

Vertiacals bars "|" are part of the commands, they are _not_ line separators.

Doing all the steps in sequence again will not hurt at all, so do it and the errror messages should go away completely.

Revision history for this message
Shaymus22 (shaymus22) said :
#33

Thanks Dennis P. Nikolaenko, that solved my question.

Revision history for this message
Sergio de la Cruz (sergiodlc) said :
#34

I had pretty much the same problem of Shaymus22 and the comments of Dennis P. Nikolaenko were the key to solve my problem. At first I tried what he suggested but failed. Once I realized that my /var/lib/dpkg/info/ directory was missing I created it manually (sudo mkdir /var/lib/dpkg/info/) and then repeated Nikolaenko's instructions. After that everything worked like a charm... almost.

I was allowed to install any package but every time I ran apt-get it complained about some trouble with the gnupg-curl package. I removed that package and manually deleted the files in /usr/lib/gnupg/ and reinstalled the package afterwards. Everything begun to work again without issues.