ndiswrapper won't load in feisty

Asked by Neal Gompa on 2007-04-22

I just did a clean install of Feisty Fawn and i downloaded the debian packages for ndiswrapper needed to use it. I installed wifi drivers for Netgear WG111T USB adapter and did sudo depmod -a and sudo modprobe ndiswrapper. The problem is that it wont initalize the wifi device. I dont think the ndiswrapper module is even working! Using default kernel packaged with Feisty CD. It should have activated the wifi device and allowed me to choose a network to connect to. Yet, none of that is happening. Restarting the PC doesnt do anything either.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-04-22
Last reply:
2007-04-27
Javier Jardón (jjardon) said : #1

This card work with native drivers (not install ndiswrapper). http://prism54.org/newdrivers.html

please get me the output of the command: "iwlis scan" and teh content of your "/etc/network/interfaces" file

Javier Jardón (jjardon) said : #2

please get me the output of the command: "iwlis scan" and teh content of your "/etc/network/interfaces" file

Alvaro Ballesteros (barian-26) said : #3

Javier:

I have the same problem, my laptop Thinkpad T40 2374 with a ADMtek 8211 wifi card was working excelent with Edgy (after installing ndiswrapper and configuring with iwconfig). But when I upgraded to feisty, I have tried several tools, without success. Here are some of my info:

iwconfig
no wireless extensions.

eth0 no wireless extensions.

irda0 no wireless extensions.

wmaster0 IEEE 802.11b Frequency:2.412 GHz
          RTS thr:off Fragment thr=2346 B

eth1 IEEE 802.11b ESSID:"INFINITUM2769"
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          RTS thr:off Fragment thr=2346 B
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

irda0 Interface doesn't support scanning.

wmaster0 Failed to read scan data : Operation not supported

eth1 No scan results

/etc/network/interfaces

auto lo
iface lo inet loopback

iface eth1 inet dhcp
wireless-essid INFINITUM2769
wireless-key 1292301050

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp

iface eth0 inet dhcp

auto eth0

iface wmaster0 inet dhcp
wireless-essid INFINITUM2769
wireless-key 1292301050

auto eth1

Thank you

Javier Jardón (jjardon) said : #4

Hello Alvaro!

Please, comment all network interfaces except lo and restart computer (https://help.ubuntu.com/community/WifiDocs/NetworkManager)

froggy2006 (froggy2006) said : #5

Hello Everyone!
    I'm still quite new to Linux Ubuntu but I'm a very skilled PC/Windows user. I just switched from Windows XP to Ubuntu and now my wireless adapter is not working. I tried installing ndiswrapper but it would not install. I need a solution for this. My adapter is a TEW-423PI PCI Card. Thanks for your time!

Froggy
Head Webmaster for SaiyanPride.TK

Javier Jardón (jjardon) said : #6

Hello froggy2006, give me the ouput of command lspci and the file /etc/network/interfaces

froggy2006 (froggy2006) said : #7

00:00.0 Host bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 01)
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
02:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:09.0 Ethernet controller: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless (rev 03)

froggy2006 (froggy2006) said : #8

/etc/network/interfaces:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

Javier Jardón (jjardon) said : #9

You card is not supported by a native driver :-(
See https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper to use the windows driver in linux

Can you help with this problem?

Provide an answer of your own, or ask Neal Gompa for more information if necessary.

To post a message you must log in.