Firefox doesn't know how to open this address, because the protocol (smb) isn't associated with any program.

Asked by Peyre on 2008-12-11

I have a fresh install of Xubuntu 8.10, fully updated and with both tksmb and smb4k installed. Yet when I open Firefox and enter "smb://hostname" (yes, I'm entering the destination host name, not the word "hostname"), the browser returns this error. I'm plugged into the wired network. When I try it at work, I've set it to the same proxy server settings we use at work, and when I try it at home I have it set not to use the proxy server. Anyone know what might be causing this?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Jim Campbell (jwcampbell) said :

Hi there,

I'm guessing that you might be using Windows at work, but Xubuntu at home? Unfortunately, Xfce does not natively support the browsing of Samba shares at this time.

You may try using FUSESMB to arrange for Samba support from within Xubuntu (you can search google for how to set this up), but that might not be an ideal situation for you. It's likely that Xubuntu will include some kind of application that will allow for the mounting of Samba shares (maybe not native to Thunar, the Xfce file manager, though) in the 9.04 release.

Revision history for this message
Peyre (lordpeyre) said :

Thanks Jim! Well that explains it.

Actually no, I installed Xubuntu on two machines, one at home and one at work. Both were giving the same error.

But if it's doing that because Xubuntu doesn't support browsing Samba shares (i.e., it's not doing it because it's not set up to do it), then I can stop beating my head against the wall. That's too bad though--I was really getting to like Xubuntu, but I do need to be able to browse Samba shares. Maybe I'll go back to experimenting with plain Ubuntu.