Flash player install help needed

Asked by krdan4th

Hello again all alright I am having a bit of a problem I went to upgrade to 8.10 from 8.04 when everything had already been running amazingly smooth no problems at all. once I completed the upgrade I noticed that I couldn't watch videos,and before the page could load with the video firefox would crash. So I was like alright I am installing 8.04 all over again, I did so, and now I can't remember how to get flash player to work again it says that i need to install adobe flash player so i click on the link and than pick the Ubuntu version of the download, I download it and than once it finishes and (package installer- adobe-flashplugin) opens up next to status it says "Error: Wrong architecture 'i386'" in red print. What does this mean and what do I do to get flash player to work. i tried deleting flash that came preinstalled on Ubuntu and reinstalling the previous version but that was a no go.

Oh and it is of any help the file i was trying to download said ".deb for Ubuntu 8.04+"

Thank you so much

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Marcin Ostajewski (panszpik) (panszpik) said :

Maybe You have an AMD processor?
[packages are often designed for specific system architecture, that may be the reason of this error]

Can You give me Your hardware specs?

Or You can install the player via Synaptic:
1) Applications->System->Synaptic Package Manager
2) Click search -> adobe
[you should have adobe-flashplugin in the results]
3) mark the package for install [right-click on package and choose appropriate command]
4) Click Apply

[synaptic should get the version compatible with Your processor]

If everything goes right, videos should work

Best regards

Revision history for this message
krdan4th (krdan4th) said :

Yes I do have an AMD processor, I had read a different thread and some one said they installed ubuntu restricted package through synaptic. so i tried that, can play a few videos but not all, can't stream music either and now when there is supposed to be a flash video there is a big round play button, and say if i click the menu button on the browser if the add or video is close to it the menu will appear behind it (rather annoying). Should I uninstall it? Would getting flash to work be my better bet?

And my hard ware specs are:
AMD athlon x2 4400+
OCZ GTX8800 video card
2 gigs ram (2 sticks of 1 gig) PQI turbo
2x 320 gig hard drives ones hitatchi other is western digital
(Ubuntu one XP on other)
ASUSE M2N SLI deluxe motherboard

my PC was originally built for gamming
thats why i still have windows :-/

anything else i left out let me know

And thanks for your time!

Revision history for this message
krdan4th (krdan4th) said :

I tryed searching adobe and nothing showed in the results. no adobe.

Revision history for this message
Fabián Rodríguez (magicfab) said :

Go to Applications > Add/Remove, make sure "All applications" is the search scope. Search for "Flash".

I am not on an Intrepid system right now but you should be presented with Flash-non free or a similar plugin. That will download an installer and it will complete the required configuration.

There is no need to manually download and install Flash software, several sites try to be smart about that and present such options which are not needed in Ubuntu.

Revision history for this message
Sam_ (and-sam) said :

btw. there is no guarantee that any flash, either adobe, gnash, or other apps are working well on any website.

Revision history for this message
Steve (sauls1967) said :

go to a terminal
issue the following command
sudo apt-get install ubuntu-restricted-extras
logout and then log back in
***** this installs flash and all of the codecs ******
***** even on 64 bit ubuntu it takes care of installing the compatability layer for the 32bit flash plugin.****

Revision history for this message
krdan4th (krdan4th) said :

I had already installed the restricted packages. And it didn't help anything And before I had to reinstall Ubuntu every thing was working flawlessly even flash player no matter what site I went to it would play any flash file/media that it threw at me. Oh yea I am not on intrepid I am still using Hardy 8.04. I tryed deleting and reinstalled the restricted extras package a few times and nothing work and than. Should I upgrade to intrepid would that make everything work a little better.
I can play you tube videos fine but if i am on a different site the videos never load once i click on them.

Revision history for this message
Sam_ (and-sam) said :

You are right, I have to restrict my comment because I don't use restricted-extras.

However, if you didn't experience problems with AMD before, either Hardy or Intrepid provide the package flashplugin-nonfree (multiverse).
You may pay attention to conflicts of different versions of flash.
locate libflashplayer.so

or check plugins in firefox.
If installed correctly and still doesn't work, you may remove or rename the profile in ~.mozilla.

Revision history for this message
krdan4th (krdan4th) said :

where would I go to remove that profile in mozilla

I just can't remember what I did to get flash player working properly after the first time I installed Ubuntu. Its not the biggest problem its just one of those little problems that really annoying.

Revision history for this message
krdan4th (krdan4th) said :

and would I be able to find libflashplayer.so in the lib folder.

Revision history for this message
Sam_ (and-sam) said :

The mentioned command should give you an answer
locate libflashplayer.so

Options of path:


e.g. if in case downloaded from here

In case of renaming ~/.mozilla
save bookmarks and be aware of reinstalling extensions
mv .mozilla .mozilla.old

or in Nautilus with right click

a restart of firefox will create a new .mozilla folder.
The .old backup can be used for reimporting bookmarks.
If everything works it can be removed.

Revision history for this message
krdan4th (krdan4th) said :

hmmm i noticed that i don't have a lib folder in usr but there are a lot of lib files and no there isn't a flash one. would it be safe to put all those files into a folder tittled lib and extract flash player to there.

Revision history for this message
Sam_ (and-sam) said :

I'm sorry, if you're sure, there is no lib in /usr, please don't "play manually" in this directory. But obviously there is something very wrong and you should solve this problem as priority with a new question.
Option is new installation

Please give the output from
uname -a
lsb_release -a

Revision history for this message
krdan4th (krdan4th) said :

Oh never mind I found a lib folder under the usr directory I found it using the ls command after cding to the usr directory through terminal. And I still didn't find that libflashplayer.so file nor is there an adobe folder. I don't mind working through the terminal even tho I am a noob to Linux if you can explain to me what i should do through terminal that would be very much appreciated and thank you so much for taking time out of your day to help me out.

Revision history for this message
Sam_ (and-sam) said :

Ok, for a correct diagnose please post the output from mentioned commands:
uname -a
lsb_release -a
dpkg -l firefox

Then, please look in firefox for plugins
e.g. in the url bar type:

check if there is any flash, shockwave, macromedia or whatever related to flash.

Revision history for this message
krdan4th (krdan4th) said :

uname -a 2.6.24-22-generic #1 SMP Mon Nov 24 19:35:06 UTC 2008 x86_64 GNU/Linux

Distributor ID: Ubuntu
Description: Ubuntu 8.04.1
Release: 8.04
Codename: Hardy
dpkg -l firefox Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
ii firefox 3.0.4+nobinonl meta package for the popular mozilla web bro

Shockwave Flash

    File name: libswfdecmozilla.so
    Shockwave Flash 9.0 r100

application/x-shockwave-flash Adobe Flash movie swf Yes
application/futuresplash FutureSplash movie spl Yes

and thats what I saw when I typed in about:plugins
just taking a guess, that whole list, is that all the plugins that I have pluged in?

Revision history for this message
Sam_ (and-sam) said :

Yes, that is the list of plugins which firefox is recognizing as such.
You have swfdec installed.
So my suggestion is to remove swfdec to avoid conflicts. You can do this by search in Synaptic: swfdec
Then right click on packages which are installed and remove completely.
Don't have firefox running during the procedure.
It's up to you then installing either flashplugin-nonfree, reinstalling restriced-extras or direct from adobe website flashplayer 10 for linux, anyway keep in mind the amd64 architecture.

Testsite for flash

Revision history for this message
Sam_ (and-sam) said :

flashplugin-nonfree for Hardy LTS 8.04 wont install directly, it takes the path around to adobe, and this doesn't currently work. So in case it's recommended to install the .deb from adobe.

Revision history for this message
Sam_ (and-sam) said :

Hi again,
so for you to reproduce I did a test case, since I have a amd64 with Hardy LTS 8.04.

I've removed my swfdec complete with Synaptic, download the alpha version from here
and save it to the desktop.

Because I didn't have one, created a new folder 'plugins' in my home directory

Then unpack the archive and move the file 'libflashplayer.so' in there.
Start firefox and voila it works out of the box.
Finished and no big deal, until now no trouble on a website.
The downloaded archive can be removed.
Keep in mind there will be off course no security update within the Ubuntu structure, because it's a third party module, so actually it's not recommended.

In Intrepid the 'flashplugin-nonfree' from the official repositories shouldn't make a problem.
Before installing the alpha version should be removed to avoid conflicts.

Revision history for this message
krdan4th (krdan4th) said :

I am having a hard time finding the plugins folder I may not have one but where would I go to find/create the folder.

I am wondering would it be safe to unpack the package to my lib64 folder.

Revision history for this message
krdan4th (krdan4th) said :

ok scratch that of course I found the folder after i sent that. So do I want to extract the package to that plugins folder

Revision history for this message
Sam_ (and-sam) said :

please don't think about any lib folder within the root directory, we only talk about your home/user directory.
In there you've found the .mozilla/plugins folder and in this one only you move only the content of the archive, which is only one file, the 'libflashplayer.so'. Then start firefox and enjoy.
##This subject was about installing manually without a package manager e.g. Synaptic, hence without root privilege.

If installing with Synaptic, lets say on Intrepid, the 'flashplugin-nonfree' will be automatically placed in the correct path within the root directory, hence with root privilege.

Again, to avoid conflicts try to make sure only one flashplugin at the same time is installed.

To view plugins another option as mentioned above is in firefox -> extras -> addons -> plugins.

Can you help with this problem?

Provide an answer of your own, or ask krdan4th for more information if necessary.

To post a message you must log in.