Can't locate object method "save_parsers_debian" via package "XML::SAX"

Asked by Anahit on 2008-12-02

Hi,

Could help me,when I install this packages I have the message listing below, mostly "Can't locate object method "save_parsers_debian" via package "XML::SAX" at /usr/bin/update-perl-sax-parsers line 90."

Could you tell,how to fix this?
I use Ubuntu7.10

root@flibkoha-desktop:/usr/share/idzebra-2.0-examples/oai-pmh# apt-get install libxml-sax-perl libxml-libxml-perl libxml-libxslt-perl libxml-simple-perl libxml-sax-expat-perl Reading package lists... Done
Building dependency tree
Reading state information... Done
libxml-sax-perl is already the newest version.
libxml-sax-perl set to manual installed.
libxml-libxml-perl is already the newest version.
libxml-libxslt-perl is already the newest version.
libxml-simple-perl is already the newest version.
libxml-sax-expat-perl is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 215 not upgraded.
5 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up libxml-sax-perl (0.14-0.1) ...
Can't locate object method "save_parsers_debian" via package "XML::SAX" at /usr/bin/update-perl-sax-parsers line 90.
dpkg: error processing libxml-sax-perl (--configure):
 subprocess post-installation script returned error exit status 255
dpkg: dependency problems prevent configuration of libxml-libxml-perl:
 libxml-libxml-perl depends on libxml-sax-perl (>= 0.11); however:
  Package libxml-sax-perl is not configured yet.
dpkg: error processing libxml-libxml-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxml-libxslt-perl:
 libxml-libxslt-perl depends on libxml-libxml-perl (>= 1.59); however:
  Package libxml-libxml-perl is not configured yet.
dpkg: error processing libxml-libxslt-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxml-sax-expat-perl:
 libxml-sax-expat-perl depends on libxml-sax-perl (>= 0.03); however:
  Package libxml-sax-perl is not configured yet.
dpkg: error processing libxml-sax-expat-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxml-simple-perl:
 libxml-simple-perl depends on libxml-sax-perl; however:
  Package libxml-sax-perl is not configured yet.
 libxml-simple-perl depends on libxml-libxml-perl | libxml-sax-expat-perl; however:
  Package libxml-libxml-perl is not configured yet.
  Package libxml-sax-expat-perl is not configured yet.
dpkg: error processing libxml-simple-perl (--configure):
 dependency problems - leaving unconfigured Errors were encountered while processing:
 libxml-sax-perl
 libxml-libxml-perl
 libxml-libxslt-perl
 libxml-sax-expat-perl
 libxml-simple-perl
E: Sub-process /usr/bin/dpkg returned an error code (1)

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-12-02
Last reply:
2008-12-17
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.