No trash on external drive

Asked by Dan Wolff on 2008-11-29

The trash for my external drive seems to be gone. When I delete something from my external drive I get the dialog telling me that the file can't be moved to trash, and asking if I'd like to remove it immediately.

I'm using Ubuntu 8.10.
I don't know if it matters - but the owner of the drive's folder is root - and that's impossible to change (AFAIK), even when logged in as root.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-12-04
Last reply:
2008-12-20
Andre Mangan (kyphi) said : #1

The "Trash" folder on your external hard drive is a hidden folder. To make it visible press Ctrl+h.

Right click on the Trash folder and go to Properties, Permissions and see who owns this folder. If it Root, for example, you need to change it so that it is owned by you (sudo chown <your_name>:<your_name> <path to trash folder>).

Similarly you can change the owner of the drive or you can do both in one go:
sudo chown <your_name>:<your_name> -R /media/disk (If that is the path to your external drive).

You may also have to reset permissions (sudo chmod -R 755 /media/disk).

You will have to adjust the path statements to suit your setup.

Wyatt Smith (wyatt-smith) said : #2

Sounds like the external drive is format as NTFS. Drives with this format do not use #NIX type permissions. They are given assigned ownership and permission when mounted.

To enable a trash can on a NTFS partition you will have to make an entry in your /etc/fstab file. You must specify the drive by UUID and assign a userid.

To discovery the UUID of the external drive. Please plug the drive in and then type

sudo blkid

To edit your fstab file with root permission

gksu gedit /etc/fstab

Here is an example of how the entry should look. Please replace the UUID and mountpoint with the appropriate values from your system

# NTFS Partitions
UUID=19031A6158945892 /media/DATA ntfs-3g defaults,uid=1000,locale=en_US.UTF-8 0 0

Save and exit.

To remount (unmount then mount) all drives listed in /etc/fstab

sudo umount -a
sudo mount -a

You should then see a hidden trash folder on your ntfs drive.

Hope this helps

Dan Wolff (dan-wolff) said : #3

Thanks, a lot, but...

@Andre
Nothing happened - permissions and owner are still the same.

@Wyatt
Yes, it's an NTFS drive.
blkid results in:
...
/dev/sdb1: UUID="4FB271F7329883F8" LABEL="Extern" TYPE="ntfs"
Even though the type given is "ntfs" it should be "ntfs-3g" in the fstab? Either way leads to the following:

When running umount not everything is unmounted (I think the hard drive of the computer is listed there too), but the external drive is, so I guess not anything else has to be unmounted.

When mounting again nothing happens and I get the following error message:
>> fuse: failed to access mountpoint /media/DATA: No such file or directory
When trying to mount via the GUI I get the following error messages:
>> ... mount: only root can mount /dev/sdb1 on /media/DATA
>> Could not mount Extern: DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Thanks so far.

Wyatt Smith (wyatt-smith) said : #4

From your output, looks like you haven´t created a mountpoint. You can name the mountpoint anything you would like. Just remember that you will have to create the mountpoint in your media folder with root privilege using sudo. For example you can try

sudo mkdir /media/External

Then the corresponding entry in /etc/fstab would look like...

# NTFS Partitions
UUID=4FB271F7329883F8 /media/External ntfs-3g defaults,uid=1000,locale=en_US.UTF-8 0 0

And yes, it should be ntfs-3g.

Please let me know how you make out.

Thanks

Dan Wolff (dan-wolff) said : #5

Well, it sort of works. The trash works as expected, and I can mount and unmount the drive with terminal, but when I try to mount/unmount with Nautilus it tells me that only root may mount/unmount.

Another problem is that other users can't use the trash on the drive.

Wyatt Smith (wyatt-smith) said : #6

Sorry, the mounting options I gave were for an internal drive with a single user.

Please try changing to the following mounting options

# NTFS Partitions
UUID=4FB271F7329883F8 /media/External ntfs-3g rw,suid,dev,exec,auto,async,user,uid=1000,gid=100,umask=000,locale=en_US.UTF-8 0 0

Hope this helps

Dan Wolff (dan-wolff) said : #7

Doesn't work:
* other users than me (e.g. user with ID 1001) can't use the trash
* I still can't mount via Nautilus, but I got another error message this time:
*>when mounting: Unprivileged user can not mount NTFS block devices using the external FUSE library. Either mount the volume as root, or rebuild NTFS-3G with integrated FUSE support and make it setuid root. Please see more information at http://ntfs-3g.org/support.html#unprivileged
*>when unmounting: only root can unmount UUID=4F...F8 from /media/External

I don't really understand the link they gave.

Wyatt Smith (wyatt-smith) said : #8

Any drive mounted in /etc/fstab can only be unmounted with as root with sudo command from terminal.

The group id, gid=100, is typically the user group, which all users should be a member of. The option umask=000 sets all the files with 777 permission. To find out more about mount options, you can look at

man mount

Sorry if I can´t be of more help. I believe that this is a persistent issue in regards to multiple user systems with external drives.

Dan Wolff (dan-wolff) said : #9

Well, if the /etc/fstab drives can only be (un)mounted as root I'd rather not be able to have a trash can.
Unfortunate, but if there isn't a better solution there isn't anything to do about it.

Thanks for all your help.

Launchpad Janitor (janitor) said : #10

This question was expired because it remained in the 'Open' state without activity for the last 15 days.