Can't set native resolution on Toshiba R20 laptop

Asked by Wladston Viana on 2007-04-20

After having problems to install ubuntu (see bug #107113) and installing on the text mode, I can't set the screen resolution to it's normal size (1440x900).

I have already tried the dpkg-reconfigure, selecting 1440x900, but that mode isn't still available on the "Screen Resolution" dialog. (Should this be filled as a bug ??)

I have heard about a "915resolution" hack to the kernel, but, as a simple end-user, I wish to know if there is an easy way to correctly set my resolution.

Thanks for the attention!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Wladston Viana
Solved:
2007-04-23
Last query:
2007-04-23
Last reply:
2007-04-23

boot into recovery mode, and when prompted, log into terminal as root,

then type 'sudo dpkg-reconfigure xserver-xorg'

follow the instructions, and your display should, if things go well, restore itself

Wladston Viana (wladston) said : #2

Sam,

Did EXACTLY as you said. Booted on safe mode, entered the command. Selected i810 as the video driver. I have set the "kernel Framebuffer" to disable (the default, i guess). Left the modules as "default" too.

On "video modes to be used by X server", I let the default go - with was the resolution that I wanted - 1550x900. It only marked THAT option on the list. When it asked for the refresh rates, I searched the manual and the online specification, and couldn't find it. Left it to the default - the only mode option I had for my native resolution was "1440x900 @ 100Hz". I have selected that one.

Selected 24 bits color depth.

When it was over, I entered "startx". The end-result is that I was back to the SAME state as I was before. Tried rebooting, but that didn't help either.

Javier Jardón (jjardon) said : #3

Hello
Install 915resolution package:
type "sudo apt-get install 915resolution" in terminal

reboot and reconfigure your screen

Best Wladston Viana (wladston) said : #4

Javier,

Thanks!

I had tried that and it didn't work.

That forum topic solved my problem : http://ubuntuforums.org/showthread.php?t=351647

Javier, also, so you know where is the bug related to this issue ?