Cannot boot 7.04 LiveCD - SQUASHFS errors

Asked by John Williams on 2007-04-19

When I attempt to boot the live CD for 7.04 (and the beta) I am getting screen fulls of squashfs errors. Errors such as:

SQUASHFS error: sb_bread.....
SQUASHFS error: unable to read page.....
SQUASHFS error zlib_inflate returns unexpected error.....

The CD integrity check gives 5 errors in files.

I have checked the MD5Sum of the iso and it is OK.

When I try the CD using VMWare 5.5 on the same machine there are no problems. When I use the CD on other machines again no problems.

Knoppix and OpenSuse both work fine on the same machine and the CD/DVD drive works OK under WIndows 2000 and XP.

My machine is a Compaq using a ASUS A7N8X-LA motherborad, chipset nVidia nForce2 400 SPP/nVidia MCP-T.

Has anyone any suggestions as to what I can try next.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
John Williams
Solved:
2007-04-26
Last query:
2007-04-26
Last reply:
2007-04-20

If the integrity check fails then either the drive the cd or the iso is duff. You have discounted the iso, and the drive, so i would re-burn the disc at a lower speed.

John Williams (jr-williams) said : #2

Thanks for the suggestion The CD was burned at my lowest speed - X12. I also burned a CD (different supplier) on another machine but with the same results, it worked fine on other machines and VMWare but not when booting on my own machine.

I forgot to mention on my first post that 6.06 and 6.10 live CDs work OK.

Could there be some incompatibility between the 7.04 kernel and my motherboard?

Might be worth having a look through the bugs for the live cd system called casper:-

https://bugs.launchpad.net/ubuntu/+source/casper/+bugs

John Williams (jr-williams) said : #4

I've had a look at the bugs as suggested but can't find any that are relevant.

I have run the memory test just in case that could be the problem but it was fine.

I'm now about to upgrade my CD/DVD drive firmware in the vain hope it might make a difference.

What I don't understand is why would it run OK using VMWare but not when booting from restart! The VM is set up to use the physical CD/DVD drive.

Although I would rather run the LiveCD to check Ubuntu out first, is there any way I can dump the CD onto to the hard disc and boot from a floppy to install it?

You could try the netinst method?

http://archive.ubuntu.com/ubuntu/dists/feisty/main/installer-i386/20061102ubuntu26/images/netboot/mini.iso

Grab that ISO image (it's ~8MiB in size) and burn it to a CD. Maybe a smaller image will be less likely to trigger whatever the issue is?

Best John Williams (jr-williams) said : #6

I've solved my problem. I downloaded the Fedora live CD and got the same squashfs errors. After searching the WEB again for problems with squashfs I came across a reference to DMA. By supplying the boot time option:

ide=nodma

I got both the Ubuntu and Fedora live CDs to boot.

Thank you for you help.

eneth80 (eneth80) said : #7

sorry, where do you put the ide=nodma option?

You must put the ide=nodma at boot time. This means, in the same moment you select among the start options (start live, install, check cd for defects, and so on...). After you highlight the install option, I get a message like "press tab to edit the options", and you get the actual options that are going to be used. You should put the ide=nodma between them (sorry, I don't remember all of them, but I as I remember I added it after the last X=X option). So take this as a hint.

Anyway, just saw that it didn't work for me with Kubuntu 8.04.01... :-(

Felipe Martim (felipemartim) said : #9

try acpi=off

Unbelievably, it fixed all my squashfs problems, although I had some other problems during installation. My solution then, was to install Dapper and upgrade it.

You might want to take a look at this: https://help.ubuntu.com/community/SquashfsErrors

Damiano Venturin (damko) said : #11

I tried debian-live 5.0, ubuntu 9.04, knoppix V5 and V6. It's all the same.
It's surely a ide-related issue. infact if you try to boot connecting a iso file present on your filesystem, rather than from a real cd in a real ide drive, it works perfectly, you get the squash error only from ide cd-drives

Dam