Scratchbox issue: can file those .so file?

Asked by math

I use scratchbox2 to compile xorg for my arm engineering board. But it says some *.so files missed went I am making the xserver (configure goes well).

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Māris Fogels (mars) said :

Hi math,

This looks like a question better served by the Ubuntu group, so I've moved the question there. However, it may be better to ask in #scratchbox on, or check the Scratchbox mailing lists:

Hope this helps,


Revision history for this message
Best Caesar (shcaesar) said :

Hey math,

First, to compile xserver, you need to compile xorg-lib first. xserver depends on those *.so files generated when you compile xorg-lib. Thus, maybe you need to compile or recompile xorg-lib before you can go further.
After you have the xorg-lib compiled, login the scratchbox, check out if your have those *.so files under the directory /usr/lib. If not, they should be in /[your_prefix]/lib where "your_prefix" is the value of the parameter named "--prefix" you specified when you compile xorg-lib. You should find those *.so files there. In this case, make soft links from /usr/lib/*.so to /[your_prefix]/lib/*.so; this will make the compiler of your scratchbox found those *.so files. You need a script to do this efficiently.

Revision history for this message
math (sh-mathematics) said :

Thanks Caesar, that solved my question.