ntfs-config

Asked by Sebastian Geiger on 2007-04-18

I read in the Ubuntu forums that with installing the ntfs-config package i can easily enable/disable ntfs read/write support. yet it seams that i can not find the ntfs-config package.
also i tried to install the 3g-ntfs driver and fuse but i dont know how to configure these. (in the ubuntu reps i can not find the v.1.0 of the 3g-ntfs driver.

and a generall question:

why cant i find the lates versions of certain programms in the ubuntu repos even though i know they have already been released:
e.g. ubuntu still runs with open office 2.0 although 2.2 is out. or i cant find the 3g-ntfs driver v.1.0.
maybe im too much used to the windows world, but i really dont understand why its so difficult to update to a newer version when it has been released.

Best regards
Lanoxx

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Sebastian Geiger
Solved:
2007-04-18
Last query:
2007-04-18
Last reply:
2007-04-18
Ralph Janke (txwikinger) said : #1

Thanks for the question.

Not every new version of a particular package is backported to every ubuntu release available. OpenOffice 2.2 is i.e. in feisty, but will not be backported to dapper or edgy as far as I know.

All the packages and versions can be found here:

http://packages.ubuntu.com/

This gives you all packages containing ntfs

http://packages.ubuntu.com/cgi-bin/search_packages.pl?keywords=ntfs&searchon=names&subword=1&version=all&release=all

and here you can see the ntfs-config is available for feisty:

http://packages.ubuntu.com/cgi-bin/search_packages.pl?keywords=ntfs-config&searchon=names&subword=1&version=all&release=all

I hope this helps.

Best Sebastian Geiger (lanoxx) said : #2

this already helps quite a lot to understand the logic behind the packets. thanks very much.

what i still dont understand is why packages have to be backported and how complex that is?

Ralph Janke (txwikinger) said : #3

Because often they depend on functions in libraries that are non-existent in the library in the earlier release. Those in turn might need a newer kernel etc... So if you would backport certain packages, you end up almost with the new release of ubuntu anyway. That would just increase the workload with double testing etc. and not give a lot of benefits.

I hope that clarifies it a little.