Can't Install Printer Drivers

Asked by Fidelio on 2007-04-17

I've done this:
https://help.ubuntu.com/community/Ha...IP4200#preview

but with the ip2200 drivers as suggested.
But when i try to install the printer (system>admin>printing etc) I can't see the ip2200 driver.

When I ran alien on the rpm I got a warning message about skipping scripts (don't know what this means) but I appended --script to the command and ran alien again, and I didn't get the error when it created the deb.

If it makes any difference, my printer is actually an ip1600, but it is supposed to work with the ip2200 drivers. Anyway, I can't see the ip2200 drivers, so even if I had one, I wouldn't be able to use it.

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Massimo Forti
Solved:
2007-04-18
Last query:
2007-04-18
Last reply:
2007-04-18
Massimo Forti (slackwarelife) said : #1

in shell do:

wget http://software.canon-europe.com/files/soft24301/software/iP2200_Linux_260.tar.gz

tar -zxf iP2200_Linux_260.tar.gz

rm -f cnijfilter-common-2.60-1.src.rpm cnijfilter-ip2200-lprng-2.60-1.i386.rpm

sudo alien cnijfilter-common-2.60-1.i386.rpm
sudo alien cnijfilter-ip2200-2.60-1.i386.rpm

sudo dpkg -i cnijfilter-common_2.60-2_i386.deb
sudo dpkg -i cnijfilter-ip2200_2.60-2_i386.deb

After open the printing manager tool and search the new driver.

Thanks.

Massimo Forti (slackwarelife) said : #2

Soory I have forgotten this:

after all I have written before do:

sudo ln -s /usr/lib/libtiff.so.4 /usr/lib/libtiff.so.3

sudo ldconfig

sudo /etc/init.d/cupsys restart

These commands are present in the cannon guide.

Thanks

Fidelio (andysuttie) said : #3

Thanks for trying, but if you look at the link in my first post, you can see that I have done exactly that. I am still unable to select the ip2200 driver in the printing manager. It's just not listed.

Best Massimo Forti (slackwarelife) said : #4

Sorry.
If you go in to the /usr/share/cups/model direcotry, wich file you find it. If you have installed correctly the deb file you can find the canonip2200.ppd.
If you see this, when you are in the printig administrator tool you can click on the Install Driver button and than search this file in this directory.

Thanks

Fidelio (andysuttie) said : #5

Thanks slackwarelife, that solved my question.