Get a "Failed to fetch" message with some packages

Asked by Sebastian Bassi on 2007-04-17

I am using Ubuntu 6.10 and when I try to update or install some packages, I got this error:

W: Failed to fetch
http://ar.archive.ubuntu.com/ubuntu/pool/universe/e/eclipse/eclipse-platform_3.2.1-0ubuntu3_i386.deb
 403 Forbidden [IP: 91.189.88.31 80]

What is strange is that most packages download OK, but with some of then, I get this message. So I have pending securities updates since some of them can't be fetched from the server. In this case (eclipse-*) it was not an security update, it was a package that I wanted to install and I couldn't.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Sebastian Bassi
Solved:
2008-12-10
Last query:
2008-12-10
Last reply:
2008-12-09
Cesare Tirabassi (norsetto) said : #1

It is possible that the server you were trying to use was busy or unavailable. It looks ok now.

I agree with Cesare, probably a busy or offline server, if it was offline it should be back online by now, they are never off for great durations of time

Sebastian Bassi (sbassi) said : #3

This not seems to be the problem.
I tried today, 2 days after the day I reported this, and I got:

W: Failed to fetch http://ar.archive.ubuntu.com/ubuntu/pool/universe/e/eclipse/eclipse-platform_3.2.1-0ubuntu3_i386.deb
  403 Forbidden [IP: 91.189.89.6 80]

W: Failed to fetch http://ar.archive.ubuntu.com/ubuntu/pool/universe/e/eclipse/eclipse-source_3.2.1-0ubuntu3_i386.deb
  403 Forbidden [IP: 91.189.89.6 80]

Ralph Janke (txwikinger) said : #4

Did you update the list of packages in the repository?

You can do that either in your package manager, or on the aommand line with

sudo apt-get update

I hope this helps

Sebastian Bassi (sbassi) said : #5

I've just did it. Now most packages are downloading OK, but this 2 still have the same problem:

W: Failed to fetch http://ar.archive.ubuntu.com/ubuntu/pool/universe/e/eclipse/eclipse-platform_3.2.1-0ubuntu3_i386.deb
  403 Forbidden [IP: 91.189.89.6 80]

W: Failed to fetch http://ar.archive.ubuntu.com/ubuntu/pool/universe/e/eclipse/eclipse-source_3.2.1-0ubuntu3_i386.deb
  403 Forbidden [IP: 91.189.89.6 80]

So I have a new question: May I select a new server to download updates? I see there is an "ar" prefix in the download site, like as this server was made for Argentina (I am in Argentina), but I didn't request it, I would like to download from the same place most people do, I guess that a problem in an Argentine server would not be noted and corrected so fast as a problem in Ubuntu main server.

Best,
SB.

Scott Kitterman (kitterman) said : #6

That is the current version for Edgy, so I think trying a different mirror might be a good next step.

If you like, you can just remove the ar. from the URLs in your sources llist.

However, I can download that .deb file from here, so the ar. repository is not fundamentally broken.

Another option is to click on the http: link here:

http://ar.archive.ubuntu.com/ubuntu/pool/universe/e/eclipse/eclipse-source_3.2.1-0ubuntu3_i386.deb

Then once you've download that file you can install is using sudo dpkg -i eclipse-source_3.2.1-0ubuntu3_i386.deb

If that was the only problem file, all should be well. I'd retry a regular update first. I may be that there was a problem in the mirror and it's been corrected now.

Sebastian Bassi (sbassi) said : #7

I also have problem with this package, that doesn't have AR, so I don't know how to change repo for this:

W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/o/openoffice.org/openoffice.org-core_2.0.4-0ubuntu5_i386.deb
  403 Forbidden

Ketan (ketan9) said : #9

in your /etc/apt/apt.conf file, remove the line that mentions proxy.

remove the line "Acquire::http::Proxy "false";

Once removed, your problem will be gone forever. It took me 2 hours to figure this thing.

Ketan
http://www.eClassifieds4u.com - 100% Free Classifieds

@Sebastian Bassi: If this is now solved would you please come back to the page and mark it as 'solved'? Thanks.

Fhernd (fernd-ortiz) said : #11

Hi! Ketan, thanks for the answer. I followed your instructions and I got the solution. Bye!

Sebastian Bassi (sbassi) said : #12

It seems the problem was that I was behind a transparent proxy in my university that reject large download, that is why all large files provoked that error.
Thank you all.

Fabián Rodríguez (magicfab) said : #13

Just FYI 6.10 isn't supported since April this year, see:
https://wiki.ubuntu.com/Releases

mustafa (mustafaabuahmed) said : #14

I had also the same problem
please try to update Firefox in steps ....

may be this will helps

raghulrajan (raghulrajan) said : #15

Thanks to ketan. For a newbie like me. it was easy
raghul