Dbus + pam.d + Ldap + Ubuntu server

Asked by Massimo Forti on 2007-04-17

 I ubinto 10.4 I can not instaler of gaming's window. you can fair ubonto conpatible window's games

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Massimo Forti
Solved:
2007-04-17
Last query:
2007-04-17
Last reply:
2007-04-17
Kevin Kubasik (kkubasik) said : #1

Your in luck, there is a new tool being worked on called authrool built just so that this type of configuration is easier.

https://launchpad.net/ubuntu/feisty/+source/authtool

Its not finished yet, but I used it to authenticate against a LDAP server. So it might help.if not, heres the tut for it:

https://help.ubuntu.com/community/ActiveDirectoryHowto

Best Massimo Forti (slackwarelife) said : #2

I know the tool authtool, but I do not succeed to install it on Ubuntu 6,10 serveur edition. I have read also the ActiveDirectoryHowto document, but shaping the files common-account, common-auth, common-password and common-session as described in this document, the demon dbus does not work. In the net I have found of post in which users advised to modify the files in /etc/dbus-1/system.d, I try to modify hal.conf and networkmanager.conf for the notebooks that uses the wi-fi. but I'm not successful to resolve it. Hour I have the following configuration of files:

/etc/pam.d/common-account
account sufficient pam_unix.so
account required pam_ldap.so

/etc/pam.d/common-auth
auth sufficient pam_unix.so nullok_secure
auth requisite pam_ldap.so use_first_pass
auth optional pam_smbpass.so migrate

/etc/pam.d/common-password
password sufficient pam_unix.so nullok obscure min=4 max=8 md5
password requisite pam_ldap.so
password optional pam_smbpass.so nullok try_first_pass use_authtok

/etc/pam.d/common-session
session required pam_env.so readenv=1
session required pam_unix.so
session optional pam_ldap.so
session required pam_mkhomedir.so skel=/etc/skel/ umask=077
session optional pam_foreground.so

I have found this configuration on the net, it works fine, but I don't have all I want, infact if is possible I want to be able to change the passowrd of users using the gui tool in ubuntu desktop. Tody I have asked to do it to the users, but I have obtained to change the password only on the LDAP server, but not on the local machines.
I don't understand.

Thanks for any aid

chokri (chokri0007) said : #3

thx
and good luck