Wireless Card for 7.04

Asked by Meir Israelowitz on 2007-04-17

I upgrade from 6.10 to 7.04, and everything is o.k (I had to upgrade some files by hand, not problem), but when new network management and network management gnome when into place could not can not find the wireless card, which work with 6.04 and 6.10. I switch to Kwland and I try to use Wife radar, but nothing work, now the only way I can connect to the system is using dhcp.Using Wireless network drive and going to configure network, I see IP for the network card and Wireless, but I can not change anything. How I can fix the problem.

Meir

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Meir Israelowitz
Solved:
2007-04-29
Last query:
2007-04-29
Last reply:
2007-04-27

This question was reopened

TraceyLedbetter (concept10) said : #1

Is your wireless network card (or chipset) enabled?

Goto System > Administration > Network and see ensure your wireless networking card is enabled.
(and possibly configured for DHCP, if thats what you use)

I check, and Enable the card, In the password I have WEPkey, for configuration I set to Automatic configuration DHC. The card have IP Adress and subkmaks. The Kwland ask me for WPA Supplicant, I see diffrent methos not idea which one to use. I configure the DHCP and can run is sodu, but I can not get the land and wireless card working.

I just check using sudo vi /etc/network/interfaces, what i found is the :

auto lo
iface lo inet loopback

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp

auto eth1
iface eth1 inet static

the auto is lo. I need to change to eth0, any one have idea how to changes, I'm not sure what lo means.

Mackenzie Morgan (maco.m) said : #4

They're all auto...

The new network manager lets you do static or DHCP and will just pop up a box asking for the WEP or WPA password when you connect. There should be an applet for it in your notification area. Try using that instead of System > Admin > Networking. Does it work if you do that?

O.k I will like my problem from the moment after the upgrade. After upgrade 7.04 install Network manager and Network Manager Gnome, when I try to activate the Wireless Card, I can see green light from the Card trying to be activated, but in the end will said not network found. I had the Labtop in the Wireless Network , so I know the network working.

I when through the internet and the was suggestion using KWland and install, I had to uninstall Network manager and Network Gnome, since KWland works with DHCP.
When I did that and restart the system, I get IP address, but I can not activate anything, I try to activate from network and using Windows Wireless networks, but nothing happen.
The only way I can connect to network by hand just sudo dhcp eth0 and works, but I can't get to work the computer as was working with 6.10.

And I forgot when I try to us KWland, ask me which type of WPA Suplicant, which provides a lsit of type connections, and for sure I have not idea. I can get into the software, just after changes I can't activate anything. Even with KWland I have to activate DHCP by hand, I can't do that directly from the software.

Javier Jard贸n (jjardon) said : #7

Meir,

comment the /etc/network/interfaces file except lo: (this is need to networkmanager to work)

auto lo
 iface lo inet loopback
#auto eth2
 #iface eth2 inet dhcp
#auto ath0
 #iface ath0 inet dhcp
#auto wlan0
 #iface wlan0 inet dhcp
#auto eth1
# iface eth1 inet static

I have made the changes the you suggested and restart the computer, the next thing I did, I try to activate the network management and I can see the "Green light" of the Card try to start and after some time looking for the wireless network reverse to wire network and say can't find the wireless network. Using the Wireless Manager, said there is not network (I have Labtop running in the Wireless Network) and trying to use Wireless network Manager does not help either.

The Wireless Card I have, the same I sue for 6.06 and 6.10 is:
 Network controller: ADMtek ADM8211 802.11b Wireless Interface (rev 11)

I found more info about the Card in:

http://ndiswrapper.sourceforge.net/mediawiki/index.php/List

Card: 3COM #[3CRSHPW796], 11mbps [OfficeConnect Wireless CardBus] (rev 15)

    * Chipset: ADMTek ADM8211
    * pciid: 10b7:6000
    * Driver: 3CRSHPW796_29Sep03.exe from [1]
    * Other:Works fine on Toshiba Satellite 1410 SP-173 runing SuSE 9.2 (kernel 2.6.8-24-default), using the guide from this page, NdisWrapper 0.10-3. Note for wireless newbies (I'm on) deactivate the eth0 before config the wlan0 with Yast and after it restart!

The 7.04 has the same problems?

Looks the Wireless driver is not found I try to install:

 sudo apt-get install ndiswrapper-utils-1.8

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package ndiswrapper-utils-1.8

$ apt-cache search ndiswrapper-utils
ndiswrapper-utils-1.9 - Userspace utilities for the ndiswrapper linux kernel module

It's 1.9 now :)

Alan, thanks that help but I think found the problem, not idea hod to solve, so when I try to run:
sudo ndiswrapper -l
your_driver : invalid driver!
 and then when I try:

sudo iwconfig wlan0 essid "AP" key ababababababababab mode Managed
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlan0 ; No such device.

Javier Jard贸n (jjardon) said : #14

NetworkManager not support your card (http://live.gnome.org/NetworkManagerHardware)

You must configure your card manually in /etc/network/interfaces

if eth1 is your wireless card, put this in /etc/network/interfaces (not delete lo interface!):

auto eth1
iface eth1 inet dhcp

Javier Jard贸n (jjardon) said : #15

if eth1 is your wireless card, put this in /etc/network/interfaces (not delete lo interface!):

auto eth1
iface eth1 inet dhcp
wireless-essid <your essid>
wireless-key <your wep key>

Javier I have all that and I still get there is not a Wireless Card:

sudo ndiswrapper -lyour_driver : invalid driver!
 I check the network file:

#auto eth2
#iface eth2 inet dhcp

#auto ath0
#iface ath0 inet dhcp

#auto wlan0
#iface wlan0 inet dhcp

auto eth1
iface eth1 inet static

and ISP

Javier I change the iface eth1 inet static to dhcp not change, can not finf the Driver

Javier I check my network file and I relaized there is not
I have
auto eth1
and
iface eth1 inet dhcp
but not
wireless-essid
or
wireless-key s

another problem:
sudo ifconfig ra0 down
ra0: ERROR while getting interface flags: No such device

I try this:

 sudo iwlist wlan0 scan

and I get

wlan0 Scan completed :
          Cell 01 - Address: 00:12:BF:4B:6A:8F
                    ESSID:"WLAN"
                    Mode:Master
                    Frequency:2.462 GHz
                    Quality:0 Signal level:0 Noise level:0
                    Encryption key:off
                    Extra:tsf=00000011a77917b1
so why I can't see the network?

Javier Jard贸n (jjardon) said : #21

Remove ndiswrapper. Then put this in your /etc/network/interfaces:

auto wlan0
iface wlan0 inet dhcp
wireless-essid WLAN

Then in terminbal put: sudo ifup wlan0 to activate network card

2007/4/21, Meir Israelowitz <email address hidden>:
> Question #5130 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/5130
>
> Meir Israelowitz gave more information on the question:
> I try this:
>
> sudo iwlist wlan0 scan
>
> and I get
>
> wlan0 Scan completed :
> Cell 01 - Address: 00:12:BF:4B:6A:8F
> ESSID:"WLAN"
> Mode:Master
> Frequency:2.462 GHz
> Quality:0 Signal level:0 Noise level:0
> Encryption key:off
> Extra:tsf=00000011a77917b1
> so why I can't see the network?
>

o.k this what I got i return:

sudo ifup wlan0
wlanctl-ng: Operation not supported
Failed to enable the device, exitcode= 1 .
run-parts: /etc/network/if-pre-up.d/linux-wlan-ng-pre-up exited with return code 1
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/aa:00:04:00:0a:04
Sending on LPF/wlan0/aa:00:04:00:0a:04
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Javier thank you very much work, perfect I have conection.

Javier, the solution work, but in one point I loss the Wireless network, I try to look for the interface in the Wireless network manage is not there, after I try Manual congiguration, which ask me for my pass word, but does not appear, I use
sudo ifup wlan0
Password:
ifup: interface wlan0 already configured
 and then
lspci
 give me

00:0b.0 Network controller: ADMtek ADM8211 802.11b Wireless Interface (rev 11)

so the wireless card is there, but I can not start the wireless card.

Javier Jard贸n (jjardon) said : #25

type:

"sudo ifdown wlan0" to deactivate the card and then "sudo ifup wlan0"
to activate again

2007/4/22, Meir Israelowitz <email address hidden>:
> Question #5130 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/5130
>
> Status: Solved => Open
>
> Meir Israelowitz is still having a problem:
> Javier, the solution work, but in one point I loss the Wireless network, I try to look for the interface in the Wireless network manage is not there, after I try Manual congiguration, which ask me for my pass word, but does not appear, I use
> sudo ifup wlan0
> Password:
> ifup: interface wlan0 already configured
> and then
> lspci
> give me
>
> 00:0b.0 Network controller: ADMtek ADM8211 802.11b Wireless Interface
> (rev 11)
>
> so the wireless card is there, but I can not start the wireless card.
>

I get this message when I do both:

sudo ifup wlan0
wlanctl-ng: No such device
Failed to enable the device, exitcode= 1 .
run-parts: /etc/network/if-pre-up.d/linux-wlan-ng-pre-up exited with return code 1
wlan0: ERROR while getting interface flags: No such device
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlan0 ; No such device.
There is already a pid file /var/run/dhclient.wlan0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
SIOCSIFADDR: No such device
wlan0: ERROR while getting interface flags: No such device
wlan0: ERROR while getting interface flags: No such device
wmaster0: unknown hardware address type 801
Bind socket to interface: No such device
Failed to bring up wlan0.

and I try this too:

sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 IEEE 802.11b Frequency:2.412 GHz
          RTS thr:off Fragment thr=2346 B

eth1 IEEE 802.11b ESSID:""
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          RTS thr:off Fragment thr=2346 B
          Encryption key:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

vmnet1 no wireless extensions.

vmnet8 no wireless extensions.

Javier Jard贸n (jjardon) said : #28

Hello again ;-)

Deactivate card: "sudo idown wlan0"

Put this in your /etc/network/interfaces:
auto eth1
 iface eth1 inet dhcp
 wireless-essid WLAN

Then restart or put in terminal: "sudo ifup eth1" to activate network card

Javier, when I do lspci can see there is a card, so
00:0b.0 Network controller: ADMtek ADM8211 802.11b Wireless Interface (rev 11)
but the network manager is not seeing the wireless card.

I did the changes and I try:

1. sudo ifup eth1
ifup: interface eth1 already configured

2. sudo ifdown wlan1
ifdown: interface wlan1 not configured

Javier Jard贸n (jjardon) said : #31

sorry, type sudo idown eth1 and then sudo ifup eth1

When I do the first part I get this:

sudo: idown: command not found

Javier Jard贸n (jjardon) said : #33

Ops

sudo ifdown eth1
sudo ifup eth1

Still can't activate the card
1. sudo ifdown eth1
RTNETLINK answers: No such process
There is already a pid file /var/run/dhclient.eth1.pid with pid 15457
Fix use ifdown, but when I do sudo ifup eth1 nothing happen:

killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/eth1/00:e0:98:b3:3a:b1
Sending on LPF/eth1/00:e0:98:b3:3a:b1
Sending on Socket/fallback
DHCPRELEASE on eth1 to 192.168.2.1 port 67

2. sudo ifup eth1
There is already a pid file /var/run/dhclient.eth1.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/eth1/00:e0:98:b3:3a:b1
Sending on LPF/eth1/00:e0:98:b3:3a:b1
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Javier Jard贸n (jjardon) said : #35

type "iwlist scan"

I did that this what I get:

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning : Operation not supported

eth1 Scan completed :
          Cell 01 - Address: 00:12:BF:4B:6A:8F
                    ESSID:"WLAN"
                    Mode:Master
                    Frequency:2.462 GHz
                    Quality:0 Signal level:0 Noise level:0
                    Encryption key:off
                    Extra:tsf=00000028f73493b2

sit0 Interface doesn't support scanning.

vmnet1 Interface doesn't support scanning.

vmnet8 Interface doesn't support scanning.

Javier Jard贸n (jjardon) said : #37

Put this in your /etc/network/interfaces:

 auto eth1
 iface eth1 inet dhcp
 wireless-essid WLAN

put near your router and restart. This should work

I try again down and up

1. sudo ifdown eth1
RTNETLINK answers: No such process
There is already a pid file /var/run/dhclient.eth1.pid with pid 6137
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/eth1/00:e0:98:b3:3a:b1
Sending on LPF/eth1/00:e0:98:b3:3a:b1
Sending on Socket/fallback
DHCPRELEASE on eth1 to 192.168.2.1 port 67

2. sudo ifup eth1
There is already a pid file /var/run/dhclient.eth1.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/eth1/00:e0:98:b3:3a:b1
Sending on LPF/eth1/00:e0:98:b3:3a:b1
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 6
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
meir@Bakunin:~$

Thanks Javier Jard贸n, that solved my question.

I try again still the network manager does not have Wireless network activation card

I try again

sudo ifdown eth1
Password:
RTNETLINK answers: No such process
There is already a pid file /var/run/dhclient.eth1.pid with pid 6663
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/eth1/00:e0:98:b3:3a:b1
Sending on LPF/eth1/00:e0:98:b3:3a:b1
Sending on Socket/fallback
DHCPRELEASE on eth1 to 192.168.2.1 port 67
meir@Bakunin:~$ sudo ifdown eth1
ifdown: interface eth1 not configured

2. sudo iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning : Operation not supported

eth1 Interface doesn't support scanning : Network is down

sit0 Interface doesn't support scanning.

vmnet1 Interface doesn't support scanning.

vmnet8 Interface doesn't support scanning.

sudo ifup eth1
There is already a pid file /var/run/dhclient.eth1.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/eth1/00:e0:98:b3:3a:b1
Sending on LPF/eth1/00:e0:98:b3:3a:b1
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Maybe the network Manager version I have is corrupt.

I did changes in /etc/network/interfaces

and I did changes in

auto eth1
 iface eth1 inet dhcp
 wireless-essid WLAN

 and restart systesm, not change

Javier Jard贸n (jjardon) said : #45

Don't use network-manager, your card is not supported in this program
http://live.gnome.org/NetworkManagerHardware

Javier when I use 6.04 and 6.10 I had not problem with that, so why now is a issue

I found information about the Card of the other day and said is supported:

http://ndiswrapper.sourceforge.net/mediawiki/index.php/List

Card: 3COM #[3CRSHPW796], 11mbps [OfficeConnect Wireless CardBus] (rev 15)

    * Chipset: ADMTek ADM8211
    * pciid: 10b7:6000
    * Driver: 3CRSHPW796_29Sep03.exe from [1]
    * Other:Works fine on Toshiba Satellite 1410 SP-173 runing SuSE 9.2 (kernel 2.6.8-24-default), using the guide from this page, NdisWrapper 0.10-3. Note for wireless newbies (I'm on) deactivate the eth0 before config the wlan0 with Yast and after it restart!

Javier Jard贸n (jjardon) said : #48

The card work in ubuntu but not with network manager program, you need
to configure manually edit /etc/network/interfaces ot in System->Net

Javier the you have suggestion how to do that, manually is better for me, since I'm use to Unix commands

in the interface file I have this:

auto lo
iface lo inet loopback

#auto eth2
#iface eth2 inet dhcp

#auto ath0
#iface ath0 inet dhcp

auto eth1
 iface eth1 inet dhcp
 wireless essid WLAN

#auto eth1
#iface eth1 inet dhcp

and

        address <numbers>
 netmask <numbers>
 gateway

How I find the

wireless-key

Javier Jard贸n (jjardon) said : #52

is the WEP key of your network

Javier another question, what is the key if (just make sure I have the Wireless Card working) for open network, if move to open spot what will be that.

Javier can I use configure network file

up pkill dhclient ath0 && ifconfig ath0 down && ifconfig ath0 up && dhclient ath0

Javier Jard贸n (jjardon) said : #55

if the network is open it not have key ;-)

Javier, I think the problem is not with the configure file, one thing was when I lost the Wireless network connection, the Wireless Manager menu the WPA icon disappear

Javier Jard贸n (jjardon) said : #57

Your card work in ubuntu but not with network manager program (the icon you see in rifth corner), you need
 to configure manually your card editing /etc/network/interfaces or in System->Net

I do not have Net, how I can get the Net

System->Net

Javier Jard贸n (jjardon) said : #60

Sorry, my fault System-->Administration-->Networking. See
https://help.ubuntu.com/community/WifiDocs/WirelessNetworking

I check the System-->Administration-->Networking, and is not in the menu

Javier Jard贸n (jjardon) said : #62

do you use gnome or kde? if you use gnome -> you can view this
screenshot https://help.ubuntu.com/community/WifiDocs/WirelessNetworking

Well is not in my menu, how I can get the file with the Network

Javier Jard贸n (jjardon) said : #64

Install the gnome-system-tools package:

sudo apt-get install gnome-system-tools --reinstall

o.k now I can see the card, I try to run trough and wireless card is eth1 and only see eth0

sfil (sebastian-fladung) said : #66

Hallo, I麓ve got the same problem. I 麓ve got the network card "D-Link DWL 120+".
This card worked with Ubuntu 6.10 without any problems.

After the upgrade it doesn麓t work.
In the menue "System-->Administration-->Networking" is the interface wlan0 shown as "kabelgebundene Verbindung" => wired Connection (I run the german language). I could not set the essid and the key with the gui. The gui looks like the wired settings.
If I set the settings in the /etc/networking/interfaces - I get the error: "Error for wireless request "Set ESSID" (8B1A) :" ...

That is the problem I have now I change the sudo gedit /etc/network/interfaces
and I change the eth0 into eth1, but if you do that will start the networks and will not have IP address. What Javier say to me the cards are not supported by the Network manager so need to start manually. I have sunday the Wireless work, but the I lost the Network and also network. If you follow Javier told me to sudo apt-get install gnome-system-tools --reinstall, which work.

sfil (sebastian-fladung) said : #68

Hi, i have run "sudo apt-get install gnome-system-tools --reinstall" for some minutes. Nothing has changed.
It麓s interesting, if I run "iwlist scanning" the commandline shows "wlan0 Interface doesn麓t support scanning"
I think the driver is not supported correctly.

Try this, I try this Sunday work for 6 hours then nothing:

Remove ndiswrapper. Then put this in your /etc/network/interfaces:

auto wlan0
iface wlan0 inet dhcp
wireless-essid WLAN

you meay need the key from your network

sfil (sebastian-fladung) said : #71

@ meir I tried to change the /etc/network/interfaces with the settings
auto wlan0
iface wlan0 inet dhcp
wireless-essid ...
wireless-key ....
but i doesn麓t work

Try this first

Try this first sudo iwlist scan

I get this:

wlan0 Scan completed :
          Cell 01 - Address: 00:12:BF:4B:6A:8F
                    ESSID:"WLAN"
                    Mode:Master
                    Frequency:2.462 GHz
                    Quality:0 Signal level:0 Noise level:0
                    Encryption key:off
                    Extra:tsf=0000004d49a4b917

using sudo lshw
I get this:

network:0
             description: Wireless interface
             product: ADM8211 802.11b Wireless Interface
             vendor: ADMtek
             physical id: b
             bus info: pci@00:0b.0
             logical name: wmaster0
             version: 11
             serial: aa:00:04:00:0a:04
             width: 32 bits
             clock: 33MHz
             capabilities: bus_master cap_list logical wireless ethernet physical

Javier Jard贸n (jjardon) said : #76

Hello Meir,

Your card works now?

Well recognize the card, but does not activate, if I change the sudo gedit /etc/network/interfaces
to

auto eth0
iface eth0 inet dhcp
wireless-essid WLAN

restart the system, will go to wireless card but get not connection, if set back to eth1 file I'm back to wire connection.

The network setting have the wireless connection is wlan0 not wlan1

When I try this I get this answer:

sudo ifup wlan1
Password:
Ignoring unknown interface wlan1=wlan1.

Javier Jard贸n (jjardon) said : #80

iface eth0 inet dhcp --> this is your wired interface card

iface wlan0 inet dhcp --> this is yor wireless interface card
 wireless-essid WLAN

I did the changes and at least I can work wireless card, I can see is not light up and goes to the wire network:

auto lo
iface lo inet loopback

#auto eth0
#iface eth2 inet dhcp

#auto ath0
#iface ath0 inet dhcp
auto eth0
iface eth0 inet dhcp
iface wlan0 inet dhcp
wireless-essid WLAN

and when

 sudo ifup wlan0
wlanctl-ng: Operation not supported
Failed to enable the device, exitcode= 1 .
run-parts: /etc/network/if-pre-up.d/linux-wlan-ng-pre-up exited with return code 1
There is already a pid file /var/run/dhclient.wlan0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/aa:00:04:00:0a:04
Sending on LPF/wlan0/aa:00:04:00:0a:04
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

and when I
sudo iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning : Operation not supported

wlan0 Scan completed :
          Cell 01 - Address: 00:12:BF:4B:6A:8F
                    ESSID:"WLAN"
                    Mode:Master
                    Frequency:2.462 GHz
                    Quality:0 Signal level:0 Noise level:0
                    Encryption key:off
                    Extra:tsf=0000005d2a3ede77

sit0 Interface doesn't support scanning.

vmnet8 Interface doesn't support scanning.

vmnet1 Interface doesn't support scanning

sfil (sebastian-fladung) said : #82

root@gnudalf:/home/sfil# lshw
gnudalf
    description: Desktop Computer
    product: A7S8X-MX
    vendor: ASUSTek Computer INC.
    version: 1.xx
    serial: 123456789000
    width: 32 bits
    capabilities: smbios-2.3 dmi-2.3

....
 *-network
             description: Ethernet interface
             product: SiS900 PCI Fast Ethernet
             vendor: Silicon Integrated Systems [SiS]
             physical id: 4
             bus info: pci@00:04.0
             logical name: eth0
             version: 90
             serial: 00:13:d4:14:b5:2f
             size: 100MB/s
             capacity: 100MB/s
             width: 32 bits
             clock: 33MHz
             capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
             configuration: autonegotiation=on broadcast=yes driver=sis900 driverversion=v1.08.10 Apr. 2 2006 duplex=full ip=192.168.0.3 latency=32 link=yes maxlatency=11 mingnt=52 multicast=yes port=MII speed=100MB/s
             resources: ioport:c800-c8ff iomemory:eb003000-eb003fff irq:21
        *-ide:1
             description: IDE interface
             product: RAID bus controller 180 SATA/PATA [SiS]
             vendor: Silicon Integrated Systems [SiS]
             physical id: 5
             bus info: pci@00:05.0
             logical name: scsi0
             logical name: scsi1
             version: 01
             width: 32 bits
             clock: 66MHz
             capabilities: ide bus_master cap_list scsi-host
             configuration: driver=sata_sis latency=32
             resources: ioport:cc00-cc07 ioport:d000-d003 ioport:d400-d407 ioport:d800-d803 ioport:dc00-dc0f ioport:e000-e07f irq:22
  *-network
       description: Ethernet interface
       physical id: 1
       logical name: wlan0
       serial: 00:0d:88:e9:95:64
       capabilities: ethernet physical
       configuration: broadcast=yes multicast=yes

This is a nice command. Here you can see that my wlan0 is known as a "ethernet interface" and not as a "Wireless interface".

Javier suggested to add

iface wlan0 inet dhcp

sudo gedit /etc/network/interfaces
that help to a problem I had with the Wireless card and I use the Network Utility. I took out the networ manager, in nay case I have not IP for the wireless card, I think if I can fix that problem will solve the problem I had.

I try sudo dhcpcd wlan eth0, that should give in IP, but nothing happen.

Javier Jard贸n (jjardon) said : #84

Hello Meir,

if you want a manuall ip configuration, add this:

iface wlan0 inet static
address <ip_you_want>
netmask 255.255.255.0
wireless-essid WLAN

I have now IP address, but the Wireless Card is not activate even I do ifup wl

if I do:
sudo ifdown wlan0
RTNETLINK answers: No such process
There is already a pid file /var/run/dhclient.wlan0.pid with pid 6109
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/aa:00:04:00:0a:04
Sending on LPF/wlan0/aa:00:04:00:0a:04
Sending on Socket/fallback
DHCPRELEASE on wlan0 to 192.168.2.1 port 67
wlanctl-ng: Operation not supported

 sudo ifup wlan0
wlanctl-ng: Operation not supported
Failed to enable the device, exitcode= 1 .
run-parts: /etc/network/if-pre-up.d/linux-wlan-ng-pre-up exited with return code 1
There is already a pid file /var/run/dhclient.wlan0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/aa:00:04:00:0a:04
Sending on LPF/wlan0/aa:00:04:00:0a:04
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Javier, I think the only issue need to resolve is how I can find the IP address for the Wireless Card

Javier Jard贸n (jjardon) said : #89

Is your router configured to dhpc?
With ifconhfig command you can see the ip addres of your card

yes the router is configure dhpc

Javier Jard贸n (jjardon) said : #91

Get me the ouput of "ifconfig" command when do "sudo ifup wlan0"

 Link encap:Ethernet HWaddr 00:0D:61:B7:44:EF
          inet addr:<" IP Adress I Have> Bcast: <I Have> Mask:255.255.255.0
          inet6 addr: fe80::20d:61ff:feb7:44ef/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:7368 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5046 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9932557 (9.4 MiB) TX bytes:608389 (594.1 KiB)
          Interrupt:19

lo Link encap:Local Loopback
          inet addr:<I have> Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:130 errors:0 dropped:0 overruns:0 frame:0
          TX packets:130 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:7274 (7.1 KiB) TX bytes:7274 (7.1 KiB)

vmnet1 Link encap:Ethernet HWaddr 00:50:56:C0:00:01
          inet addr:<I have> Bcast:<I have> Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

vmnet8 Link encap:Ethernet HWaddr 00:50:56:C0:00:08
          inet addr:<I have> Bcast:<I Have> Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wlan0 Link encap:Ethernet HWaddr AA:00:04:00:0A:04
          inet addr:<I have> Bcast:<I have> Mask:255.255.255.0
          inet6 addr: fe80::a800:4ff:fe00:a04/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:91 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b) TX bytes:8843 (8.6 KiB)

wmaster0 Link encap:UNSPEC HWaddr AA-00-04-00-0A-04-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

sudo ifup wlan0
ifup: interface wlan0 already configured

Javier Jard贸n (jjardon) said : #94

Is your problem solved yet?

No, I can get not connection to the wireless card, if I do dhcp with out in address I can see when start the green light of the card start, but then nothing happen or the light showing connection. I try the System-Administration Network, whether I have in IP or DHCP I can't get the card working

Javier when I run only DHCP:

wlan0 Link encap:Ethernet HWaddr AA:00:04:00:0A:04
          inet6 addr: fe80::a800:4ff:fe00:a04/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:86 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b) TX bytes:10642 (10.3 KiB)

Javier Jard贸n (jjardon) said : #97

Don't can be connected to a wired and wireless network simultaniusly.
Deconfigure the ethernet car (wired) and the wireless card first
Configure you ethernet card not to start automaticaly
Restar and activate the wireless card again.

Question how you do this first:

1. How I can deconfigure the ethernet car (wired) and the wireless card first.

2. How I can Configure you ethernet card not to start automaticaly

Javier Jard贸n (jjardon) said : #99

Hello Meir,

You can do this in the Networking tool can be found by choosing from the menus System-->Administration-->Networking

Mark your ethernet card and deactivate it, only active your wireless card

Javier if I run the network in DHCP, the wireless activatio, the I need an IP address.

The reason I'm asking is because, this info I get:

wlan0 Link encap:Ethernet HWaddr AA:00:04:00:0A:04
          inet6 addr: fe80::a800:4ff:fe00:a04/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5342 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b) TX bytes:498636 (486.9 KiB)

Javier I have the Wireless Card working, I just want to make sure before I can say works. What I did first deinstall all the file with networks, and I kept network, then I have all in DHCP, reisntall Network Manager and Network Gnome only, restart the computer and work

Well The card is working, thank you Javier for all your help