W: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/c/cupsys/cupsys-common_1.3.7-1ubuntu3.1_all.deb Connection failed [IP: 91.189.88.40 80]

Asked by Pushpinder Singh on 2008-11-09

I am not able to install the cupsys update. Every time I launch the update manager the following message is displayed:

W: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/c/cupsys/cupsys-common_1.3.7-1ubuntu3.1_all.deb Connection failed [IP: 91.189.88.40 80]

This is happening since last 1 month. It is very irritating seeing the updates available icon in the panel everyday and not being able to do anything.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-11-16
Last reply:
2008-11-16
cubells (cubells) said : #1

Update your package list (Applications>Accessories>Terminal):

$ sudo uptitude update

and try again

$ sudo update-manager

Any problem?

cubells (cubells) said : #2

Sorry. The correct command is:

$ sudo aptitude update

Please first try to open the:
http://archive.ubuntu.com/ubuntu/pool/main/c/cupsys/cupsys-common_1.3.7-1ubuntu3.1_all.deb
using Firefox can you open it...?

If yes...

Open a Terminal from the menu Applications → Accessories → Terminal and type:
(when the system ask you a password give your user password, you will not see nothing when you type it, then press enter)

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get clean
sudo apt-get autoremove

Please report errors here.

Hope this helps

I tried all the steps suggested in your reply.

The download of the file starts but gets stuck at 30%..... then again the connection terminates. This is really frustrating. All other updates are installed fine, even big ones which are more than 2Mb.

Think I have to get a faster and more stable internet connection. Currently connecting using USB modem over CDMA network very low speed 159 kbps.

This looks like another quirk of using Linux on a laptop designed for MS-Windows.

Please try to disable ipv6...

Howto disable ipv6

Please use this official method to disable ipv6 https://help.ubuntu.com/community/WebBrowsingSlowIPv6IPv4

In short, open Applications → Accessories → Terminal and type

sudo sh -c 'echo blacklist ipv6 >> /etc/modprobe.d/blacklist.local'

give your user password when requested, you don't see nothing when you type it, then press enter.

The above command appends a line to the local blacklist configuration. The file will be created if it does not exist.

To restart your computer, type:

sudo reboot

HTH

Can you help with this problem?

Provide an answer of your own, or ask Pushpinder Singh for more information if necessary.

To post a message you must log in.