Ubuntu 8.10 upgrade 64bit PC screen freezes after login on boot up/reboot

Asked by Devinder on 2008-11-07

Just upgraded UBUNTU from 8.04 to 8.10 on my 64 bit PC. On boot up when I login, the desktop screen appears blank (no text, no icons). I tried to reboot in recovery mode also where I tried to repair broken packages by running dpkg but it fails . Tried to run ' dpkg --configure -a' but no success.

devinder

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Devinder
Solved:
Last query:
Last reply:
Revision history for this message
Devinder (devinderparmar) said :
#1

Above mentioned problem was encountered in all cases when I booted in following modes:
ubuntu 8.10 linux kernel 2.6.27-7-generic
ubuntu 8.10 linux kernel 2.6.24-21-generic
ubuntu 8.10 linux kernel 2.6.24-19-generic
ubuntu 8.10 linux kernel 2.6.22-14generic
ubuntu 8.10 linux kernel 2.6.20-16generic

I tried recovery modes also. I have been upgrading ubuntu right from feisty fawn onwards to gutsy gibbon, hardy heron . Only on this upgrade this problem started.

initially on upgrade when booted in 2.6.27-7- generic mode there was other error report. Last error among others was ' [0.454241] kernel panic - not syncing : VFS : unable to mount root fs on unknown-block (0,0).

Subsequently I booted in other modes. Login screen asking for username would appear, but username could not be typed in that.

Subsequently i booted in other modes in recovery mode and selected option ' dpkg repair broken dependencies'. This solved problem partially. I could boot in all modes upto login screen. Username could be typed but it would lead to a blank orange screen withou text or icons or menu bars. I again tried in recovery mode and selected option ' dpkg repair broken dependencies' but no further success. I am stuck up.
Devinder

Revision history for this message
Devinder (devinderparmar) said :
#2

When login screen appeared on boot up I started fail safe terminal session. Tried 'sudo apt-get update' which gave errors as reported earlier and ended with a message for running manually 'dpkg --configure -a'. I typed this time 'sudo dpkg --configure -a' which ran successfully. I exited the terminal and logged. Problem was solved. Again on restart it worked perfectly fine.