After upgrading ubuntu 8.10 dvd-rom missing

Asked by izzy200198 on 2008-11-02

I have a dualboot win xp and Ubuntu 8.04 PC. I upgraded to 8.10 via internet. After rebooting I noticed the cd/dvd drive is missing in ubuntu. Only showing hard drives. I rebooted and from the GRUB menu selected the previous kernal. cd/dvd shows and works just fine as before the upgrade. Rebooted again to new kernal and once again the cd/dvd player is missing. Anyone know how to resolve this? I'm stuck and will be forced to go back otherwise. thanks.

Joe

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
izzy200198
Solved:
2008-11-09
Last query:
2008-11-09
Last reply:
2008-11-07
Wim (launchpad-xs4all) said : #1

Izzy,

in both versions of Ubuntu, try this to give us more information:

start a terminal,
the enter those commands, and post the lines here

cat /etc/fstab <Enter>

cat /etc/mtab <Enter>

(reboot with the command
init 6 <Enter> )

izzy200198 (izzy200198) said : #2

changes since last post. i couldnt use computer without cd/dvd so i deleted partition and started over. knowing that i can install 8.04 with no problems i attempted to install or boot live cd 8.10. i get dropped to a busy box prompt which reads:

cp: cannot create /root/var/log: no such file or directory
mount: mounting /root/dev on /dev.static/dev failied. no such file or directory
mount: mounting /sys on /root/sys failed: no such file or directory
mount: mounting /proc on /root/proc failed. no such file or direcotry
target file system doesnt have /sbin/init
no init found. try passing init=bootarg

from initramfs if i type exiti get
kernel panic-not syning: attempted to kill init.

computer is then frozen and i have to kill the power.

What kills me is i can install hardy heron no problem at all. if i booted ibex on previous kernal it was fine also. all i can think is that a new bug was introduced in the new kernal upgrade.

izzy200198 (izzy200198) said : #3

Found the problem. I changed the jumper on my lite-on cd/dvd rom from slave to cable select. the cd rom was alone on its own ide cable. for whatever reason, 8.04 didnt seem to care. but 8.10 wants cable select in order to detect the cd rom.