Connecting to the internet

Asked by plymouthjp on 2008-10-30

I have just dowloaded ubuntu 8.10 and I am running it off a CD at the present moment in time before I go and install it on my hard disk. The problem I am having is that I am still not able to connect to the internet. I have been here before, about a month ago, with exactly the same problem but it was suggested I wait until the new version comes out as the problem could be due to my motherboard (Asus P5N32-SLI Premium). I have a dual boot system with Vista and Ubuntu. I know my internet connection is ok as it works fine in Vista. Any help would be greatly appreciated as I would like to be able to use Ubuntu to its fullest potential. Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
Last query:
Last reply:
Revision history for this message
Mark Rijckenberg (markrijckenberg) said :
#1

Hi,

Can you tell us the detailed name of the network card that you use to connect to the Internet? Is it wired or wireless?

Could you please send us the output of following commands?

sudo lshw -C network
sudo lsusb
dmesg|grep eth
dmesg|grep wifi
sudo lspci

Regards,

Mark

Revision history for this message
plymouthjp (jonathanperryman) said :
#2

Hi Mark,
I have a wired connection to a belkin router. The network card is with the motherboard but displays Asustek Computer MCP55 Ethernet when the network connection icon is pressed. Below I have listed the output from the various commands.

sudo: lshw-C: command not found
ubuntu@ubuntu:~$ sudo lshw -C network
  *-network:0
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:15:af:0b:a7:75
       capabilities: ethernet physical wireless
       configuration: broadcast=yes multicast=yes wireless=IEEE 802.11bg
  *-network:1 DISABLED
       description: Ethernet interface
       physical id: 2
       logical name: pan0
       serial: 2e:67:3d:fc:59:41
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes
ubuntu@ubuntu:~$ sudo lsusb
Bus 002 Device 008: ID 14aa:0226 AVerMedia (again) or C&E
Bus 002 Device 007: ID 045e:0039 Microsoft Corp. IntelliMouse Optical
Bus 002 Device 006: ID 05ac:0221 Apple, Inc. Keyboard (Aluminium) (ISO)
Bus 002 Device 005: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 002 Device 003: ID 05ac:1006 Apple, Inc. Hub in Aluminum Keyboard
Bus 002 Device 002: ID 058f:6377 Alcor Micro Corp. Multimedia Card Reader
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
ubuntu@ubuntu:~$ dmesglgrep eth
bash: dmesglgrep: command not found
ubuntu@ubuntu:~$ dmesg|grep eth
[ 1.768359] ACPI Error (psparse-0530): Method parse/execution failed [\_PR_.CPU0._PDC] (Node ffff88007e8045e0), AE_ALREADY_EXISTS
[ 1.768367] ACPI: Marking method _PDC as Serialized because of AE_ALREADY_EXISTS error
[ 6.593891] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.61.
[ 6.594362] forcedeth 0000:00:11.0: PCI INT A -> Link[APCH] -> GSI 23 (level, low) -> IRQ 23
[ 6.594367] forcedeth 0000:00:11.0: setting latency timer to 64
[ 7.112454] forcedeth 0000:00:11.0: ifname eth0, PHY OUI 0x5043 @ 1, addr 00:18:f3:d8:de:3f
[ 7.112458] forcedeth 0000:00:11.0: highdma csum vlan pwrctl mgmt timirq gbit lnktim msi desc-v3
[ 7.112942] forcedeth 0000:00:12.0: PCI INT A -> Link[AMC1] -> GSI 22 (level, low) -> IRQ 22
[ 7.112947] forcedeth 0000:00:12.0: setting latency timer to 64
[ 7.633428] forcedeth 0000:00:12.0: ifname eth1, PHY OUI 0x5043 @ 1, addr 00:18:f3:d8:e9:94
[ 7.633431] forcedeth 0000:00:12.0: highdma csum vlan pwrctl mgmt timirq gbit lnktim msi desc-v3
[ 10.718711] Driver 'sd' needs updating - please use bus_type methods
[ 10.896718] Driver 'sr' needs updating - please use bus_type methods
[ 74.879617] eth0: no link during initialization.
ubuntu@ubuntu:~$ dmesg|grep wifi
ubuntu@ubuntu:~$ sudo lspci
00:00.0 Host bridge: nVidia Corporation Device 0071 (rev c1)
00:00.1 RAM memory: nVidia Corporation Device 007f (rev a1)
00:00.2 RAM memory: nVidia Corporation Device 0075 (rev a1)
00:00.3 RAM memory: nVidia Corporation Device 006f (rev a1)
00:00.4 RAM memory: nVidia Corporation Device 00b4 (rev a1)
00:01.0 RAM memory: nVidia Corporation Device 0076 (rev a1)
00:01.1 RAM memory: nVidia Corporation Device 0078 (rev a1)
00:01.2 RAM memory: nVidia Corporation Device 0079 (rev a1)
00:01.3 RAM memory: nVidia Corporation Device 007a (rev a1)
00:01.4 RAM memory: nVidia Corporation Device 007b (rev a1)
00:01.5 RAM memory: nVidia Corporation Device 007c (rev a1)
00:01.6 RAM memory: nVidia Corporation Device 007d (rev a1)
00:02.0 PCI bridge: nVidia Corporation Device 007e (rev a2)
00:05.0 PCI bridge: nVidia Corporation Device 007e (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a1)
00:0a.0 ISA bridge: nVidia Corporation MCP55 LPC Bridge (rev a2)
00:0a.1 SMBus: nVidia Corporation MCP55 SMBus (rev a2)
00:0a.2 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a2)
00:0b.0 USB Controller: nVidia Corporation MCP55 USB Controller (rev a1)
00:0b.1 USB Controller: nVidia Corporation MCP55 USB Controller (rev a2)
00:0d.0 IDE interface: nVidia Corporation MCP55 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:0e.1 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:0e.2 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:0f.0 PCI bridge: nVidia Corporation MCP55 PCI bridge (rev a2)
00:0f.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
00:11.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)
00:12.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)
00:13.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:17.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:18.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
01:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GS] (rev a1)
02:00.0 Mass storage controller: Silicon Image, Inc. SiI 3132 Serial ATA Raid II Controller (rev 01)
03:0b.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306 Fire II IEEE 1394 OHCI Link Layer Controller (rev c0)
ubuntu@ubuntu:~$

Revision history for this message
Mark Rijckenberg (markrijckenberg) said :
#3

Hi,

OK, please send output of following commands (in the order below):

sudo rmmod forcedeth
sudo modprobe forcedeth msi=0 msix=0
sudo /etc/init.d/networking restart
sudo dhclient
ifconfig
ping google.com
sudo lshw -C network

Regards,

Mark

Revision history for this message
Mark Rijckenberg (markrijckenberg) said :
#4

Hi,

After digging a little deeper, I read that this is a known bug/regression that also occurred in Hardy Heron. It looks like a bug in the forcedeth driver, that is still not fixed. :-(

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/136836

Hope my previous list of commands will work as a workaround.

Regards,

Mark

Revision history for this message
plymouthjp (jonathanperryman) said :
#5

Thanks Mark,
After typing the top two commands, I finally have the Internet. As I have not yet installed 8.10 onto my computer, do i have to carry out these commands again with 8.04 that is installed on my computer?

Once again, Thanks

(Could you tell me what the top two commands actually do, as i have no idea)

Revision history for this message
Mark Rijckenberg (markrijckenberg) said :
#6

Hi,

See the remark from Stefan Bader on https://bugs.launchpad.net/ubuntu/+source/linux/+bug/136836 :

"Stefan Bader wrote on 2008-08-13: (permalink)

To get this settings permanent create (as root) /etc/modprobe.d/forcedeth (or update /etc/modprobe.d/config). Add the line:

options forcedeth msi=0 msix=0

and save. Then rebuild the initramfs with the command

sudo update-initramfs -u -k $(uname -r)

"

I believe you need to perform Stefan's Bader procedure in Ubuntu 8.04 and/or 8.10 in order to make the new network configuration change permanent, even after rebooting.

Regards,

Mark

Revision history for this message
Best Mark Rijckenberg (markrijckenberg) said :
#7

Hi,

The first two commands unload and then reload the forcedeth kernel module (read: forcedeth network driver) using non-standard networking options.

Regards,

Mark

Revision history for this message
plymouthjp (jonathanperryman) said :
#8

Thanks Mark Rijckenberg, that solved my question.

Revision history for this message
weixelgeist (gw-weixdach) said :
#9

Hi Mark,
i have the same problem as plymouthjip with the same motherboard (Asus P5N32-SLI Premium).
But the workaround does not work for me!
Any hints?