eeePC 2G Intrepid Ibex - Can't compile wireless driver

Asked by komputes

I'm using kernel 2.6.27-7-generic on an eeePC and it seems that unlike with previous versions of the kernel I am not able to compile the madwifi-hal- driver for the built-in Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

Instruction can be found here:

First I tried to do what the site said for Intrepid Ibex:

Wireless should work out-of-the-box with Ubuntu 8.10 Intrepid Ibex (as from kernel 2.6.27-1-generic). EeePC 900s (and possibly 701s) may still require "blacklist ath_pci" added to /etc/modprobe.d/blacklist" to enable wireless.

So I blacklisted the ath_pci module and rebooted. Still no wireless.

Then I went on with trying to compile the driver I got stuck at the make command:

$ make
Checking requirements... ok.
Checking kernel configuration... ok.
make -C /lib/modules/2.6.27-7-generic/build SUBDIRS=/home/komputes/eee/madwifi-hal- modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.27-7-generic'
  CC [M] /home/komputes/eee/madwifi-hal-
  CC [M] /home/komputes/eee/madwifi-hal-
  CC [M] /home/komputes/eee/madwifi-hal-
  CC [M] /home/komputes/eee/madwifi-hal-
  LD [M] /home/komputes/eee/madwifi-hal-
  CC [M] /home/komputes/eee/madwifi-hal-
cc1: warnings being treated as errors
/home/komputes/eee/madwifi-hal- In function 'ath_hal_lookup_register_name':
/home/komputes/eee/madwifi-hal- error: format not a string literal and no format arguments
make[3]: *** [/home/komputes/eee/madwifi-hal-] Error 1
make[2]: *** [/home/komputes/eee/madwifi-hal-] Error 2
make[1]: *** [_module_/home/komputes/eee/madwifi-hal-] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-7-generic'
make: *** [modules] Error 2

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Berry van der Linden
Last query:
Last reply:
Revision history for this message
Best Berry van der Linden (madberry) said :
Revision history for this message
komputes (komputes) said :

Thank you, this is not using the madwifi driver but the ath5k driver.
The instructions for Ubuntu 8.10 Intrepid Ibex have been updated on

Revision history for this message
komputes (komputes) said :

Thanks madberry, that solved my question.