Volume keys toggle bass, not master volume

Asked by Allard Hoeve on 2007-04-12

Since adding software mixing (for Skype) to my alsarc, my multimedia keys stopped working properly, both on my plantronics USB headset and on my multimedia keyboard.

The keys function properly and are mapped to volume up/down and mute as the are supposed to, but all the controls now function on the Bass Volume, not on the master volume or pcm volume. After some experimenting and deducing the problem, it seems to me that gnome just toggles the first control it sees:

allard@allard-laptop:~$ amixer scontrols
Simple mixer control 'Bass',0
Simple mixer control 'Bass Boost',0
Simple mixer control 'Treble',0
Simple mixer control 'PCM',0
Simple mixer control 'Mic',0
Simple mixer control 'Auto Gain Control',0
Simple mixer control 'Software',0
allard@allard-laptop:~$

The first control is the one getting toggled.

Please advise on how to change correct behaviour.

Thanks in advance for reading/ideas/help.

Regards,

Allard Hoeve

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-04-12
Last reply:
2008-12-20
Ruben Romero (huayra) said : #1

Hi!

I found an answer to that one yesterday.

Go to the settings -> sound -> Volume keys and choose (with Ctrl + mouseClick) all the controls you want the keys to control. I choose PCM + Headset and it worked like a chram.

Choose PCM and the other controls you want to override when using the volume keys and it wokrs!

Cheers!

R

Allard Hoeve (allard) said : #2

Are you talking KDE? I'm running edgy with Gnome 2.16.1. There's no 'settings' available to me, just System -> Preferences -> Sound, there's no keybinding available to me there.

Maybe I'm missing something though :)

Mike Dahlgren (dahlgren) said : #3

I believe that this could be because you are running edgy, and I think Ruban, is running Fiesty.

Tormod Volden (tormodvolden) said : #4

Right-click on the speaker icon in the upper right, choose Preferences.

Aldo Latino (aldolat) said : #5

@ Allard

I have had your problem and I solved in this way.
Write on a terminal:
gnome-sound-properties
At the bottom of the window highlight the channel you want to control via multimedia keys on your keyboard.
That's all. Hope I helped you.

Tormod Volden (tormodvolden) said : #6

Notice that "gnome-sound-properties" is what you get when you go to System -> Preferences -> Sound. The "Default Mixer Tracks" is the mixer control track that will be controlled by the volume keys on your computer. To choose which keyboard buttons you want to act like volume keys, go to System -> Preferences -> Keyboard Shortcuts.

Aldo Latino (aldolat) said : #7

@ Tormod
Yes, what you say is correct, but I confirm my tip.
On a clean Feisty installation I have found the volume control on my keyboard wrongly associated with the Treble control.
A simple way to fix this was to open the gnome-sound-properties and relink correctly the association.

Greg (ghornby) said : #8

I've got the same problem: the controls on my headset and keyboard control some sort of volume dial (a graphic pops up for this) but it in now way affects the volume coming out of my headset.

Under "Volume Control => Change Device to Headset" I can manually change the volume to my headset.

In "System=>Preferences=>Sound" (which is the same as gnome-sound-properties) I don't see a way to do change keyboard settings.
My top-level menu options are "Devices", "Sounds" and "System Beep".

"Devices" seems most promising, and at the bottom of the window/dialogue it says,
"Select the device and tracks to control with the keyboard. Use the Shift and Control keys to select multiple tracks if required."
I select Bass, Treble & PCM for my Plantronics Headset (this was Ruben's & Aldo's suggested fix) but again, when using my headset with Skype, adjusting the volume with either the keyboard or headset does nothing.

Suggestions?

Tormod Volden (tormodvolden) said : #9

> I don't see a way to do change keyboard settings.

See two post up: To choose which keyboard buttons you want to act like volume keys, go to System -> Preferences -> Keyboard Shortcuts.

Tormod Volden (tormodvolden) said : #10

> when using my headset with Skype, adjusting the volume with either the keyboard or headset does nothing.

Make sure you select the same device under Sound->Devices as you are using in Skype (for instance OSS vs ALSA).

Greg (ghornby) said : #11

Yep, I had gone through System -> Preferences -> Keyboard Shortcuts and got the volume keys on my keyboard (and headset) to control for Sound->Volumedown and Sound->Volumeup. When I use the keyboard keys for this (or the headset) and graphic pops up in the lower-middle part of my screen that shows some volume bar being adjusted. These keys (and headset) do control the volume that is sent to the speakers connected to my system, but don't do anything for the volume going to my headset. Note that there is only one set of Sound up/down options so it doesn't appear that this method will let me configure a way to control sound for the speakers and headset invidividually (which isn't an issue for me, but I thought I'd point it out).

Both Skype and System->Preferences->Sound are set to ALSA.

To summarize, I can control the volume coming out of the speakers using the keyboard or the controls on my headset but I cannot control the volume of my headset by either of these means. I can control the volume of my headset manually through the Volume Control panel when I right click on the sound icon on the top right of the screen.

Any idea how to get the headset buttons to control headset volume?

Greg (ghornby) said : #12

Yep, I had gone through System -> Preferences -> Keyboard Shortcuts and got the volume keys on my keyboard (and headset) to control for Sound->Volumedown and Sound->Volumeup. When I use the keyboard keys for this (or the headset) and graphic pops up in the lower-middle part of my screen that shows some volume bar being adjusted. These keys (and headset) do control the volume that is sent to the speakers connected to my system, but don't do anything for the volume going to my headset. Note that there is only one set of Sound up/down options so it doesn't appear that this method will let me configure a way to control sound for the speakers and headset invidividually (which isn't an issue for me, but I thought I'd point it out).

Both Skype and System->Preferences->Sound are set to ALSA.

To summarize, I can control the volume coming out of the speakers using the keyboard or the controls on my headset but I cannot control the volume of my headset by either of these means. I can control the volume of my headset manually through the Volume Control panel when I right click on the sound icon on the top right of the screen.

Any idea how to get the headset buttons to control headset volume?

Tormod Volden (tormodvolden) said : #13

If you leave the Volume Control panel (where you can adjust the headset volume) open while you press the volume buttons, the slider in the panel doesn't move?

This is possibly a bug. I see something similar if I try to set Default Mixer Track Device to my USB microphone, which has one "Microphone" entry. It is then the Microphone slider of the main audio card that gets modified when I press the volume keys. Actually, I can not (un)set the one without (un)setting the other. It's mixing up the Devices.

Greg, can you please file a bug? Please provide a screenshot where you show the setting in "Default Mixer Track Device", as well as the Volume Control panel. You should also give the information asked on https://help.ubuntu.com/community/DebuggingSoundProblems

Tormod Volden (tormodvolden) said : #14

Greg, you also have to give the ouptut from amixer -c 1 (where 1 corresponds to the second sound card, your headset).
You can also run gconf-editor and monitor the value of desktop/gnome/sound while you switch devices.

Greg (ghornby) said : #15

Ok, I posted a bug and its #116929:
https://bugs.launchpad.net/ubuntu/+bug/116929

Tormod Volden (tormodvolden) said : #16

Allard, do you still have any trouble with this?

mike (michael-rhynes1) said : #17

hi im new and i dont have any volume can someone please help me

Neil (neil-ghosh) said : #18

Let me summarize the solution
========================================

My Volume knob in Laptop was controlling the line in instead of the Master volume

I typed gnome-sound-properties in command line

under devices tab ..at the bottom default mixer devices
select master volume to control the same with the Knob/Multimedia keys

Thanks

Can you help with this problem?

Provide an answer of your own, or ask Allard Hoeve for more information if necessary.

To post a message you must log in.