My Windows XP partition type thinks it is Linux swap!

Asked by Tarek on 2007-04-12

Hi

When I'm in ubuntu, I can see all files and folders in 3 partitions 2 windows in addition to ubuntu. However, my PC can not boot from either of the 2 windows partitions where I get the can not find Autochk program... skipping Autochk!! then goes into an endless reboot sequence! I can see the c: drive if I use installation XP disk and choose recovery mode.

I checked the partition table in ubuntu terminal and it looks like this:

fdisk -l

Disk /dev/sda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 3365 27029331 82 Linux swap / Solaris
/dev/sda2 4024 4864 6755332+ 83 Linux
/dev/sda3 3366 4023 5285385 82 Linux swap / Solaris

Partition table entries are not in disk order

Which indicates that a change in ID and subsequently System has occurred!

I have run gparted and it sees things in a different light, as I don't know how to copy/paste the page I re-typed:

Partition Filesystem Mountpoint Size Used Unused Flags
/dev/sda1 ntfs /media/hda1 25.78 GiB 19.54 GiB 6.24 GiB boot
/dev/sda3 fat32 /media/hda3 5.04 GiB 3.78 GiB 1.26 GiB
/dev/sda2 ext3 / 6.44 GiB 3.91 GiB 2.53 GiB

Is there a way to change things back in order without losing data?

Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-04-12
Last reply:
2007-04-13
Ruben Romero (huayra) said : #1

Hi!

This seems strange.

try:

sudo umount /dev/sda1

and then do:

sudo mount /dev/sda1 /media/hda1

It should do the trick.

Good luck!

Best regards
Ruben

On 4/12/07, Tarek <email address hidden> wrote:
>
> New question #4923 on Ubuntu:
> https://answers.launchpad.net/ubuntu/+ticket/4923
>
> Hi
>
> When I'm in ubuntu, I can see all files and folders in 3 partitions 2
> windows in addition to ubuntu. However, my PC can not boot from either of
> the 2 windows partitions where I get the can not find Autochk program...
> skipping Autochk!! then goes into an endless reboot sequence! I can see the
> c: drive if I use installation XP disk and choose recovery mode.
>
> I checked the partition table in ubuntu terminal and it looks like this:
>
> fdisk -l
>
> Disk /dev/sda: 40.0 GB, 40007761920 bytes
> 255 heads, 63 sectors/track, 4864 cylinders
> Units = cylinders of 16065 * 512 = 8225280 bytes
>
> Device Boot Start End Blocks Id System
> /dev/sda1 * 1 3365 27029331 82 Linux swap /
> Solaris
> /dev/sda2 4024 4864 6755332+ 83 Linux
> /dev/sda3 3366 4023 5285385 82 Linux swap /
> Solaris
>
> Partition table entries are not in disk order
>
> Which indicates that a change in ID and subsequently System has occurred!
>
> I have run gparted and it sees things in a different light, as I don't
> know how to copy/paste the page I re-typed:
>
> Partition Filesystem Mountpoint
> Size Used Unused Flags
> /dev/sda1 ntfs /media/hda1 25.78 GiB 19.54 GiB
> 6.24 GiB boot
> /dev/sda3 fat32 /media/hda3 5.04 GiB 3.78 GiB
> 1.26 GiB
> /dev/sda2 ext3 / 6.44 GiB
> 3.91 GiB 2.53 GiB
>
>
> Is there a way to change things back in order without losing data?
>
> Thanks
>

Tarek (tarekjomaa) said : #2

Hi Ruben,

I have tried the unmount/mount but the only effect was for hda1 to disappear from places list in ubuntu so I rebooted and found it there..

fdisk -l and gparted have come up with same info as before and XP boot failed same way as before!

Would it be wise, is it possible, to simply change the type of the XP partitions?

Ruben Romero (huayra) said : #3

it should help, but the change must be done in fstab. Take a backup of fstab.

This thread should give you a hand:

http://www.psychocats.net/ubuntu/mountwindows

Try booting and accessing windows as normal under boot first. If that does not work take a look at the grub settings as well.

R

Tarek (tarekjomaa) said : #4

Ok, I had a look at my fstab:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda2
UUID=f7ee3fc0-7918-46e2-b5e1-84b659d0f182 / ext3 defaults,errors=remount-ro 0 1
# /dev/hda1
UUID=DC2409DC2409BB12 /media/hda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/hda3
UUID=1B33-0A00 /media/hda3 vfat defaults,utf8,umask=007,gid=46 0 1
/dev/hdb /media/cdrom0 udf,iso9660 user,noauto 0 0

What should I be doing with it? Note, in the example fdisk -l is showing the correct ID and system info while as mine is showing linux swap! Should I consider something like "cfdi t" to fix them?

Thanks

Tormod Volden (tormodvolden) said : #5

Windows has to believe it's booting from the first primary partition. Use the grub "map" and "hide" commands. See https://help.ubuntu.com/community/GrubHowto and the link at the bottom of that page.

You can change the ID displayed by fdisk by using the fdisk "t" command.

fdisk can also reorder your partion table (in x'pert mode) but be warned that the /dev/hdaX numbering might change. This should however not be a problem as long as you are using UUID in /etc/fstab and /boot/grub/menu.lst

Can you help with this problem?

Provide an answer of your own, or ask Tarek for more information if necessary.

To post a message you must log in.