install usbModem SAGEM 800 Wanadoo

Asked by Amadeo on 2007-04-11

I tray to install a usbADSLModem from Wanadoo: 'SAGEM F@st 800'
ANY one more had problems with it?.
Is perhaps a version problem?
Can change to ubuntu 6.10 solve it?

--- details: ----------
(build-essential, linux-headers-2.6.15-25-386 and make are instaled)
the driver fail on compilation 'make' + 'make install'
(Also fail on similar maner with 'eagle-usb' driver o 'ueagle.atm')
Error similar to: URB_XXXX_XX geting first time on Pxxx.c line 950
on line 950 in Pxxx.c realy is refered this macro, which must be (I think) included with line '#include main.h'

a aprox look to main.h: (I try to remenber because I h'nt connection there).

#if src_versoin <= linux-kernel(VERSION) (any thing similar to)
...
#else
...
#define URB_XXXX_XX USB_XXXX_XX
...
#endif
----------------------------------

Thank
Amadeo.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Amadeo
Solved:
2007-04-16
Last query:
2007-04-16
Last reply:
2007-04-13
Best Amadeo (amadeo) said : #2

Thanks Marco.

Problem solved.

I'he installed 'ueagle-arm' on Ubuntu 6.06, on way suggest in article refered by you.

The problem:
 After Try install 'eagle-usb-data' and 'eagle-data-utils' with Snaptic with 'Automatic config' without satisfactory result,
We must use 'Marcar para eliminar completamente', NOT ONLY 'Marcar para eliminar' (on Ubuntu.es)
After that, we can re-install with 'MANUAL CONFIG' without error.

In any case, I've installed driver 'ueagle-atm.1.3.1' + firmware 'ueagle-data-1.1.1' and it run now.

Thankx, amadeo.