Down arrow key doesn't work after upgrading to Intrepid

Asked by Matthew Paul Thomas on 2008-10-22

In Ubuntu 8.04, all my arrow keys worked fine. But after upgrading to Intrepid, the Down key has stopped working in any program (regardless of whether it's GTK, XUL, Qt, or OOo).

I'm using a MacBook rev3. Fn Down still activates Page Down as expected; it's just Down by itself that doesn't work.

What could be the problem?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Matthew Paul Thomas
Solved:
2008-10-23
Last query:
2008-10-23
Last reply:
Matthew Paul Thomas (mpt) said : #1

In Ubuntu 8.04, I had added this entry in .xmodmap made Command click simulate right-clicking:
    keycode 116 = Pointer_Button3

In an 8.04 update a month or two ago, this line stopped working and I had forgotten about it.

In Intrepid, keycode 116 has apparently been changed to represent the Down key rather than Command click. This is why, with that line in .xmodmap, pressing the Down key does not work.

Solution: remove the line from .xmodmap.

Underlying problem: Ubuntu expects people to be able to right-click but does not set up a working key combo for that purpose by default (bug 122962).

Luke Hoersten (lukehoersten) said : #2

Thanks for the bug report. I had this same problem and would never have remembered I did the same thing!

Pascal Polleunus (ppolleunus) said : #3

Thanks also.
For those who have also forgot where .xmodmap is located (like me ;-)), it's in you home directory. Don't forget also the one for root.
Some extra keywords for referencing: upgrade Ubuntu 8.10 keyboard MacBook Pro Santa Rosa

Ross Golder (ross-golder) said : #4

FWIW, in Intrepid, I used xev to figure out the keycodes and now I have the following ~/.xmodmap to map the two keys to the right of the space bar to the middle and right mouse buttons respectively...

keycode 134 = Pointer_Button2
keycode 104 = Pointer_Button3