trying to become ubuntero

Asked by Aureliano Gonzalez on 2007-04-09

Well I can't seem to find the answer to this.. I copy the contents of the email with the open pgp stuff into a file..do a gpg -d newfile and it gives me this:

gpg: can't open `newfile'
gpg: decrypt_message failed: file open error

I'm guessing it has something to do with permissions? I'm new to linux, but I tried with sudo as well and same thing...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Aureliano Gonzalez
Solved:
2007-04-09
Last query:
2007-04-09
Last reply:
2007-04-09
Ralph Janke (txwikinger) said : #1

Thanks for your question.

Can you show the permission of 'newfile' here please?

Thanks

Mackenzie Morgan (maco.m) said : #2

Try using the text encryption plugin in Gedit. You can enable it in Edit > Preferences > Plugins. It might require having seahorse installed. Seahorse is a neat little program (GUI) for managing/creating/syncing GPG keys.

Hello, thank you for your fast answers! I already solved it, I moved it to another directory and it worked from there. Must have been my fault, sorry for wasting your time, and thanks again.

Mike Toscano (moj0rising) said : #4

Hi. For future Googlers: This message often appears when the path to the file you give GPG does not contain a GPG/PGP encrypted file.

So if you type gpg -d ~/documents/encryptedfile.gpg but the file is actually in ~/files/encryptedfile.gpg, the messages, "gpg: can't open `newfile' gpg: decrypt_message failed: file open error" will appear. To resolve the issue, verify the path to your file and try again. No need to move the file as long as you type the right path to it and get the file name right.

A possible "fix" for this issue would be for GPG to have better error messages. Something like, "cannot access filename: No such file or directory" would do it.

Mike